Intel G2 SSD suttering on Win7

Sufu

[H]ard|Gawd
Joined
Sep 3, 2006
Messages
2,004
Hello fellow [H] members, I need some serious help before my SSD ends up in the bottom of a lake!

I recently bought the G2 80GB Intel SSD from newegg, and installed Win7 on it (let it install a new partition). Problem is I am getting a lot of stuttering every couple of min, lasting a few secs. It makes the computer unusable because even the sound stutters in and out :mad:

My Specs; eVGA 750i FTW, 4GB Corsair DDR2, XFX 8800GTS, Auzuntech Prelude, Win7 64bit. Bios is up to date (latest one is from 2008)

This is what I have tried so far:
Running with native windows drivers
Running with eVGA drivers
Disabled NCQ on eVGA drivers
Moved Pagefile to another drive
Disabled Prefetching
Disabled Superfetching
Re-installed Win7 2x times w/no change (re-partitioned each time).
Checked the drive came with the latest firmware (via Intel tool)
Installed older audio drivers (just checking..)
Installed latest Auzuntech sound drivers
AHCI enabled in BIOS (always has been)

I don't know what else to do, other than cut my losses and return the thing. Please help :(

Edit: HDTune graph:

 
Last edited:

Impulse

[H]F Junkie
Joined
Apr 5, 2001
Messages
10,232
Blatantly obvious but, you've checked that the Windows defragmenter isn't running on it by mistake right? You shouldn't need to but you could also try disabling the indexer... If you haven't, you could also try another SATA cable/port as well (ya never know how/when one could be damaged). I also saw a weird Q&A on CPU mag recently where they mentioned this really old option was causing conflicts with the X25-M specifically when it was sometimes enabled. Dunno why or how it became enabled, it's not by default AFAIK, but it's worth checking and unchecking it to cycle it as they mentioned that this solved some weird behavior they were seeing randomly during testing (of the X25-M).
 

Impulse

[H]F Junkie
Joined
Apr 5, 2001
Messages
10,232
Honestly, you shouldn't have to mess with even half of these tweaks (Search, indexing, etc.)... I'd look at some of the other stuff suggested or try to come up w/something more esoteric, maybe try it on a different mobo or a friend's PC, 'cuz the X25-M by itself shouldn't need a whole lot of tweaking in order to work properly.
 

bmg

Limp Gawd
Joined
Sep 15, 2000
Messages
865
You really should try standard IDE rather than AHCI if you haven't found the cause of the problem yet.
 

Lazn_Work

Supreme [H]ardness
Joined
May 30, 2001
Messages
5,618
Have you tried the latest nforce drivers (nVidia drivers) rather than the eVGA ones? I never trust MFG drivers when the originals are available.
 

Damar

Supreme [H]ardness
Joined
Jun 20, 2004
Messages
4,577
Honestly, you shouldn't have to mess with even half of these tweaks (Search, indexing, etc.)... I'd look at some of the other stuff suggested or try to come up w/something more esoteric, maybe try it on a different mobo or a friend's PC, 'cuz the X25-M by itself shouldn't need a whole lot of tweaking in order to work properly.
Per MS a lot of those settings should be disabled by default when Win 7 is installed, but for many people it doesn't seem to do it.

Good read here if anyone still hasn't seen it yet.

http://blogs.msdn.com/e7/archive/2009/05/05/support-and-q-a-for-solid-state-drives-and.aspx
 

Impulse

[H]F Junkie
Joined
Apr 5, 2001
Messages
10,232
Per MS a lot of those settings should be disabled by default when Win 7 is installed, but for many people it doesn't seem to do it.

Good read here if anyone still hasn't seen it yet.

http://blogs.msdn.com/e7/archive/2009/05/05/support-and-q-a-for-solid-state-drives-and.aspx
I've quoted that same article dozens of times on these boards myself, read it a bit more carefully...

It's not a lot of stuff that should be disabled by default under Win7, it's exactly two things, Superfetch and the defrag tool, period. They don't disable hibernate by default, they don't disable the page file, they don't disable prefetching, they don't disable indexing nor Search, etc.etc. You should leave all that stuff alone unless you have a really valid reason to mess with it, as Windows tends to manage it all pretty well.

The only one that I think there's even a valid reason to mess with is hibernate. If you have 8-12GB of RAM the hibernation file (which saves the state of all your RAM) is obviously gonna be equally large, and it'll eat a good chunk of a small SSD, and with 4GB or less I'd keep it ('specially on laptops) as a matter of convenience... It's nice being able to hibernate with a dozen windows/tabs/etc open and come back to it all re-opening in 5s or less.
 

bmg

Limp Gawd
Joined
Sep 15, 2000
Messages
865
I've quoted that same article dozens of times on these boards myself, read it a bit more carefully...

It's not a lot of stuff that should be disabled by default under Win7, it's exactly two things, Superfetch and the defrag tool, period. They don't disable hibernate by default, they don't disable the page file, they don't disable prefetching, they don't disable indexing nor Search, etc.etc. You should leave all that stuff alone unless you have a really valid reason to mess with it, as Windows tends to manage it all pretty well.

The only one that I think there's even a valid reason to mess with is hibernate. If you have 8-12GB of RAM the hibernation file (which saves the state of all your RAM) is obviously gonna be equally large, and it'll eat a good chunk of a small SSD, and with 4GB or less I'd keep it ('specially on laptops) as a matter of convenience... It's nice being able to hibernate with a dozen windows/tabs/etc open and come back to it all re-opening in 5s or less.

From: http://blogs.msdn.com/e7/archive/2009/05/05/support-and-q-a-for-solid-state-drives-and.aspx

"By default, Windows 7 will disable Superfetch, ReadyBoost, as well as boot and application launch prefetching on SSDs with good random read, random write and flush performance. These technologies were all designed to improve performance on traditional HDDs, where random read performance could easily be a major bottleneck. See the FAQ section for more details."
 

TechHead

2[H]4U
Joined
Oct 12, 2001
Messages
3,870
Try running without the Auzentech? X-Fi + NfORCE chipset... Do they still have issues?
Posted via [H] Mobile Device
 

Sufu

[H]ard|Gawd
Joined
Sep 3, 2006
Messages
2,004
Try running without the Auzentech? X-Fi + NfORCE chipset... Do they still have issues?
Posted via [H] Mobile Device
Not sure how I could remove the nForce chipset off my Mobo :confused:

In any case, I also tried to disable drive cache but that ddn't make a difference sadly. It's weird because it was working fine for two days...I am gonna try a different port as a last resort, but it seems the only hope is to get a X58 mobo and Core i5...

As good excuse as any to upgrade!
 

bmg

Limp Gawd
Joined
Sep 15, 2000
Messages
865
Not sure how I could remove the nForce chipset off my Mobo :confused:

In any case, I also tried to disable drive cache but that ddn't make a difference sadly. It's weird because it was working fine for two days...I am gonna try a different port as a last resort, but it seems the only hope is to get a X58 mobo and Core i5...

As good excuse as any to upgrade!
Tried switching from AHCI to IDE yet?
 

Syntax Error

2[H]4U
Joined
Jan 14, 2008
Messages
2,642
Nvidia chipset? You could try an Intel ICH10R or something but I don't know if that's the cause of the problem. I'm usually pretty apprehensive about Nvidia southbridges, especially in RAID.
 

Sufu

[H]ard|Gawd
Joined
Sep 3, 2006
Messages
2,004
Tried switching from AHCI to IDE yet?
I never saw an option to switch from AHCI to IDE in Bios. I tried enabling all the IDE features I could find but it was still running in AHCI under Win7. So far it seems my Nforce mobo hates my Intel SSD, because if I run Win7 on my WD RaptorX everything is back to normal.
 

echn111

[H]ard|Gawd
Joined
Jan 30, 2007
Messages
1,069
Try it like a standard user with no tweaks at all. Note that on Win7 defrag is not disabled explicitly which is why some people think you need to disable it, but doesn't defrag your SSD. Try it like a normal user would use it - just connect it and don't try anything fancy.

If that doesn't work, perform a full erase using something like HDD Erase to refresh to it's original condition. I had some problems when I accidently formatted my SSD (as in a full format, not a quick format), and wiping it fixed it.
 

Sufu

[H]ard|Gawd
Joined
Sep 3, 2006
Messages
2,004
Try it like a standard user with no tweaks at all. Note that on Win7 defrag is not disabled explicitly which is why some people think you need to disable it, but doesn't defrag your SSD. Try it like a normal user would use it - just connect it and don't try anything fancy.

If that doesn't work, perform a full erase using something like HDD Erase to refresh to it's original condition. I had some problems when I accidently formatted my SSD (as in a full format, not a quick format), and wiping it fixed it.
That's actually the first thing I did when I got my SSD. I popped in my Win7 DVD, let it partition the drive and do it's thing. I went about installing my drivers when I started noticing the occassional sutters/freezes that last for like 1sec, but happen quite often. Like once every few min...

Once I put in my audio drivers, whenever I would play a movie (either from a diff HDD or online, or even just streaming audio from my PS3), the sound would stutter and you would hear these loud pops.
I tried re-formatting and installed Windows from a different DVD that I just burned, just incase...Same thing happened, even after I tweaked every possible little thing I could find.

I have the latest BIOS for my mobo, and firmware for my SSD. It leads me to think that this crappy NForce chipset does not get along with SSDs.
 

echn111

[H]ard|Gawd
Joined
Jan 30, 2007
Messages
1,069
Re-formating is not what I said. Formatting the SSD caused my initial problem. The solution was to "wipe" it back to it's orginal state (not format it yet again) and at this stage, I highly recommend you consider this.

(Also, what makes you think the sound stuttering is due to the SSD?)
 

Sufu

[H]ard|Gawd
Joined
Sep 3, 2006
Messages
2,004
(Also, what makes you think the sound stuttering is due to the SSD?)
Because it doesn't happen when Win7 is on my WD Raptor. The only thing that changed when this started happening, was the SSD HDD.
 

DiscreteMeat

Limp Gawd
Joined
Sep 4, 2009
Messages
150
Note that on Win7 defrag is not disabled explicitly which is why some people think you need to disable it, but doesn't defrag your SSD.
In Advanced Tools under Open Disk Defragmenter; it states scheduled defragmentation is turned ON. However, it also states my SSD has never been defragmented. Does this indicate that Windows 7 knows not to defrag my SSD or should I turn this feature off just to be safe?
 

lowteckh

Supreme [H]ardness
Joined
Jul 23, 2008
Messages
5,073
In Advanced Tools under Open Disk Defragmenter; it states scheduled defragmentation is turned ON. However, it also states my SSD has never been defragmented. Does this indicate that Windows 7 knows not to defrag my SSD or should I turn this feature off just to be safe?
Probably cuz you turned your computer off before the scheduled time. Turn it off.
 

Sufu

[H]ard|Gawd
Joined
Sep 3, 2006
Messages
2,004
Where do I find HDDErase? I broke down and bought a Core i7 rig minus VGA from newegg (waiting on stupid waterblock adaptor for my D-Tek Fuzion, even though newegg already delivered all my parts in 24hrs o_o)
 

DiscreteMeat

Limp Gawd
Joined
Sep 4, 2009
Messages
150
Probably cuz you turned your computer off before the scheduled time. Turn it off.
Perhaps, but I don't think so. I have a second HDD in my system and it shows it was last defragmented on 09/02 at 3:00 AM. I installed my SSD prior to that date. That means my system was indeed ON during a scheduled defrag, (yet my SSD was not automatically defragmented). To be on the safe side I now have it disabled. But it appears that Windows 7 knew to disregard my SSD when it performed the scheduled maintenance. :)
 

TalynOne

n00b
Joined
Sep 9, 2009
Messages
12

Sufu

[H]ard|Gawd
Joined
Sep 3, 2006
Messages
2,004
Google came up with nothing?

You can get the latest verison of HDDErase here:
http://cmrr.ucsd.edu/people/Hughes/SecureErase.shtml

Hardware compatibility for HDDErase is pretty mediocre, and didn't work on the three motherboards I have around me. I instead used hdparm from an Ubuntu 9.04 live cd running from a flash drive:
http://ata.wiki.kernel.org/index.php/ATA_Secure_Erase
No - just too many results and I wasn't sure how writing over all sectors on your HDD would return the drive back to the factory state.
 

xpavement

n00b
Joined
May 9, 2005
Messages
23
Try turning off TRIM in Win7:

From an admin command prompt:

fsutil behavior set DisableDeleteNotify 1

To turn it back on substitute 1 with a 0

This has helped others using OCZ Vertex SSDs in windows 7 with the same stuttering issues, so not sure if this applies to Intel drives, but worth a shot before wiping the drive.
 

TalynOne

n00b
Joined
Sep 9, 2009
Messages
12
No - just too many results and I wasn't sure how writing over all sectors on your HDD would return the drive back to the factory state.
Applying a Secure Erase across the drive isn't the same as writing 0's across the drive or formating the drive. A secure erase marks each SSD cell as empty. Read up on TRIM:

http://en.wikipedia.org/wiki/TRIM_(SSD_command)

to find out why a deleted or written to SSD cell isn't the same as an empty cell when it comes to write performance.
 

Iching

[H]ard|Gawd
Joined
Nov 29, 2008
Messages
1,820
Take one of your ram sticks out and see if that helps. Them, swap and check the other one... If stuttering continues after all those remedies above I would return the SSD.
 

bmg

Limp Gawd
Joined
Sep 15, 2000
Messages
865
Take one of your ram sticks out and see if that helps. Them, swap and check the other one... If stuttering continues after all those remedies above I would return the SSD.
I can't imagine what that's going to do unless one of the ram sticks is bad, and that seems unlikely unless the ram's being pushed to it's limits. Switching to IDE instead of AHCI has helped some people, but the original poster doesn't seem inclined to do that. Also, as was recently mentioned, use fsutil to turn off Trim. That makes a difference for some people even when their SSD doesn't support Trim. It's enabled by default in Win7. Try power settings to max performance if it's not that way already.
 

Sufu

[H]ard|Gawd
Joined
Sep 3, 2006
Messages
2,004
thanks for all the help. I already have a X58 and Core i7 920 here so I will be testing the drive on a different system. I honestly think it's more to do with the stupid Nforce controller than anything else.

And as far as memory goes - Win7 runs fine on my RaptorX, but runs like shit on my Intel SSD. I think that rules out bad memory? It's not overclocked at all. I will also have to try to see if turning off TRIM makes a difference on my evga 750i, ill check tomorrow.
 

skindogg

Limp Gawd
Joined
Jun 29, 2005
Messages
445
I setup my Intel G2 SSD a couple weeks ago and have the following settings:

SATA mode IDE in bios
Set superfetch and prefetch to 0
Disabled hibernate (powercfg -h off)
Disabled scheduled defrag
Disabled Indexing on that drive
Made swapfile static.

I haven't had any stuttering problems, but I have noticed that even though in the power settings I don't let the HD go to sleep, if i'm away for long enough, it will take a minute for Windows to become responsive again. I don't know if the firmware is TRIMming or what is going on.

Also when I installed Win7 RTM, it didn't seem to change settings for SSDs automatically. It had prefetch and superfetch set to 3. So i'm wondering if it's aligned correctly as well.

I did run the performance index, and it came out to 7.1, so the speed is there.
 

Lateralus

More [H]uman than Human
Joined
Aug 7, 2004
Messages
15,547
I setup my Intel G2 SSD a couple weeks ago and have the following settings:

SATA mode IDE in bios
Set superfetch and prefetch to 0
Disabled hibernate (powercfg -h off)
Disabled scheduled defrag
Disabled Indexing on that drive
Made swapfile static.

I haven't had any stuttering problems, but I have noticed that even though in the power settings I don't let the HD go to sleep, if i'm away for long enough, it will take a minute for Windows to become responsive again. I don't know if the firmware is TRIMming or what is going on.

Also when I installed Win7 RTM, it didn't seem to change settings for SSDs automatically. It had prefetch and superfetch set to 3. So i'm wondering if it's aligned correctly as well.

I did run the performance index, and it came out to 7.1, so the speed is there.
Overall, how do you like it compared to the Raptor? Got my G2 on Tuesday but haven't been able to install it yet. I'll be coming from a VR -- just wondering what to expect. :cool:
 

skindogg

Limp Gawd
Joined
Jun 29, 2005
Messages
445
I'm just running Win7 and gaming with it. There's a bit of difference in loading bigger games like UT3 and BF2, a few secs here and there. It's definitely much quieter, which is nice since my comp is in the living room now.

I also setup a 2GB ramdisk for IE and FF cache as well as temp files. That's probably making a bigger difference than anything. I never had it before the SSD, so it's a combination effect.
 

Impulse

[H]F Junkie
Joined
Apr 5, 2001
Messages
10,232
Having a ramdisk for temp files when you have a SSD seems redundant/overkill... I mean, that's the reason MS disables Superfetch to an extent. Unless you're super concerned with it's longevity (not an issue for the vast majority imo). Some people also see better performance with AHCI.

Anyway, if you're concerned with whether Win7 recognized it and properly aligned the partition, it's not hard to check... It can have a big impact on performance (as much as 30%), but chances are the setup didn't mess that up.
 
Top