HP SAS Expander Owner's Thread

pgjensen

Limp Gawd
Joined
Apr 20, 2006
Messages
342
I have a P410 with 6.64 FW, an HP SAS 6G expander with 2.06 FW, and an HP SAS 12G expander with 4.21 FW. I was able to get the 12G upgraded from 4.21 to 4.22 using the P410. I'm having compatibility issues with the 12G and my Areca 1883 cards, so I am reverting back to the 6G card, but I want to update the FW. No matter what I do, the P410 cannot find the 6G expander card. I tried just port 8 to one of the two ports on the P410. Then both ports 8 and 9 to the two on the P410. Still nothing, no device found during discovery of the 2.10 FW upgrade in Linux. lsscsi shows the P410 card the same as it did when the 12G updated (the 6G and 12G never show up in lsscsi for me, only the P410). Any ideas on how to get this upgraded? My main purpose is to see if I get better SATA 3.0 connections on my WD 10tb drives (some do connect at 3.0 but most connect at 1.5).
 

Operations

n00b
Joined
Mar 11, 2019
Messages
45
I also use the HP expander with an Areca 1882. But SATA300 is too slow for 2020... right :) So which Expander card does 6G/12G and is affordable?
 
Last edited:

ClintE

Limp Gawd
Joined
Mar 27, 2006
Messages
131
I also use the HP expander with an Areca 1882. But SATA300 is too slow for 2020... right :) So which Expander card does 6G/12G and is affordable?
Depends on how you're using your server. With some systems, such as unRAID, most people use SSD for cache writes and then dump the cache to spinning drives overnight. Things that need fast read speeds are kept on the SSD cache.

Cheers!
 

mwroobel

Supreme [H]ardness
Joined
Jul 24, 2008
Messages
5,001
I also use the HP expander with an Areca 1882. But SATA300 is too slow for 2020... right :) So which Expander card does 6G/12G and is affordable?
As long as you are using spinners, it is more than enough. If you are using SSDs then it would be a good idea to upgrade. Just remember if you move to a 12G SAS expander you also need to upgrade your HBA and devices to 12G to get end-to-end throughput Increasesto 12G. If you just hang a 12G expander on your existing 1882 with SATA drives you will see NO increase in speed.
 

bigo93

n00b
Joined
Mar 8, 2020
Messages
2
Hi new to forums and looks like I'm pretty late to the party.
For the last couple of weeks I've been trying to get this working, but have no idea what I'm doing

Got a HP G1610T Gen8 microserver.
Want to add more than 4 drives using a HP SAS Expander card (Green PCB).

I've tried the following cards in my server
1) P222 Raid Controller - FW 8.32 - Set to HBA mode
2) LSI SAS9207-8E - FW P20 - Set to IT mode (BIOS is set to one iteration older as it gave red screen)

And in an old PC case I have an old motherboard with a HP 24 Bay SAS Expander card and currently 3 hdds installed for quick testing

And theses are connected using a SFF8088 - SFF8088 cable

Not sure what firmware the SAS Expander is on, not sure how to check that.
I have just found a place to get the Gen8.1 Service Pack
Downloaded the SAS Expander firmware, I assume this is right one,
https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_07e17cded9e8409ea4b9d7ea74

Placed it into the SPP usb in /hp/swpackages
Ran in firmware update, now it detect the additional component.
But when it comes to selecting which updates I want to install. The SAS firmware isnt listed at all

Now these 59 pages is a lot to read.
I have a HP server, so shouldnt it update?
Or do I have to use a SFF8087 cable and connect to the internal port of my P222 card, to Port 9C on the SAS Expander in order for this to upgrade?
Or will I have to do it the Linux Terminal way?

With the SAS Expander, my server does not detect any drives at all!

The closest I have got is replacing the SAS Expander with one of these cards
https://www.ebay.co.uk/itm/2-Ports-...465615?hash=item2165c7110f:g:b38AAOSwukRcxWWs

But for some reason only 2 of the drives are being detected.
I've swapped the SFF8087-SATA cables with a different one.
But still, only 2 drives being detected.
Doesnt matter if I use the P222 or LSI card. Same thing.

Help?

----------
edit 1

So now trying to update the sas via ubuntu
But still the sas is not detected.
Using the terminal command lsscsi -H, it shows the 4 drives in the server, then [4] mpt2sas
Which I assume is the LSI card.
So why isnt it showing up?

---------
edit 2

Got a 8087-8087 cable
Plugged one end into the internal P222 port
Other end into Port 8C on SAS
Ran Ubuntu Linux Terminal, still only pickin up the P222, wont show the SAS

Tried again with SPP firmware update, still wont include the update in list in Step 2 Review

So how do I update the card if I cant do it either way here???
 
Last edited:

WestSidaz

Limp Gawd
Joined
Jan 13, 2011
Messages
214
Personaly i have 2-3 connected LSI 9211 cards + 4 x HP SAS Expanders connected and never had any issues and if needed.. easily fixed in bios..
 

bigo93

n00b
Joined
Mar 8, 2020
Messages
2
I'm at a complete loss.
I've mixed and matched the 2 cards in my server,
how the sas is connected to the server
even mixed and matched different cables and ports.

I just cant get my sas expander to work, de detected in linux terminal, update or even check what firmware its on....
Even removed the server board from main unit so I could attach sas expander directly to server. Still cant detect or update.

Nor any idea why the adaptor I linked in previous post only detects 2 drives.
And only with cables P2 and P3
Doesnt matter which post I use in the adaptor, or even use a different cable..... :/

Update:
So now even bought a P410 Controller, which should be compatible with this sas
Still not being detected....

---------

Edit


FINALLY! Got it working!!!!!

Created a post on reddit and got a reply from user skels130
"According to my research, many, if not most, motherboards will not power a paid device without a CPU."

I bought a PCI-E Rise board, the ones people use for bitcoin mining with multiple GPUs
And it worked!


Also easy way to tell if the SAS Expander will work in your motherboard is:
Turn it on.
If LED R6 is remains Solid Green permanently then your motherboards isnt powering it up fully
If LED R6 is Solid Green for a few seconds, then goes to a continuous blink, then it's powered up properly

Linux terminal in Ubuntu still did not detect the SAS expander but did detect a Logical volume connected to it
But the Service Pack for Proliant boot USB worked and updated the SAS Expander firmware to latest, 2.10C

Also fixed the 2 drive detected issue.
Once I detected by the SPP boot USB, it then shows the drives in the Smart Storage Administrator
From there I cleared the current configuration and set each drive to a separate individual Raid 0 "Array"

Now all external 3 drives connected to the expander are being detected by the server.
now to test withxpenology.
 
Last edited:

bluttmer

n00b
Joined
Mar 10, 2020
Messages
23
Hello all,

I am new here and have been wanting to do something like this with an expander card. I was wondering if I could get some help.

if I get the hp expander card, then get the LSI SAS9201-16e, I hook up 12 drives to the expander card, then would I really only need one cable from the expander to the lsi card?

Any help is appreciated.

Thank you
Bill
 

bluttmer

n00b
Joined
Mar 10, 2020
Messages
23
Hi all,

I am trying to update the firmware on the HP expander, I don't have an HP server so I am trying the linux route. I have ubutnu 18.04 installed and updated, I installed my drivers for my areca 1880ix-12 and its recognized plus the drives that are connected to the HP expander. but Ubutnu doesnt seem to recognize the HP expander?

this all works properly in Windows server 2016 but don't see an option to update firmware in windows.

I tried this guide... but lsscsi -g | grep HP doesn't show my expander.

https://serverfault.com/questions/6...as-expander-card-without-smart-array-controll

Does anyone have other ideas or tricks?

Thank you
Bill
 

Blue Fox

[H]F Junkie
Joined
Jun 9, 2004
Messages
11,811
The Areca card is not presenting the device to the OS. Unless you have a specific reason that requires you to update the firmware on the card, I wouldn't bother with it.
 

bluttmer

n00b
Joined
Mar 10, 2020
Messages
23
The Areca card is not presenting the device to the OS. Unless you have a specific reason that requires you to update the firmware on the card, I wouldn't bother with it.
I am currently running firmware 2.06 and HP recommends to update the firmware, is there anyway to have the card pass the device to the OS?
 

Jalien

n00b
Joined
May 24, 2020
Messages
1
Hi Guys,
I've studied this thread fairly extensively, but can't see a concrete solution. I have an HP 468405-002, configured to use 24 ports. I would much prefer to use all of the board ports as HDD connections, but if I connect to the 'TO CONTROLLER' ports, it raises an error. The card is connected by the external 8088 port to an LSI Logic SAS9201-16e Quad Port card in the server machine.

Based on this thread the best idea I'm working down is disabling SES2, but I'm fairly far off the ball on that one.

Apologies I forgot to actually ask the question: does anyone have any advice, ideas or experience with this? What model cards are you aware of that natively can address 32 drives or have done with say a setting or firmware change?
 
Last edited:

DQntSG2zhv

n00b
Joined
Aug 19, 2020
Messages
1
I have an LSI 9211-8i card. I have been searching for a definite answer to the question, if I go the cheapo HP SAS Expander 3GBs route, will it support hard drives over 2TB in size?

For more information on my actual setup: I have a 15 bay server chassis. All 5 of the SATA ports on the motherboard are used and all 8 of the SAS to SATA cables are in use from the LSI card. I just need to expand 2 more drives but all my drives are 4TBs.

Some say you need to flash the firmware on the HP cards to latest. Some say as long as your controller card supports the drives the expander card doesn't matter. Some say no it will never work because it has to be a 6Gbs capable extender card. Is there an answer to this question?
 

mwroobel

Supreme [H]ardness
Joined
Jul 24, 2008
Messages
5,001
I have an LSI 9211-8i card. I have been searching for a definite answer to the question, if I go the cheapo HP SAS Expander 3GBs route, will it support hard drives over 2TB in size?

For more information on my actual setup: I have a 15 bay server chassis. All 5 of the SATA ports on the motherboard are used and all 8 of the SAS to SATA cables are in use from the LSI card. I just need to expand 2 more drives but all my drives are 4TBs.

Some say you need to flash the firmware on the HP cards to latest. Some say as long as your controller card supports the drives the expander card doesn't matter. Some say no it will never work because it has to be a 6Gbs capable extender card. Is there an answer to this question?
Yes, it will. You will only link at either 1.5 or 3.0 depending on your endpoint drive or firmware version.
 

dnsplus

n00b
Joined
Aug 25, 2020
Messages
4
I solved every problem I had with the HP SAS Expander. All the drives having the same ID, not working reliably with an LSI 9260 or 9361 adapter. Not working with a P420 adapter ...

I replaced it with a Lenovo SAS Expander which just plain works like magic with my LSI 9361-8i controller.

I sooooo wanted the HP unit to work, because I really really really wanted that external SAS port so I could connect more SAS drives.

The reality is, a 1U server is simply NOT a good platform for an ESXi server with local SAS backed datastores.

Sure there is a lot of room for argument in this post. To clarify, my goal was to run ESXi 7 with a controller that would be supported for a while. I chose the 9361-8i. Because this card has Mini SAS HD ports, and no suitable cables are available that work with my supermicro server backplane (pesky individual connector ports), I chose to go with the HPE 6G SAS Expander, since this would let me use a SAS 12G to SAS 6G cable, AND get an external SAS connector for external storage. All while working with the SAS cables that came with the system (which, were desinged for it). Always use as much original stuff as you can.

I should know better. In the future, 1U servers will be used by me for NAS heads and Hypervisors (depending on controller requirements). Anything with large amounts of local spinning/SSD drives will be 2U with ample slots for controllers, and external expansion if the capacity demands require it.
 
Last edited:
Top