No sound when using RX580 8Gb hdmi to TV

Discussion in 'Video Cards' started by mejiadavid, Nov 30, 2019.

  1. mejiadavid

    mejiadavid n00b

    Messages:
    3
    Joined:
    Nov 30, 2019
    I am trying to get audio through HDMI to a Samsung TV.

    PC parts:
    AMD Ryzen 5 2nd Gen 3400G
    MSI Radeon RX580 8Gb
    MSI Carbon x370 Gaming Pro (BIOS up to date)
    16Gb RAM
    Windows 10 x64 - 1909 (up to date)
    Adrenalin 2019 Edition 19.9.2(WHQL) also try with Adrenalin 2019 Edition 19.11.3


    Here are the details and issue:

    Without GPU: If I use integrated graphics rx vega 11, the sound works fine hdmi to TV.
    With GPU: If I connect hdmi to tv, video works fine but no audio, I have try both hdmi ports on rx580.
    I have tried with both drivers, using DDU to switch between drivers.
    With GPU: If I go to the sound icon, I can only see Digital Audio(S/PDF), I cannot see the TV listed as an option for audio output.
    Without GPU: If I use the integrated graphics, If I go to the sound icon, I can see the TV as default and the Digital Audio(S/PDF).
    I have another rx580, and the same issue with both cards.
    With GPU: If I plug an USB headset, audio works fine through USB.
    With GPU: if I go to device manager, under Sound..., there is only 1 device listed.
    When I go to Radeon settings, System, Software: AMD Audio Driver Version: 10.0.1.12

    Initially Y built the PC with all the parts listed, when I notice that there was no audio,
    I uninstall the GPU and use integrated and the sound worked without GPU.
    I then went to safe mode, use DDU, uninstall drivers and shut down, I reinstall the GPU but same issue, no audio.

    Any help will be greatly appreciated!
     
    Last edited: Nov 30, 2019
  2. crazycrave

    crazycrave Gawd

    Messages:
    553
    Joined:
    Mar 31, 2016
    If you have a speaker tab in your tool bar ( left click it ) then left click the up arrow and the click another option for sound .
     
  3. wra18th

    wra18th [H]ardness Supreme

    Messages:
    7,796
    Joined:
    Nov 11, 2009
    It's probably setup to send audio thru the sound card out.
     
  4. Nenu

    Nenu [H]ardened

    Messages:
    19,039
    Joined:
    Apr 28, 2007
    I had exactly this issue years ago and is why I havent had an AMD card since.
    I bought an NVidia card (GTX580 at the time) and have not had the problem since.
    Yours might be the same cause.

    I'll cut to the chase.
    The problem was caused by the AMD driver detecting HDMI devices as DVI, when it did this there was no audio.
    It did this to my monitor, TV and AV system, it didnt matter which port.
    Randomly on the odd occasion it would detect as HDMI, maybe 1 in 10 times of rebooting and trying again.
    I spent most of the time I should have been enjoying my games cursing and trying to make it detect as HDMI.
    If I left my PC on overnight with it working, most times it would change to DVI again of its own accord by the morning!
    It was infuriating.
    I put up with this for a year hoping it would get fixed and in the end sold the card and swore off AMD for good.
     
  5. mejiadavid

    mejiadavid n00b

    Messages:
    3
    Joined:
    Nov 30, 2019
    UPDATE:

    Here are some things that I have tried:
    Downgraded BIOS 2 versions,
    CPU stop working,
    used and an old CPU (AMD A8),
    There was sound coming from the GPU,
    upgraded BIOS 1 version,
    Still using A8, there is sound in GPU,
    Switch back to Ryzen 5,
    Won't boot (MOBO is from 2017ish and CPU from 2019, there are some know issues)
    Switch back to A8, upgraded to latest BIOS,
    Again, no sound.

    I need the latest BIOS because it works with ryzen 5 but it causes problems with GPU.
    version 7A32v1NU(Beta version) works with MOBO and Ryzen 5 but causes GPU issues
    version 7A32v1L won't work with MOBO and ryzen 5 but it works with A8 and GPU
    version 7A32v1K won't work with MOBO and ryzen 5 but it works with A8 and GPU
     
  6. Nenu

    Nenu [H]ardened

    Messages:
    19,039
    Joined:
    Apr 28, 2007
    Your cause looks different then, I was using an Intel CPU.
    Good luck!
     
  7. DrDoU

    DrDoU 2[H]4U

    Messages:
    2,456
    Joined:
    Jun 4, 2007
    Can you turn off intergrated graphics in bios and then see what happens?
     
    Armenius, kirbyrj and wra18th like this.
  8. kirbyrj

    kirbyrj [H]ard as it Gets

    Messages:
    24,925
    Joined:
    Feb 1, 2005
    Do this. It has to be some sort of confusion with your IGP and the video card. I've had 3 or 4 580's and have been able to get sound out of HDMI on all of them.

    If you have a 580, sell the 3400G and get a cheap 2600. Same generation of processor with 2 extra cores. Probably be an even swap in price or you might even come out ahead.
     
    DrDoU likes this.
  9. Zepher

    Zepher [H]ipster Replacement

    Messages:
    17,014
    Joined:
    Sep 29, 2001
    what do you see in your sound settings?

    sound-windows.jpg
     
    Armenius and primetime like this.
  10. thesmokingman

    thesmokingman [H]ardness Supreme

    Messages:
    5,332
    Joined:
    Nov 22, 2008
    ^^This, check yer sound control panel before doing anything else. I disable everything I don't use, leaving just 1 option.
     
    Armenius and primetime like this.
  11. mejiadavid

    mejiadavid n00b

    Messages:
    3
    Joined:
    Nov 30, 2019
    Donde this, still no audio.

    Only 1 device listed, no the TV.
     
  12. ashmelev75

    ashmelev75 [H]ard|Gawd

    Messages:
    1,573
    Joined:
    Nov 29, 2007
    Happened to me once when I tried to do a clean install. By some reason the HDMI audio went away and the device could not be detected any more.

    What happens if you unplug the HDMI cable to TV with Windows loaded and plug back into a different connection?
     
  13. Armenius

    Armenius I Drive Myself to the [H]ospital

    Messages:
    19,406
    Joined:
    Jan 28, 2014
    I would DDU the Radeon drivers, disable the IGP in the BIOS, and reinstall the Radeon drivers.
    Can you show us a screenshot?

    Also, while there, go to the links on the right side and click on Sound Control Panel. On the Playback tab, make sure there is a green check mark next to the TV speakers if it shows up. If there isn't, right-click it and choose Set as default device. If any other devices show up in this menu, right-click and disable them.

    upload_2019-12-2_10-7-18.png