XFX Radeon 7850 GHOST Fan

Ang

Gawd
Joined
Mar 20, 2008
Messages
597
I thought something was wrong with my video card, because it wasn't posting so I bought a new video card to replace it.

Long story short, the PCI-E cable was loose on my power supply, so the PCI-E wasnt giving the video card any power.

I decided to keep my new video card, and was thinking about giving/selling my 7850 to someone. But I noticed the fan doesnt spin unless I set the speed to 90-100% fan speed. Or if the fan speed is on auto, the fan will turn on at around 75 deg C. I cant find anything online about it, but i could have sworn the fan was on all the time. I don't want to give a card to someone that is faulty.

Does anyone know if this card is supposed to have the fans off at low temps? Thanks.

http://xfxforce.com/en-us/products/all-previous-gpus/amd-radeon-hd-7850-core-edition-fx-785a-cnl4
 

XFXSupport

XFX Representative
Joined
Sep 14, 2006
Messages
622
hello,

The fan speed scales to need. it should nearly always be running (unless at totally idle).

we have replacement fans for these that we can ship, free of charge. PM me your shipping name and address and i can ship you a fan. we did run out of stock yesterday, but more stock will trickle in over the next few weeks.

Mark at XFX
 
Joined
Aug 6, 2016
Messages
5
hey Ang , did replacing the fan sort out the problem? I have exactly the same thing occuring with mine ( even the 90% to 100% fan setting only getting them running )
.It is currently not in my desktop because of it :(
 
Top