Xfire and V-Sync Issue

suiken_2mieu

2[H]4U
Joined
Apr 7, 2010
Messages
2,910
Okay, I plopped in my second 7970 a couple days ago and immediately ran into an issue with v-sync when I loaded up BF3.

On a single-GPU, I have no issue with v-sync. I get FPS from 0 to 60. Though with Xfire, I immediately get 30 / 31 FPS locked with V-sync. If I turn off v-sync I get 65 FPS (I have that as my frame limit). It's very smooth at without v-sync, but when there's flashing or the frame rate fluctuates, I get tearing. Massive tearing.

The weird part is that I average 60+ FPS at almost all times. So I wouldn't think the v-sync FPS halving would effect me. Ideas?
 

aznever

Gawd
Joined
Sep 7, 2010
Messages
587
raise your frame limit to 120 and then set vsync. you should get 60 after that.
 

suiken_2mieu

2[H]4U
Joined
Apr 7, 2010
Messages
2,910
raise your frame limit to 120 and then set vsync. you should get 60 after that.

Nope, it still goes down to 30/31FPS. It does this whether there is a cap in place or not. It's really weird to me. I want to avoid using D3DOverrider as it cause instability in my system.
 
Joined
Oct 26, 2005
Messages
2,340
Weird. You sure it's running on both GPUs? Don't know about Crossfire, but FPS halving doesn't seem to happen in SLI.

I know you don't want triple buffering as a permanent solution, but what's your framerate with it enabled? Over or under 60?
 

staticlag

[H]ard|Gawd
Joined
Mar 26, 2010
Messages
1,679
Are you running with one crossfire bridge connected or both?

I had issues similar to this and purple banding when I ran both bridges connected.
 

257Tony

Gawd
Joined
May 18, 2011
Messages
723
Some games just seem to do that. I'm playing dead space 3 right on my 7970 xfire setup,and get 150+ fps (5760x1080) with vsync off , and 30 with it on. Afterburner frame limiter with vsync off fixes that one, some games require d3d overrider or Radeon pro with triple buffering forced to get it right.
 
Joined
Oct 26, 2005
Messages
2,340
Some games just seem to do that. I'm playing dead space 3...
Vsync in all 3 Dead Space games caps your fps at 30 (probably a "feature" inherited from the console verisons...). Disable it in-game, force it from the control panel. BF3 doesn't have this problem.

Wouldn't this be a triple buffering thing?
Only if the framerate's under 60 without vsync, which it apparently isn't.
 

suiken_2mieu

2[H]4U
Joined
Apr 7, 2010
Messages
2,910
Weird. You sure it's running on both GPUs? Don't know about Crossfire, but FPS halving doesn't seem to happen in SLI.

I know you don't want triple buffering as a permanent solution, but what's your framerate with it enabled? Over or under 60?

With triple buffering I still have a 30 FPS cap. Which is weird. That's with over 60 fps and under 60 fps.

Have you tried using Radeon Pro to tweak the Vsync?

http://www.radeonpro.info/en-US/

I haven't, will try this.

Are you running with one crossfire bridge connected or both?

I had issues similar to this and purple banding when I ran both bridges connected.

Just one. A while ago, I heard something about the crossfire bridges not being designed for large eyefinity resoltuions. Like there was a bandwidth cap. But that was during the 5000 series, dunno if that is / was an issue.

Some games just seem to do that. I'm playing dead space 3 right on my 7970 xfire setup,and get 150+ fps (5760x1080) with vsync off , and 30 with it on. Afterburner frame limiter with vsync off fixes that one, some games require d3d overrider or Radeon pro with triple buffering forced to get it right.

I had that issue with dead space as well, but I never heard of anything like this with BF3.

Wouldn't this be a triple buffering thing?

No. Triple Buffering would actually dis-allow the fps halving issue.
 
Top