Windows 10: Your thoughts so far?

Silent Knight

[H]ard|Gawd
Joined
Dec 5, 2010
Messages
1,224
For those who are experiencing Windows 10 (either Home or Pro version), is there any problem you have faced so far using it? Anything you like about it?

For me, every time my laptop boots, disk load runs up to 100%, which makes me feel so worried.

Importing bookmarks from other browsers to the Edge has not completed yet I think, cannot find my Firefox on the list.
 

bizzmeister

[H]ard|Gawd
Joined
Apr 26, 2010
Messages
1,584
I'm using windows 10 pro now for about 20 minutes and just setting up everything again, loving it so far.

Everything feels much better/smoother/faster it seems. Loving the xbox integration/mail the new Microsoft edge browser.

All super quick. Still discovering stuff as I type this, getting late though lol. gonna go to sleep.
 

Tiberian

DILLIGAFuck
Joined
Feb 12, 2012
Messages
5,725
Can't stand it at all, honestly. Haven't been able to find one reason to replace Windows 7 on my hardware with Windows 10, not one single reason so far - not even the fact that it's free - and I've been part of the Insider program since day one testing all the builds provided to gain knowledge on how it's all pooched aka working. I fully expect to get a ton of support calls today from clients of mine as this rollout kicks into high gear so, even though I cannot tolerate Windows 10 at all for myself, it's sure going to give me a decent boost in income for the next few weeks.

Well, there ya go I suppose - the one good thing about Windows 10: techs and support people like myself are going to make a fortune in support calls in the immediate future. :D
 

SuperSubZero

2[H]4U
Joined
Nov 21, 2000
Messages
3,619
The upgrade went fine on my gaming rig, and it's working smoothly. I have tweaked the Start Menu with my commonly used items, imported my bookmarks from Chrome into Edge (may not end up using it but it's seriously not bad), and have just been poking around checking things out.

Making the Modern apps window-able is -so- nice. On my 2560x1440 27" I actually want to use Modern apps now. The built-in apps like Mail and Calendar are basic but functional (they work properly with Google again, yay!).

That said, in moving icons around on the Start Menu I already rendered it 'locked up' twice, where the entire Start Menu stopped responding (but I could just close/open it and it was ok).

I work in tech support and while my Windows base is kind of small (we're a Mac-centric company) I am sure some people are gonna end up upgrading. We'll see how well that goes.
 

bizzmeister

[H]ard|Gawd
Joined
Apr 26, 2010
Messages
1,584
The upgrade went fine on my gaming rig, and it's working smoothly. I have tweaked the Start Menu with my commonly used items, imported my bookmarks from Chrome into Edge (may not end up using it but it's seriously not bad), and have just been poking around checking things out.

Making the Modern apps window-able is -so- nice. On my 2560x1440 27" I actually want to use Modern apps now. The built-in apps like Mail and Calendar are basic but functional (they work properly with Google again, yay!).

That said, in moving icons around on the Start Menu I already rendered it 'locked up' twice, where the entire Start Menu stopped responding (but I could just close/open it and it was ok).

I work in tech support and while my Windows base is kind of small (we're a Mac-centric company) I am sure some people are gonna end up upgrading. We'll see how well that goes.
Just created my own thread in the NVidia driver section but check this out since your online right now, any he[p?

Just finished updating to win 10 pro from my win 7 desktop here and I'm not seein' anything NVidia related anywhere. I cant find the NVidia control panel or anything of that sort, NVidia icon gone from task bar. Went to NVidia.com and choose gtx 780 64 bit win 10, download the 259mb file and the install fails.

Everything is working fine, I haven't gamed yet on steam or anything. Am I missing something? Why would NVidia drivers disappear? Or am I seeing things? Or do I even need to do anything at all?


EDIT: *** CS:GO wont even launch, Depth launched and got to main menu but everything is choppy, cpu goes nuts and every click is delayed 3-4 seconds ( and this is just in the main menu, didn't make it to gaming )
 

Joga

Limp Gawd
Joined
May 5, 2006
Messages
392
I'm liking it so far, though there are a some niggling issues (mostly browser-related). Edge is really fast, but doesn't seem to work with Google Play Music (it just shows an empty page with the playback controls) which is a requirement for me. And like IE11 before it, it still doesn't use ClearType or support 120 Hz.

Also, Chrome seems to have a bug with W10 where sometimes typing in the URL bar just won't show the text that you type.
In this screenshot, I have already typed the entire phrase "this is a test", and the blinking text cursor is at the end, but the text itself doesn't show up in the URL bar (it does prompt a Google search for the phrase underneath it though). Pressing spacebar again or typing some more will force the browser chrome to update and the text will all magically appear all at once.



Not deal-breaking but still kinda odd.

Edit: Gaming is fine for me. Running Catalyst 15.7 (Windows 10) drivers on an HD 7950. Bioshock Infinite actually benchmarked a little bit better. CS:GO runs fine. No compatability issues that I've encountered so far.

Edit 2: I just did a clean install of Windows 10 (Well, "Reset" but pretty much the same thing). With a fresh install of Chrome as well, the strange URL bar behavior seems to be fixed, and everything works normally now.

Edit 3: Arkham Knight runs significantly worse than in Windows 8.1. Though admittedly, I was apparently the only person who ran it well without any stuttering before; now it seems I'm in the same boat as everyone else. PowerDVD 14 has problems playing BluRay discs - they'll play okay when windowed, or while the OSD is onscreen, but as soon as the OSD disappears in fullscreen mode, the video freezes, followed shortly by the audio and then the whole program (has to be killed from Task Manager).

Edit 4: AMD Catalyst 15.7.1 just fixed literally everything, lol. Bluray disc playback is fine now, and Arkham Knight is (mostly) stutter free again just like in 8.1. Woot.
 
Last edited:

Staples

[H]ardness Supreme
Joined
Jul 18, 2001
Messages
7,876
I had a few system hangups during the upgrade but it seems to work well now.

Chrome has lots of bugs so I am not surprised at that issue above. I use Opera now because I used to have so many problems with it.

Virtual Desktops was the only reason I upgraded from 8.1. They work flawlessly. I used to use Dexpot with 8.1 but it did not work well with certain window types (some were shown on all desktops).
 

Suprfire

2[H]4U
Joined
Sep 1, 2008
Messages
2,100
Just created my own thread in the NVidia driver section but check this out since your online right now, any he[p?

Just finished updating to win 10 pro from my win 7 desktop here and I'm not seein' anything NVidia related anywhere. I cant find the NVidia control panel or anything of that sort, NVidia icon gone from task bar. Went to NVidia.com and choose gtx 780 64 bit win 10, download the 259mb file and the install fails.

Everything is working fine, I haven't gamed yet on steam or anything. Am I missing something? Why would NVidia drivers disappear? Or am I seeing things? Or do I even need to do anything at all?


EDIT: *** CS:GO wont even launch, Depth launched and got to main menu but everything is choppy, cpu goes nuts and every click is delayed 3-4 seconds ( and this is just in the main menu, didn't make it to gaming )
What does your device manager look like?

My CSGO runs exactly as it did on 8.1
 

bizzmeister

[H]ard|Gawd
Joined
Apr 26, 2010
Messages
1,584
What does your device manager look like?

My CSGO runs exactly as it did on 8.1
Ok so I didn't check device manager but I did find and uninstall every NVidia driver/experience/PhysX and everything related to NVidia and reinstalled win 10 drivers direct from NVidia and everything seems to be back to normal with it all working now.
 

TDSlam720

Limp Gawd
Joined
Mar 30, 2014
Messages
364
Can't stand it at all, honestly. Haven't been able to find one reason to replace Windows 7 on my hardware with Windows 10, not one single reason so far - not even the fact that it's free - and I've been part of the Insider program since day one testing all the builds provided to gain knowledge on how it's all pooched aka working. I fully expect to get a ton of support calls today from clients of mine as this rollout kicks into high gear so, even though I cannot tolerate Windows 10 at all for myself, it's sure going to give me a decent boost in income for the next few weeks.

Well, there ya go I suppose - the one good thing about Windows 10: techs and support people like myself are going to make a fortune in support calls in the immediate future. :D
What exactly about W10 can't you tolerate. W8 was a more refined W7 ( sans metro ) and W10 is a more refined W8. The W7 people are starting to sound like the 60 year olds that live out in the sticks refusing to let go of 98SE/XP.
 

DogsofJune

2[H]4U
Joined
Nov 7, 2008
Messages
3,509
So far, only my Dell Venue 8 Pro has successfully taken Win 10, albeit it doesn't like the Microsoft Bluetooth mouse or the Dell stylus yet, nor does it allow me to switch to my wireless router. It insists on connecting to an extender instead. Outside of that everything else is peachy.

My 3770K box with Win 7 keeps getting the "modern setup host" error at 45%. Not enough beer in the house to investigate that issue. Resorting to watching movies first till licker store opens.

The Dell Inspiron is currently at 20% install and seems to be going well enough.

Mint is staying on the other laptop, and my 4820K box will stay with Win 7 till I have time to discover what proggies work, and which ones don't.

May try an old Acer netbook and see how it handles the new OS.
 

-Strelok-

[H]ardForum Junkie
Joined
Dec 2, 2010
Messages
10,005
Seems OK so far. I did have to reinstalled the Xinput drivers for my PS3 controller and the weather thing stopped responding at one point. Is there anyway to remove that search bar next to the start button? That just seems like a waste of space. Also, with Edge, is there anyway to mute volume in certain tabs? I see that it displays the little sound notification of where it's coming from, but I didn't see a way to mute it.
 

SuperSubZero

2[H]4U
Joined
Nov 21, 2000
Messages
3,619
Just finished updating to win 10 pro from my win 7 desktop here and I'm not seein' anything NVidia related anywhere. I cant find the NVidia control panel or anything of that sort, NVidia icon gone from task bar. Went to NVidia.com and choose gtx 780 64 bit win 10, download the 259mb file and the install fails.
I have a GTX970. When Win10 was done installing I had to reboot again to kick in the nVidia driver that it installed as part of the upgrade process. I had no issues.
 

ManofGod

[H]ardForum Junkie
Joined
Oct 4, 2007
Messages
11,531
I'm liking it so far, though there are a some niggling issues (mostly browser-related). Edge is really fast, but doesn't seem to work with Google Play Music (it just shows an empty page with the playback controls) which is a requirement for me. And like IE11 before it, it still doesn't use ClearType or support 120 Hz.

Also, Chrome seems to have a bug with W10 where sometimes typing in the URL bar just won't show the text that you type.
In this screenshot, I have already typed the entire phrase "this is a test", and the blinking text cursor is at the end, but the text itself doesn't show up in the URL bar (it does prompt a Google search for the phrase underneath it though). Pressing spacebar again or typing some more will force the browser chrome to update and the text will all magically appear all at once.



Not deal-breaking but still kinda odd.

Edit: Gaming is fine for me. Running Catalyst 15.7 (Windows 10) drivers on an HD 7950. Bioshock Infinite actually benchmarked a little bit better. CS:GO runs fine. No compatability issues that I've encountered so far.

Edit 2: I just did a clean install of Windows 10 (Well, "Reset" but pretty much the same thing). With a fresh install of Chrome as well, the strange URL bar behavior seems to be fixed, and everything works normally now.
Thank you for reminding me that I could do a reset. I am doing that on 2 computers now that were slow booting after the upgrade was done. Already backed up the data anyways so it is worth a try.
 

-Strelok-

[H]ardForum Junkie
Joined
Dec 2, 2010
Messages
10,005
Found the first annoying bug with a game. Rome Total War 2 crashes every time you end your turn.

EDIT: Nevermind, looks like verifying game cache fixed it. So it seems if anything is crashing/not working just try reinstalling or if it's a steam game verifying cache.
 

dara

Gawd
Joined
Apr 10, 2009
Messages
638
I like it a lot.

NVidia driver install keeps failing though. Both the latest driver from NVidias site and through windows update. :confused:
 

Comixbooks

Ignore Me
Joined
Jun 7, 2008
Messages
14,466
I wouldn't want to be a bug fixer for Nvidia or AMD right about now I wouldn't mind the pay though.
 

Webhead

Gawd
Joined
Jun 26, 2010
Messages
562
No real problems on my main rig so far. Have the SP2 and another laptop to install on. Kind of like Edge so far, but need addons.
 

Domingo

[H]ard as it Gets
Joined
Jul 30, 2004
Messages
17,545
Had it for about a month. No major issues other than the weird debacle with the recent Nvidia drivers.
For the clean install people - DO NOT try to re-install all of your programs at once. Install 2-3 and reboot. Trying to do everything in one go is where a lot of people have had problems - myself included.
Gaming is exactly where Windows 8.1 was. No better, no worse.

Gripes:
DPI handling is a mess. 100% is fine, but things are too small. Boosting it to 125% makes things the right size, BUT lots of programs and OS elements are blurry as hell as a result.

I hate that you can't sort or put modern apps in folders. Hell, some of them I just want to hide or rename. Guess what - you can't.

I dislike that they've divided so many functions between the Control Panel and new "Settings" menu. They need to unify that badly.
 

dr.stevil

[H]ardForum Junkie
Joined
Sep 26, 2008
Messages
9,096
So far so good. Installed StartIsBack and no real complaints.... just want to find a way to disable the ribbon in explorer.
 

Silent Knight

[H]ard|Gawd
Joined
Dec 5, 2010
Messages
1,224
I'm curious how he got his Start Menu to look like that with the larger folder icons and power button at the top. It definitely doesn't look like that with the default settings.
DPI handling is bad i must say. I user viber a lot and on my dell, 1800p is an impossible task for viber to scale up.

I zoom the icon up to 150%, viber is now readable but when i sign out as being told, everything goes back to tiny bit :mad:
 

G_Sup

Limp Gawd
Joined
Jan 31, 2005
Messages
300
I like it a lot.

NVidia driver install keeps failing though. Both the latest driver from NVidias site and through windows update. :confused:
This was THE deal breaker for me for now. Went back to Win 7. How in the hell they released this when you can''t even get drivers for your vid card is beyond me.
 

klank

Killer of Killer NIC Threadz
Joined
Aug 22, 2011
Messages
2,148
This was THE deal breaker for me for now. Went back to Win 7. How in the hell they released this when you can''t even get drivers for your vid card is beyond me.
I had no problems installing Nvidia drivers on either of my Win 10 machines.
 

G_Sup

Limp Gawd
Joined
Jan 31, 2005
Messages
300
I had no problems installing Nvidia drivers on either of my Win 10 machines.
Don't know what to tell you. Installed Win 10 and go to device manager, big caution sign on both cards (SLI). Go to Nvidia and get newest Win 10 drivers and install fails every time. Go to Google and tons of problems.

Did you do a clean install?
 

dr.stevil

[H]ardForum Junkie
Joined
Sep 26, 2008
Messages
9,096
I had no problems installing Nvidia drivers on either of my Win 10 machines.
likewise. Windows 10 upgrade actually automatically installed them for me. Everything seems to be working great. Hope to do a clean Windows 10 install in the near future (When I get some time)
 

G_Sup

Limp Gawd
Joined
Jan 31, 2005
Messages
300
Perhaps you guys aren't running SLI. Looks like people with multi monitors are having issues as well.
 

MrSteel74

[H]ard|Gawd
Joined
Nov 17, 2000
Messages
1,599
For the people that are having issues with installing Nvidia drivers what cards are you running? Are they pre Maxwell?
 

G_Sup

Limp Gawd
Joined
Jan 31, 2005
Messages
300
Did you do a clean install? It's weird, there are work arounds for this problem, so I know it's there... lucky you I guess.
 

dr.stevil

[H]ardForum Junkie
Joined
Sep 26, 2008
Messages
9,096
Did you do a clean install? It's weird, there are work arounds for this problem, so I know it's there... lucky you I guess.
no, it was an upgrade, but like I said, the installer automatically detected and installed the drivers.
 

ManofGod

[H]ardForum Junkie
Joined
Oct 4, 2007
Messages
11,531
I immediately could tell that something was up because his start menu is not even what is available in Windows 10 RTM. There is no start bar on the start menu directly nor are the Icons on the left correct. He is using either an older version or a Start Menu replacement.

Edit: He is using build 9481 which means that video is a complete waste. (This especially since he shows the video as being released today.) :rolleyes:
 

klank

Killer of Killer NIC Threadz
Joined
Aug 22, 2011
Messages
2,148
Perhaps you guys aren't running SLI. Looks like people with multi monitors are having issues as well.
I run dual monitors on GTX 980. Had 8.1 Pro + nvidia drivers installed prior to upgrade. Upgraded to 10, then installed latest nvidia drivers. Zero issues.
 

Domingo

[H]ard as it Gets
Joined
Jul 30, 2004
Messages
17,545
I immediately could tell that something was up because his start menu is not even what is available in Windows 10 RTM. There is no start bar on the start menu directly nor are the Icons on the left correct. He is using either an older version or a Start Menu replacement.

Edit: He is using build 9481 which means that video is a complete waste. (This especially since he shows the video as being released today.) :rolleyes:
Glad I'm not crazy for noticing that. I actually like his Start Menu better than the final/real one.
 
Top