Windows 10 sleep problem

Joined
Jan 24, 2007
Messages
725
Hello everyone, I posted this while ago but didn't get much help, and I've been battling it off and on since. I've tried more things recently.

When I checked powercfg -requests I was getting nothing. I used the 'reset this PC' function and reinstalled Windows while keeping my files. Right off the bat it went to sleep when it was supposed to, when before it would never sleep. Not long after though it woke back up. Its to the point that I put it to go to sleep after 30 mins and while I'm at work or sleeping it just constantly wakes and sleeps every 20-40 mins. After the refresh I was getting something about an updater but I can't remember the path. I stopped getting that though and now I'm getting Legacy Kernel Caller when I run powercfg -requests. I've tried adding an exception but it still wakes. I've looked in the Event Viewer which I screenshotted and for wake source it shows unknown. This has been going on for a long time and is really irritating. If anyone has any suggestions I would appreciate it.
 

Attachments

  • eventviewer3.jpg
    eventviewer3.jpg
    222.9 KB · Views: 0

vick1000

2[H]4U
Joined
Sep 15, 2007
Messages
2,255
I believe you can disable several wake sources in the BIOS. Probably something over your network, you can try disabling network devices or unplug a cable for testing.
 
Joined
Jan 24, 2007
Messages
725
I believe you can disable several wake sources in the BIOS. Probably something over your network, you can try disabling network devices or unplug a cable for testing.

In all of the googling I've done I've seen people find out its something with the network adapter, but usually something clearly pointing to it. I will still unplug the ethernet cable to try it.
 

GotNoRice

[H]F Junkie
Joined
Jul 11, 2001
Messages
10,133
I've found that most sleep issues are related to attached USB devices. Joysticks and Game-pads are big culprits. I would try to unplug all USB input devices (including your mouse and keyboard) and see if the computer stays in sleep or not. If it works properly, reconnect them one by one until you identify the problem device.
 

B00nie

[H]F Junkie
Joined
Nov 1, 2012
Messages
8,992
Pour some vodka into the computer. That always works for me when I have sleep problems!
 
Joined
Jan 24, 2007
Messages
725
I believe you can disable several wake sources in the BIOS. Probably something over your network, you can try disabling network devices or unplug a cable for testing.
So far....it worked! I unplugged the cable last night before going to sleep. Woke the computer up this morning and there was no wake/sleep cycling at all, just when I put it to sleep and then woke it up in the morning. I went into Device Manager and unchecked allowing the network adapter to wake the computer, so hopefully it keeps working. I can't believe I've been digging so deep for it to be something so simple. Thank you!
I've found that most sleep issues are related to attached USB devices. Joysticks and Game-pads are big culprits. I would try to unplug all USB input devices (including your mouse and keyboard) and see if the computer stays in sleep or not. If it works properly, reconnect them one by one until you identify the problem device.
That was one of the first things I checked into, and I was seeing something in Event Viewer about the Bluetooth USB and I unplugged it, but nothing changed. Looks like it ended up being the network adapter anyway.
Pour some vodka into the computer. That always works for me when I have sleep problems!
I want to be able to wake it up when I need it, not permanently put it to sleep!:LOL:
 

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
27,370
as suggested, disconnect any usb devices and your network cable. if it sleeps properly, add things back one at a time until it starts again. theres your culprit.
 

slavie

Weaksauce
Joined
Jan 2, 2012
Messages
118
Usually it's either mouse or network. Find your mouse in the "Device Manager", go into "Power Management" and uncheck "Allow this device to wake the computer" or whatever it's called. Do this for all mice, and for the network controller. You can still wake the computer up with the keyboard, which is what I do.
 

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
27,370
You did not state what version of windows, but I had a similar issue in this thread: https://hardforum.com/threads/is-windows-10-20h2-the-worst-windows-yet.2007796/post-1044949363
I'm currently back on 1909 which works perfectly. I have it set to put the PC to sleep in 4 hours or 5 hours. Once asleep, I simply press any key or mouse and the PC comes back to life.
valid point about no version mentioned but its not 20h2 specifically. maybe in your case there is something in conjunction with it thats causing your problem but it not a universal thing. i have dozens of machines at work and a couple at home on 20h2 that sleep just fine.
 

pinoy

Limp Gawd
Joined
Dec 8, 2010
Messages
444
I disabled the wake timers in the advanced power settings and I found my computer this morning woke up and did its maintenance dance. So now I also disabled the Allow this device to wake the computer for my Network adapter. Hopefully, that puts it to bed for good.
 
Top