Windows 10 Overriding BIOS Settings--How to stop this madness?

unMourned

n00b
Joined
Mar 11, 2021
Messages
2
First, I am a disabled US Army Veteran with cognitive challenges. Please forgive me for any shortcomings, lapses, or mistakes.

I built a computer ground-up using a Intel Core i9-10900K CPU (5.3 GHz Unlocked). I put that on a EVGA Z490 FTW WiFi motherboard.

What I'm struggling with:

Regardless of how I set up my CPU frequency in the UEFI / BIOS, Windows 10 seems to "dumb down" my CPU frequency.

I've tried adjusting the "Power Profiles" and I've changed the System32 Intel file from DLL to BAK.

How can I stop Windows 10 from doing anything contradictory, or otherwise to my specific power and frequency settings in the EVGA z490 UEFI / BIOS?

By the way, I've got a Noctua NH-D15 chromax.Black, Dual-Tower CPU Cooler (140mm, Black) sitting atop my i9-10900K on an X-shaped application of Arctic MX-4 4G (2019 Edition). Temps are in the 20s (C) at rest, and 40s (C) while gaming--while set at a fixed 4.1 GHz. I am NOT worried about temps, and I am not PRIME 95-ing my system for hours on-end.

I simply want Windows 10 to STFU when it comes to power profiles--this is not a laptop!

Thank you.

unMourned
 

chameleoneel

2[H]4U
Joined
Aug 15, 2005
Messages
4,046
do you mean downclocking when your CPU isn't doing anything?

or do you mean how your CPU will bounce between various speeds, depending upon the load?
 
Joined
Nov 13, 2006
Messages
3,103
This really isn't a Windows 10 thing that is messing with you. Unlike in the "olden" days of PCs, most modern CPUs now automatically downclock when they aren't doing any work and pretty much instantly jump back up to max freq when they are pushing something to actually do. Also, unlike the "olden" days of PCs, they can ramp up/down VERY fast and efficiently. There is no longer a need to have your CPU set to stay at max freq all the time to get performance from it. These modern CPUs can also suck up a good bit of power and produce quite a bit of heat when they are pushing a heavy load, so you really don't want your CPU running 24/7 at max freq all the time.

So, bottom line, this is completely normal CPU behavior. There is no need to worry about it. Modern CPUs are simply designed for maximum efficiency and they are constantly changing/ramping their freq and their voltage levels up and down in order to consume as little power as possible when they are not responding to a heavy software load.... but do the exact opposite and ramp it all to 11 when/if needed pretty much instantaneously.

With all that said, if you really do want you CPU running "balls to the wall" at all times, even if there is no work and don't care about heat and your power bill going through the roof, then you should be able to find in your BIOS a setting under the CPU area that talks about "C-states". Simply make sure that your "CPU C States" setting is set to "Disabled" and that should prevent the CPU from down-clocking.

Cheers from a fellow Army veteran!
 
Last edited:

unMourned

n00b
Joined
Mar 11, 2021
Messages
2
Nowadays you don't have to fiddle with the BIOS in order to overclock, you can just do it with the software that came with your motherboard or the manufacturer has available.

I use AI Suite from ASUS and the only thing I change in the BIOS is the XMP, so that the RAM runs at the rated speed, because otherwise by default it'd run at 2133MHz. Then there's XMP 1 and XMP2, my RAM modules have two profiles, 1 for 3200MHz and 2 for 3600MHz, so I set it to XMP2.

It's a breeze to overclock that way, I got my 9900KF with a be quiet! Dark Rock Pro 4, and Thermal Grizzly Kryonaut Thermal Paste to run at 5.0GHz with 77C high and 1.279v and a bunch of 120mm be quiet! fans.

I'm guessing eVGA's software for overclocking might be a little more difficult than the others. But download the software: https://www.evga.com/eleet/

And go watch tutorials on how to use it:

Thank you very much!

I looks like they do not make eleet for the z490 mobos.

=(
 
Top