navi support (rather lack thereof)

Discussion in 'Linux/BSD/Free Systems' started by Darth Ender, Sep 10, 2019.

  1. Darth Ender

    Darth Ender Limp Gawd

    Messages:
    376
    Joined:
    Oct 11, 2018
    Running Debian unstable. Kernel 5.3-rc8 latest firmware including the navi firmware

    Tried using mesa git (19.2 branch) with llvm10 and it built fully but all attempts to use the amdgpu driver resulted in xorg messages saying that 2d and 3d acceleration were disabled. Additionally I dont like this method since Debian is fairly broken when it comes to 32bit multi-arch building - you basically have to ditch that idea and have two multi-arch debian systems, one setup to build amd64 and one setup to build 32bit since trying to install the 32bit dev pkgs uninstalls the 64bit ones half the time. *shakes fist*

    I then installed the experimental 19.2 (32bit and 64bit) debian pkgs but they're rc1 still and that means they were built with llvm8, so they predictably also dont work. Trying to use amdgpu with them results in a black screen hang, so it wont even fallback to software rendering.

    Proprietary drivers require an older kernel (5.2) for dkms to build and I'm not in the mood to downgrade my kernel. Trying to use the driver with 5.3-rc8's amdgpu kernel driver results in failure to load xorg.


    It's been a long time since my graphics setup was bleeding edge ( my card was an rx480).

    Anyone else diving into the hot dumpster fire that is bleeding edge amd drivers? According to google, the mesa git build should have worked but obviously i'm missing something. I haven't heard of people using debian successfully with the 5700 yet at least, but if anyone has...what steps were taken? Seems like half the people who report success in other dists are actually running in software mode and not really aware or dont care, with glx/vulkan support not working.


    Windows wasn't fairing much better btw. Half of my games locked up or crashed with the latest amd drivers. The ones that didn't, were running well though.
     
  2. Sinistar

    Sinistar n00b

    Messages:
    51
    Joined:
    Apr 26, 2009
    Running Arch here with a 5700 XT. I don't bother with 32 bit, use default Mesa and LLVM for that. I am running the same kernel a you are, with the latest dev build of LLVM 10.0 and Mesa 19.3.
    Also, I am using the firmware from here. All steam games that worked before the graphic card upgrade still working after.

    I am not sure what method you are using to install LLVM, but you also need clang and compiler-rt built together with LLVM. After you have installed those three compile mesa, and install.
     
  3. Darth Ender

    Darth Ender Limp Gawd

    Messages:
    376
    Joined:
    Oct 11, 2018
    Was using the 19.2 branch, not .3. Hrmm. I didn't rebuild any other parts of xorg or dri outside of Mesa. Are you sure glxinfo shows hardware Accel instead of llvm pipe?
     
  4. Sinistar

    Sinistar n00b

    Messages:
    51
    Joined:
    Apr 26, 2009
    glxinfo output:

    Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: AMD NAVI10 (DRM 3.33.0, 5.3.0-rc8-mainline, LLVM 10.0.0) (0x731f)
    Version: 19.3.0
    Accelerated: yes
    Video memory: 8176MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 4.5
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
     
  5. Darth Ender

    Darth Ender Limp Gawd

    Messages:
    376
    Joined:
    Oct 11, 2018
    all is well again. debian experimental finally pushed rc3 so I upgraded to that and it's all working again... games still seem to be locked to vsync instead of overriding it but that could be the tearfree option i have enabled doing that. In any case no issues there anymore.

    I guess my self-compiled mesa just was still being overriden somewhere to use the system libs instead of what was in /usr/local even though i had /usr/local preceding /usr in ld.so.conf .... since that build should have worked. oh well.