Broke my first mouse

TeeJayHoward

Limpness Supreme
Joined
Feb 8, 2005
Messages
11,603
I've been playing around with computers since the 286 era, and I've never broken a mouse before today. This morning, I grabbed the mouse and wiggled it around to turn of my screen saver while putting on my pants, and ***ZZZZZAAAPPP***. Static electricity. Now the buttons work fine, but the mouse won't move. I've tried it on two different computers. Same issue on both. Thermaltake Level 10 M.

Is it screwed? Or is there something I can do?
 

techtechie

Gawd
Joined
Oct 7, 2013
Messages
571
i doubt that static electricity could do that but who knows........i see that there's lots of metal so theoretically i might be possible
 

Butcher9_9

Limp Gawd
Joined
Mar 8, 2010
Messages
146
I'm sure you have tried this already but just in case, did you try cleaning the underside? I get cat hair stuck in the optics slot some times and that causes no end of issues. Pulling out the hair and problem solved.

Otherwise, time for a new mouse.
 

TeeJayHoward

Limpness Supreme
Joined
Feb 8, 2005
Messages
11,603
I'm sure you have tried this already but just in case, did you try cleaning the underside? I get cat hair stuck in the optics slot some times and that causes no end of issues. Pulling out the hair and problem solved.

Otherwise, time for a new mouse.
Yeah, cleaning it didn't fix it. Bought a replacement.
 

orangekiwii

Limp Gawd
Joined
Feb 14, 2013
Messages
131
Curious what you bought? I'm partial to the g502 myself but it's on the expensive end of desktop accessories.
 
Top