Xbox One Controller Vibration Issue on Windows 10/Steam

GameLifter

Gawd
Joined
Sep 4, 2014
Messages
653
For quite a while I've been experiencing an odd issue with the vibration feature on my Xbox One controller when being used on Windows 10 with Steam. What happens is the vibration intensity varies greatly between each time it's activated. For example, in Doom when I jump or fire my weapon causing the controller to vibrate, sometimes it will barely rumble at all but other times it rumbles at full blast and keeps going for a few seconds afterward before stopping. So far I have only noticed this in Steam games with Xbox Configuration Support turned off in the Steam controller settings. When I turn on Xbox Configuration Support it fixes the rumble issue but it introduces a new issue in Doom which is that it makes the right analog stick control the mouse cursor instead of the game. This results in really slow turning and aiming making it an improper fix. In games like Alan Wake with full controller support, turning Xbox Configuration Support on fixes the rumble issue and doesn't introduce any control issues like in Doom. Doom is listed as having partial controller support on its Steam page.

I tried uninstalling and re-installing the drivers for the Xbox One controller and wireless adapter as well and tried a different Xbox One controller. I then tried the controller in wired mode. Same results for all tests. My guess is that when I turn off Xbox Configuration Support in Steam it then relies on the game and Windows 10 for controller support which somehow causes the rumble issue. When I turn Xbox Configuration Support on in Steam it then uses Steam functions for controller support which fixes the rumble problem but introduces other control issues. So, I've been trying to figure how to fix the rumble issue without introducing any other controller issues like the one I described with Doom. Any input would be greatly appreciated!

EDIT: Alright, I figured it out! When you turn on Xbox Configuration Support it turns on a mapping profile for each game and with Doom it happened to make the right stick control the mouse cursor. So, the solution to my problem was to turn on Xbox Configuration Support to fix the rumble, right click Doom in my Steam library, select Edit Steam Controller Configuration, then change the right stick from mouse cursor to game movement or whatever they called it. I'm happy I finally found out the solution to this problem but at the same time a little annoyed that Steam changed so much about how it recognizes controllers and that their default profile for Doom has the right stick acting as a mouse cursor. What a dumb decision! Before all these changes it just all worked. Oh well, glad it's fixed!
 
Last edited:
Top