Windows Server 2012 R2 switching to ACHI after installing with IDE enabled in the BIOS

Deadjasper

[H]ard|Gawd
Joined
Oct 28, 2001
Messages
1,960
Anybody who has ever done this knows you won't get back into Windows. I went searching for a solution and found tons of them and they all involved editing a registry entry that does not exist in Windows Server 2012 R2. So I kept looking and stumbled upon this web page -

https://www.codewrecks.com/post/old...2012-r2-switching-to-ahci-after-installation/


Answer was as simple as rebooting the server, go into the BIOS, change the SATA controller to ACHI. Then boot the server into safe mode. Then do a normal reboot. Problem solved.

I spent hours on this problem so I thought I'd post it here it hopes that it might save some other poor soul some time, grief and aggravation.
 
  • Like
Reactions: djoye
like this

Mazzspeed

2[H]4U
Joined
Dec 27, 2017
Messages
2,902
Anybody who has ever done this knows you won't get back into Windows. I went searching for a solution and found tons of them and they all involved editing a registry entry that does not exist in Windows Server 2012 R2. So I kept looking and stumbled upon this web page -

https://www.codewrecks.com/post/old...2012-r2-switching-to-ahci-after-installation/


Answer was as simple as rebooting the server, go into the BIOS, change the SATA controller to ACHI. Then boot the server into safe mode. Then do a normal reboot. Problem solved.

I spent hours on this problem so I thought I'd post it here it hopes that it might save some other poor soul some time, grief and aggravation.
It's the same fix for Windows 10, I'm actually surprised you've never come across it before.
 
Top