Windows 7 Won't Recognize Blu-Ray drive?

Discussion in 'General Hardware' started by SAgosto, Mar 11, 2013.

  1. SAgosto

    SAgosto Limp Gawd

    Messages:
    488
    Joined:
    Dec 28, 2007
    I must be missing something. I have a Blu-Ray drive that opens/closes as expected but isn't recognized by Windows 7. I confirmed the drive works in another machine. My MOBO has 4 SATA and 2 are being used by SATA HDs. The SONY DVD and LG DVD are old IDE drives. I have 2 open SATA but needed to use a molex/sata converter from monoprice for the Blu-Ray's power. What am I missing? Shouldn't windows just find the next open letter drive and that's it?

    Relevant hardware:

    PHARCYDE-SRVR-1
    =================
    COOLER MASTER Centurion 5 Mid Tower Case (CAC-T05-UW)
    COOLER MASTER Exteme Power 650W PS (C283-1144)

    GIGABYTE AM2 AMD 690V Micro ATX (GA-MA69VM-S2)
    COOLER MASTER 92mm Hyper TX2 CPU Cooler (RR-CCH-L9U1-GP)
    AMD Athlon X2 5600+
    CORSAIR XMS2 4GB DDR2800 (PC26400)

    Seagate 400GB SATA/300 7200RPM 16MB Cache HD (ST3400620AS)
    Western Digital Caviar Green 2TB 32MB Cache HD (WD20EADS)

    GECUBE Radeon HD3850 256MB 256-bit (GC-HD3850PG3-D3R)

    Pioneer SATA Blu-Ray DVD-ROM/12X DVD±R DVD Burner (BDC-202BK) *** NOT RECOGNIZED ***
    SONY DVD RW (DW-Q30A)
    LG CD-RW (CED-8120B)
     
  2. ninjaturtle

    ninjaturtle 2[H]4U

    Messages:
    2,327
    Joined:
    Dec 25, 2004
  3. SAgosto

    SAgosto Limp Gawd

    Messages:
    488
    Joined:
    Dec 28, 2007
    That didn't work. It seems to only work with recognized drives.
     
  4. mrtheshaggy

    mrtheshaggy [H]ard|Gawd

    Messages:
    1,211
    Joined:
    Jun 28, 2003
    Few things to try...

    Check your devices and see if there are any unrecognized sata devices.

    Go into your bios and see if your motherboard is identifying the drive.

    Swap the BluRay sata with the HD sata you don't boot from and see if it works.

    Go to you disk management and see if it's there.
     
  5. SAgosto

    SAgosto Limp Gawd

    Messages:
    488
    Joined:
    Dec 28, 2007
    It's not recognized in the Device Manager.

    The BIOS doesn't identify it. There are a few open channels in the list too. Will the use of the IDE drives mean I can't use the 4 available SATA connections?

    Disc Management shows the 2 physical drives and the 2 from Daemon Tools. Not the Blu-Ray.


    I need to swap the drive with the non bootable sata HD to see if it works (I should have done this awlready).
     
  6. mrtheshaggy

    mrtheshaggy [H]ard|Gawd

    Messages:
    1,211
    Joined:
    Jun 28, 2003
    Go to bios, click integrated peripherals, and see what your sata type is set to. Try swapping it to different options (except raid). Should be a AHCI, and two different IDE options. Give them all a try.
     
  7. ninjaturtle

    ninjaturtle 2[H]4U

    Messages:
    2,327
    Joined:
    Dec 25, 2004
    Sorry about that, I thought for reason you had it working before in that system.
     
  8. DesertCat

    DesertCat Gawd

    Messages:
    565
    Joined:
    Jun 14, 2006
    I highly suspect that you are running into a conflict with having PATA DVD drives and a SATA Blu-ray in the same system. Though it's been about 4 years ago and didn't have as many drives as you have, I ran into a conflict like that on an AMD board. The motherboard is probably expecting all of the DVD drives to be on the same interface and gets freaked out trying to deal with two different interfaces.

    Have you tried unplugging your two PATA drives from the motherboard and just having the SATA blu-ray installed?
     
  9. KILLER_K

    KILLER_K [H]ardness Supreme

    Messages:
    4,597
    Joined:
    Feb 6, 2008
    Sounds more like a controller setting issue to me in the bios. I would turn them all on and boot and see if it shows in the menu then.
     
  10. SAgosto

    SAgosto Limp Gawd

    Messages:
    488
    Joined:
    Dec 28, 2007
    No problem. Thank you for the help.

    I was thinking the exact same thing and just ran out of juice. Currently, SATA 0 and 1 ports are being used. The HD wasn't recognized when I tried SATA 2 or 3. Is there some setting that would disable this by default? Perhaps the PATA drives causing the conflict? No matter what SATA port (even tried a different cable) I used, I couldn't get the Blu-Ray SATA to be recognized. If it is indeed an issue with PATA/SATA, do I have any options to make it work? IDE -> SATA converter? Not sure if it exists.

    http://download.gigabyte.eu/FileList/Manual/motherboard_manual_ga-ma69vm-s2_e.pdf

    My BIO has a OnChip SATA setting that works fine with Native IDE but BSOD upon boot with SATA/AHCI used.

    OnChip SATA Type
    Native IDE Set the SATA channel to Native IDE mode.(Default value)
    RAID Set the SATA channel to RAID mode.
    Legacy IDE Set the SATA channel to Legacy IDE mode.
    SATA/AHCI Set the SATA channel to AHCI mode. Advanced Host Controller Interface (AHCI) is an interface specification that allows the storage driver to enable advanced
    Serial ATA features such as Native Command Queuing and hot plug.
     
  11. KILLER_K

    KILLER_K [H]ardness Supreme

    Messages:
    4,597
    Joined:
    Feb 6, 2008
    Because you need to do the registry hack to use the AHCI mode. As you didn't use it to install the os with it to start with. That is the whole problem you are having. Use this to fix it as it i a easy thing to solve.

    Code:
    1. Startup "Regedit
    2. Open HKEY_LOCAL_MACHINE / SYSTEM / CurrentControlset / Services
    3. Open msahci
    4. In the right field left click on "start" and go to Modify
    5. In the value Data field enter "0" and click "ok"
    6. exit "Regedit"
    7. Reboot Rig and enter BIOS (hold "Delete" key while Booting
    
    In your BIOS select "Integrated Peripherals" and OnChip PATA/SATA Devices. Now change SATA Mode to AHCI from IDE.
     
  12. SAgosto

    SAgosto Limp Gawd

    Messages:
    488
    Joined:
    Dec 28, 2007
    This fixed my issue. Thank you.

    After I made the registry setting, the Blu-Ray DVD player was in the Device Manager under Drives. I then rebooted and it shows up at the next letter drive available. It isn't in the BIOS under IDE channels though. What exactly did that setting do to fix my problem?