Windows 7 59Hz issue

evilsofa

[H]F Junkie
Joined
Jan 1, 2007
Messages
10,078
While installing Windows 7 64-bit, I ran into the 59Hz issue, where the refresh rate for the monitor can only be set to 59Hz; whenever I set it to 60Hz (which was available) it would revert to 59Hz. After some googling, I found two interesting threads:

http://forums.guru3d.com/showthread.php?t=301860
http://forums.techpowerup.com/showthread.php?t=100814&page=2

The guru3d post explains it's not really a bug; it's about a long-standing issue of 59.94Hz vs 60Hz and whether Windows rounds up or down; in Win7, 59Hz is actually 59.94Hz (read the whole original post, too long to quote here). However, some improperly coded games are affected by the issue. Those games include, and I quote the guru3d post, BF2 (and any sequel, or game based off the BF2 engine), WiC (works at 59hz according to pSXAuthor) and CoH.

In the techpowerup thread, post #20 further explains the issue, and suggests the problem extends to all DX10 games (but I have no way of knowing if it actually does).

When i couldnt use 60Hz, all my DX10 games would revert to 30Hz interlaced. Many games read the listing (in this order of priority)

60Hz (Progressive)
60Hz (Interlaced, aka 30Hz)
59Hz (progressive)
50Hz (Progressive)

When 59Hz is chosen in windows or is supported in the game - no problem. But when it doesnt work, the games chose the "next best" thing - which isnt 59Hz, they think 60Hz interlaced is higher than 59 progressive, so we get 30Hz.
Other comments in the threads showed that whether or not the 59Hz issue causes problems is highly variable: some displays have problems with this issue and some don't; some displays can have a problem with an HDMI connection but have no problem with a DVI or VGA connection; some dual display setups can have problems with this issue and some don't.

Post #33 of the techreport thread described a fix for nVidia cards, which I have modified slightly to reflect what I had to do:

- Go to Nvidia Control Panel
- Go to Add resolution
- Create Custom Resolution
- Click on Timing
- Click on Manual
- Set refresh rate to 60.001 Hz
- Press Test
- Restart Windows

This worked for my nVidia card running the 191.07 Win7 64bit driver, but I did need to restart Windows for the change to take effect; after applying this fix but before I restarted, my NEC 20WMGX2's OSD reported 59.7Hz; after the restart, it reported 60Hz. My other NEC 20WMGX2 on my Mac Mini reports 59.7Hz, even though it is set to 60Hz in the Displays System Preference.

Post #2 of the techpowerup thread quotes another techpowerup thread with a fix for ATi cards:

-Open CCC
-Navigate to the Attributes Tab
-Check off Reduce DVI Frequency on High Resolutions Displays
-Change the Refresh rate to 60Hz
-Right Click on the Desktop > Screen Resolution > Advance Settings > Monitor Tab > Change Screen Refresh Rate to 60Hz
-Done (you can reboot to see if the refresh rate sticks)

Addendum
Only use the above fix if this allows your monitor's on screen display (OSD) to read 60Hz refresh rate (Typically we are talking about a resolutions of 1920x1200. Other refresh rates may vary on resolution). If your monitor's OSD read's 59Hz as a refresh rate revert the setting in CCC and win7 back to it's original state. Check again to make sure that your OSD reads 60Hz this time. You may need to reboot before your screen reads 60Hz again (pending that you know for a fact that your monitor always read 60Hz as a refresh rate at that resolution). For Radeon users this means all you do is install your Cat Driver. Don't make any changes to refresh rates in CCC. For others there maybe another way to fix it.
“If you have a monitor that exposes ~59.94 (and no other frequency that we would use for 60), we enumerate both 59 and 60 and whichever you set, we set 59.94 and persist 59.94. When the UI asks what mode we’re in we tell it we’re in 59, as you see. This is the issue we had back at the end of February when we were trying to make the last minute fixes but in the end we decided that it was too late. So it is by design for now.”
I don't have an ATi card so I can't comment further on the ATi fix.
 
Last edited:

brumwald

Gawd
Joined
Aug 1, 2006
Messages
598
Great post!

Other comments in the threads showed that whether or not the 59Hz issue causes problems is highly variable: some displays have problems with this issue and some don't; some displays can have a problem with an HDMI connection but have no problem with a DVI or VGA connection; some dual display setups can have problems with this issue and some don't.
Though this doesn't make sense to me. This is purely a software issue, right?
Okay that the 59 Hz-in-windows might depend on the input etc. but once windows *decides* to show 59 Hz it shouldn't matter what monitor you have connected. If it does then the 59 Hz part of the issue only seems to be half the truth.
 

evilsofa

[H]F Junkie
Joined
Jan 1, 2007
Messages
10,078
Though this doesn't make sense to me. This is purely a software issue, right?
Okay that the 59 Hz-in-windows might depend on the input etc. but once windows *decides* to show 59 Hz it shouldn't matter what monitor you have connected. If it does then the 59 Hz part of the issue only seems to be half the truth.
I don't feel like I understand the issue well enough to say who's to blame.
 

Koslov

[H]ard|Gawd
Joined
Aug 31, 2003
Messages
1,889
hmm I can't press test after putting 60.001 -- impossible to 'set' only 60.000
any idea?
9600GSO, win7 x64
 

evilsofa

[H]F Junkie
Joined
Jan 1, 2007
Messages
10,078
hmm I can't press test after putting 60.001 -- impossible to 'set' only 60.000
any idea?
9600GSO, win7 x64
I'm just guessing, but you may be running into the issue that's discussed in the Addendum to the ATi solution - the monitor may not be able to show more than 59.94Hz. This may or may not actually cause problems for you.
 

Shane_c82

Gawd
Joined
Mar 26, 2004
Messages
812
I can set mine to 60 from 59 no probs:confused:
Then I guess you don't have the 59 refresh rate problem. So why did you post that? :confused:

I had this problem with one of the beta builds...I just installed my Win 7 Pro upgrade from the digitalriver deal and no longer have any problems with any games.
 

deadman_uk

[H]ard|Gawd
Joined
Jun 30, 2003
Messages
1,945
I am still having this problem (ATI user) there is no "Reduce DVI Frequency on High Resolutions Displays" option in CCC for me.
 

evilsofa

[H]F Junkie
Joined
Jan 1, 2007
Messages
10,078
Bumping this post to note that an issue with Two Worlds 2 and dual monitors was apparently resolved with this tweak, in this thread.
 

Ultra Wide

[H]ard|Gawd
Joined
Jul 23, 2000
Messages
1,397
I don't think it's the display. I had a 9800GT and it would insist on using 59Hz, then I got a GTX460, still the same monitor, now it reports 60Hz.
It's annoying but not a big concern.
 
Top