Windows 10 network sharing settings

Discussion in 'Operating Systems' started by NukeULater, Jan 8, 2019.

  1. NukeULater

    NukeULater Gawd

    Messages:
    900
    Joined:
    Sep 12, 2006
    This is a pretty dumb question but nothing I've found has worked so far. What settings do you need to access public folders on windows 7 computers from windows 10? They are in the same workgroup and I can see the other computers from the windows 10 machine. It just can't access them and the generic 0x80070035 error pops up. You can access the windows 10 machine from the windows 7 computers though. I have SMB1 turned on, but it really shouldn't be needed for these two os's.

    I know I'm overlooking something basic, just don't know what it might be.
     
  2. Mazzspeed

    Mazzspeed [H]ard|Gawd

    Messages:
    1,414
    Joined:
    Dec 27, 2017
    Can you access the shares using the IP address?

    Eg: //IP Address/folder name
     
  3. NukeULater

    NukeULater Gawd

    Messages:
    900
    Joined:
    Sep 12, 2006
    Just tested that and the following error comes up.

    "You can't access this shared folder because your organization's security policies block unauthenticated guest access. These policies help protect your PC from unsafe or malicious devices on the network."

    All the sharing settings are set to allow access to public folders on both public and private networks. I can also ping the other machines. I'm really stumped since I've never had any issues with basic network settings before.
     
  4. pendragon1

    pendragon1 [H]ardForum Junkie

    Messages:
    11,177
    Joined:
    Oct 7, 2000
    firewall?
    try going into settings and enable the lower encryption.
    https://www.tenforums.com/tutorials/51024-change-file-sharing-encryption-level-windows-10-a.html
     
  5. NukeULater

    NukeULater Gawd

    Messages:
    900
    Joined:
    Sep 12, 2006
  6. Algrim

    Algrim [H]ard|Gawd

    Messages:
    1,355
    Joined:
    Jun 1, 2016
    It sounds like you don't have guest access turned on for Windows 7 but you do for Windows 10.
     
    pendragon1 likes this.
  7. Easius

    Easius Limp Gawd

    Messages:
    332
    Joined:
    Jan 1, 2009
  8. Mazzspeed

    Mazzspeed [H]ard|Gawd

    Messages:
    1,414
    Joined:
    Dec 27, 2017
    Map the drives using //IP Address/share.

    As Easius has stated, SMB1 has, thankfully, been depreciated under all OS's and not just Windows, it even affects network discovery under Linux. The easiest thing to do is to simply map shares as IP addresses, or make use of the hosts file if an IP address is too difficult to remember.
     
  9. NukeULater

    NukeULater Gawd

    Messages:
    900
    Joined:
    Sep 12, 2006
    Finally found the issue last night. There's a problem with running admin privileges on both machines. Apparently it messes up basic network access and disables SMBv2 sharing. Change the following registry key and everything will work like normal again.

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]"AllowInsecureGuestAuth"=dword:1
     
  10. Executioner

    Executioner Limp Gawd

    Messages:
    292
    Joined:
    Apr 22, 2015
    Just wanted to THANK YOU for your excellent solution to networking on 1809 version of win 10. This was driving me nuts for the last couple of days. I had to enable SMB v1 in order to get it to work. Your solution was great - a simple mod to the registry. I have a simple network at home with windows 7, 8, and a Linux laptop. Now I have this windows 10 laptop. It all now works again - my win10 laptop can now access the shared folders on win7.
     
    pendragon1 and Armenius like this.
  11. Sparky

    Sparky 2[H]4U

    Messages:
    3,199
    Joined:
    Mar 9, 2000
    I wonder if this will fix Win 10 to Win 10 machines?
    Trying to access the Company File for Quickbooks from a laptop but cant see the Master PC.
     
  12. pendragon1

    pendragon1 [H]ardForum Junkie

    Messages:
    11,177
    Joined:
    Oct 7, 2000
    this fix might help with explorer finding the network shares but you should have a mapped drive for that.