Windows 10: Annoying Clock Problem

Astralogic

Gawd
Joined
Apr 24, 2012
Messages
580
Hi, could someone help me solve this annoying issue with my clock please? Whenever I start my computer the clock is one hour behind, so I have to go into the clock settings and disable "set time automatically" then re-enable it and it sets itself to the right time, which is always one exact hour behind. I have to do this every time I start my computer.

Any ideas?

Thanks
 

BrotherMichigan

Limp Gawd
Joined
Apr 8, 2016
Messages
211
Check your time zone and try setting the "Set time zone automatically" option. Additionally, make sure you have the "Adjust for daylight saving time automatically" option turned on.
 

Astralogic

Gawd
Joined
Apr 24, 2012
Messages
580
Check your time zone and try setting the "Set time zone automatically" option. Additionally, make sure you have the "Adjust for daylight saving time automatically" option turned on.
My time zone is set to auto, but my "adjust automatically for daylight saving" option is grayed out and I can't enable it. That must be the issue I think.
 

Azrak

Gawd
Joined
Oct 4, 2015
Messages
889
Is the time zone correct when you look? If the selected TZ does not follow daylight savings, the "adjust for daylight saving automatically" option will be greyed out.
Also, is the BIOS time correct?
Editing to add: If you don't move your computer to other timezones, I would set it manually and leave "set time automatically" enabled.
 

bigdogchris

[H]ard as it Gets
Joined
Feb 19, 2008
Messages
17,953
In order for any of that "set automatically" time/timezone stuff to work, you need to set your location either through Maps and Location section in Settings. Windows never prompts you to do any of that, so out of the box automatically set timezone is broken since it took me 4 years to figure this out.
 
Last edited:

Astralogic

Gawd
Joined
Apr 24, 2012
Messages
580
I've tried all suggestions, and yes my bois time is correct, but the problem still persists.
 

auntjemima

[H]ardness Supreme
Joined
Mar 1, 2014
Messages
5,640
In order for any of that "set automatically" time/timezone stuff to work, you need to set your location either through Maps and Location section in Settings. Windows never prompts you to do any of that, so out of the box automatically set timezone is broken since it took me 4 years to figure this out.
Thanks! I'll try this when I get home. Have had this issue for years.
 
Top