Win7 not indexing this one folder I have

provoko

Gawd
Joined
Aug 6, 2004
Messages
656
I can't index this one folder I have which I'm calling X. I can index every other folder on that drive, but not X. I want to index X.

So far I've tried:
Rebuilding
Right clicking X and clicking advanced and unchecking then rechecking "allow files in this..."
Removing and then adding the folder to indexing options
Making sure the file types are selected in indexing options

WTF did I do to folder X????

Thank you for your help.
 

provoko

Gawd
Joined
Aug 6, 2004
Messages
656
I know, confusing. How about this: What are the reasons why a folder wouldn't be indexed?
 

provoko

Gawd
Joined
Aug 6, 2004
Messages
656
Your missing 2 X's from the title of your folder you want Indexed.

Haha.

Ok so I don't know what I did, so I deleted X and copied my backed up X folder and it works.

X was my pictures folder and my music folder. I had backed up the files. For some strange reason my music/picture files lost the ability to be indexed, but the backed up files are perfectly indexable. I still don't know why.
 

heatlesssun

Extremely [H]
Joined
Nov 5, 2005
Messages
44,154
There are file and directory properties that can disable indexing. Right-click on a folder or file and then click the "Advanced. . ." button in the "Atributes:" section of the dialog. Make sure the second option is checked: "Allow files in this folder to have contents indexed in addition to file properties".

This is something that I've had to watch out for files that I download that I want to be indexed. Sometimes this attribute isn't selected and I've gone crazy trying to figure out why some stuff wouldn't index. This was ALWAYS the problem except in one case where a one particular PDF wouldn't index properly, but just that on file and yet another copy DID index properly AND the attributes referenced above were set properly. Who knows. But overall indexing in Windows 7 is a godsend. Yes I know Windows was late to the game a bit in search but have made up for it quite a bit I think.
 
Last edited:

provoko

Gawd
Joined
Aug 6, 2004
Messages
656
There are file and directory properties that can disable indexing. Right-click on a folder or file and then click the "Advanced. . ." button in the "Atributes:" section of the dialog. Make sure the second option is checked: "Allow files in this folder to have contents indexed in addition to file properties".

This is something that I've had to watch out for files that I download that I want to be indexed. Sometimes this attribute isn't selected and I've gone crazy trying to figure out why some stuff wouldn't index. This was ALWAYS the problem except in one case where a one particular PDF wouldn't index properly, but just that on file and yet another copy DID index properly AND the attributes referenced above were set properly. Who knows. But overall indexing in Windows 7 is a godsend. Yes I know Windows was late to the game a bit in search but have made up for it quite a bit I think.

Nah, that was definitely checked. I even unchecked it, waited, checked it, waited, no difference.
 
Top