win10 extra click to open desktop icons


Limp Gawd
Mar 5, 2009
So i just upgraded to Win10 from Win7 and noticed I have to click an extra time (3 clicks) to open desktop icons if I'm browsing in a different window. This is extremely annoying. Is this supposed to happen in Win10?

For example: I'm using Google Chrome and it's the active window, if I want to open a desktop icon I have to triple click the icon (1 click makes the desktop the active window; then the double click opens the icon).

edit: from what I've researched, it's not a Win10 problem and people have had this issue on older OS's. Still haven't found a solution; workaround for now is to change my files open with a single click instead of a double click.

edit2: problems solved. I had a corrupt DLL that I fixed by typing "regsvr32 /i shell32.dll" in the "run app"
Last edited:
Do you have to double click to open a window to start with? I have not noticed any difference between 10 and 7 or 8 once the options are set. Control Panel>Appearance and Personalization>File Explorer Options.
After a lot of googling I fixed the problem. My shell32.dll was corrupt and I had to fix it.
Mine does not do this. My browser has focus, I simply move the mouse to a desktop icon, double click, boom it opens. Sorry it's not a solution - but at least confirmation that something is not right. Works just like win 7 did for me :(