Unlinked [Username's] Documents folder in "My Computer"

Spawn85

Weaksauce
Joined
Dec 11, 2006
Messages
71
I am currently running an OEM version of Windows XP Home.

I have recently had a worm attack my system, and I ended up having to run a symantec removal tool on it. I ran the removal tool from my "My Documents" folder. When I restared my system and hit the good ol' win+d to get to "My Computer" and clicked on the "My documents" folder (on the right side of the window, not the explorer menu bar on the left) and noticed that the link of the folder was pointing to:

C:\Documents and Settings\LocalService

and not to "My Documents". A screenshot is attached below.

Does anyone know the registry value that sets this link, or know of another way to fix this issue?

Thanks

[img=http://img118.imageshack.us/img118/1534/s1ri7.th.gif]
 

Dew

2[H]4U
Joined
Jun 23, 2003
Messages
3,813
Do a properties on the "My Documents" icon, you can input a new path there.
 

Spawn85

Weaksauce
Joined
Dec 11, 2006
Messages
71
Dew said:
Do a properties on the "My Documents" icon, you can input a new path there.
Thanks, but this only works on My Documents in the Folders explorer on the left. The linkage of this folder is fine. When i do a properties on "My Documents" the link points to the proper place: C:\Documents and Settings\[Username]\My Documents

My issue is that when i double click on the [username]'s documents on the right, the link is pointing to the path: "C:\Documents and Settings\LocalService". This path cannot be edited through the right-click, properties method.

Any other ideas?
 

Spawn85

Weaksauce
Joined
Dec 11, 2006
Messages
71
I found the registry value:
\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\DocFolderPaths

Then edit the path in [Username] value to point to:

C:\Documents and Settings\[Username]\My Documents
 
Top