Thermaltake = RMA

VulturEMaN

Gawd
Joined
Sep 11, 2005
Messages
1,017
Anyone have experience with TT's RMA? I'll be sending it back later on today, that shitty 680W PSU of shittiness :p

Honestly...I was playing 2 days ago and it crashed...I thought 'Oh well...prolly just Steam again' so I rebooted and started playing again...but realized that SLI was disabled. So now I was really ready to flood the steam forums with angry posts....but then yesterday morning, the darn comp wouldn't even turn on :(

I'd love to reuse the PSU for my next build, but there are too many cables and too many crappy voltages....I might just get rid of the new one thermaltake send me right away...
 

joemama

[H]F Junkie
Joined
Sep 13, 2000
Messages
9,576
I have a bias against TT psu's (flakey purepower 420w that I trashed) but are you sure it's the psu causing this? I would try it on a secondary rig or maybe a friends machine first...your mobo may be crapping out.
 

Tt Tech

Thermaltake Rep
Joined
Jul 7, 2005
Messages
150
Oh, the 680W....


Go ahead and RMA it. Make sure u choose Advanced Service so we send you the new unit first.
 
Joined
Mar 1, 2005
Messages
3,094
Tt Tech said:
Oh, the 680W....


Go ahead and RMA it. Make sure u choose Advanced Service so we send you the new unit first.
Are there still 2 totally different PSU's labled W0049?
 

VulturEMaN

Gawd
Joined
Sep 11, 2005
Messages
1,017
Tt Tech said:
Oh, the 680W....


Go ahead and RMA it. Make sure u choose Advanced Service so we send you the new unit first.

Wow...it's good to know that there is a TT rep on here :p

But seriously...good thing that I didn't RMA it yet, cause I didn't choose Advanced Service...

EDIT: btw, the new MOZART TX VE1000SWA just blew me away. It's huge and....well...huge.
 
Top