Test Individual Drives in Raid

cthulhuiscool

2[H]4U
Joined
Mar 15, 2006
Messages
2,990
I have a 3 disk striped raid, and I think one of the drives is starting to go. When I download or write to it in high speeds I get a click. Is there a way I can test each one individually to tell which (if any) is faulty?
 

drescherjm

[H]F Junkie
Joined
Nov 19, 2008
Messages
14,916
1. I would stop the raid.
2. Test each disk individually on a different machine with a badblocks (available on linux live iso/usb releases) non destructive test. I stress non destructive test.

https://wiki.archlinux.org/index.php/badblocks#read-write_Test_.28non-destructive.29

You also probably want to create a backup of your array as well. I would do that before the testing.

With all of the above the SMART raw data for each disk may tell you the answer without needing to test.
 

mwroobel

Supreme [H]ardness
Joined
Jul 24, 2008
Messages
5,019
drescherjm makes a great suggestion on how to test the drive, but keep in mind with a 3 drive striped array if your drive finally fails during testing your array is gone. Do not attempt this unless you have a complete (at least one) backup of your data. Depending on your controller you may or may not be able to poll the individual drives for SMART, and many times a click will not manifest itself as a problem in the SMART data.
 

cthulhuiscool

2[H]4U
Joined
Mar 15, 2006
Messages
2,990
Thankfully I didn't have that much vital data, and was able to back it up and delete the raid volume. I'm running SeaTools atm, if they doesnt turn anything up I'll give the Linux method a try.
 

cthulhuiscool

2[H]4U
Joined
Mar 15, 2006
Messages
2,990
So an update: Seatools came up clean so I tried the above menthod, also clean. I also tried to reproduce the issue by writing to each individual drive and the sound did not present itself.
I recreated the raid volume and tested again, sound came back. It's very subtle, one quiet click every 5-10s or so. Does this tell you guys anything?
 

Zangmonkey

2[H]4U
Joined
Jul 6, 2005
Messages
3,970
I've heard that a light click every 5-10s leading into inactivity if is the drive trying to self-lubricate or maintain the head
 
Top