Become a Patron!

Supermicro X8SIL-F

Discussion in 'Virtualized Computing' started by olskool, Apr 25, 2015.

  1. olskool

    olskool n00bie

    Messages:
    6
    Joined:
    Mar 22, 2007
    I recently came into possession of a Supermicro X8SIL-F a Xeon X3450 and 16GB ECC Unbuffered RAM for an ESXi server. I can't get USB pass-through to work. I was wondering if anybody was able to get USB pass-through to work and if so what version of ESXi was used?
     
  2. farscapesg1

    farscapesg1 2[H]4U

    Messages:
    2,250
    Joined:
    Aug 4, 2004
    I thought I had it working under 4.1 and 5.0u1.. but then ran into the same issues a lot of people did with 5.1. If no one else answers you, I'll see if I can fire the old host up and test is with 5.5. Never had a ton of use for it in my home lab, so when it broke during 5.1 I just kinda gave up on passing USB through.

    What exactly is it doing or not doing? Purple screen when you try to start a VM with the USB passed through? Looses the settings on reboot? Or does it not even give you the option?
     
  3. olskool

    olskool n00bie

    Messages:
    6
    Joined:
    Mar 22, 2007
    I'm running 5.5u2 right now. When I try to start a VM the Error message says "Failed to register the device pciPassthru1 for 0:29.0 due to unavailable hardware or software support"

    Edit: I guess all I need to know is if someone can confirm if it works with 5.0 or resolve this error message.
     
    Last edited: Apr 25, 2015
  4. Netwerkz101

    Netwerkz101 Gawd

    Messages:
    661
    Joined:
    Jul 11, 2010
    I have no clue but was curious about the issue.
    A question came to mind .. are you using the same USB controller that you
    are attempting to pass through.

    As I typed that .. i realized it would not be available in the pass through device list then...oh well...nvm that.

    A quick google search on your error yielded:
    http://nickbasham.blogspot.com/2014/09/upgrade-to-esxi-55.html

    I am wondering if my PowerEdge T110 would have the same issue under 5.5 (same 3420 chipset as the X8SIL-F).
    May try that later.
     
  5. olskool

    olskool n00bie

    Messages:
    6
    Joined:
    Mar 22, 2007
  6. Netwerkz101

    Netwerkz101 Gawd

    Messages:
    661
    Joined:
    Jul 11, 2010
    I may have muddied the waters on your thread .. but it seems to work for me.
    I did not actually have to pass through the host USB controllers (ie configuration/Advanced settings)

    PowerEdge T110 (same 3420 chipset)
    ESXi 5.5 U1

    Win7 x64 VM - added "USB Controller" + VMware Tools

    Tested Kingston DataTraveler USB drive = successful reading/writing files
    Tested Fuji USB Scanner using TWAIN driver = successful scanned doc into MS Paint
    Tested Toshiba USB DVD-RW drive = not recognized/not working - not sure why not

    I should add it was a fresh install of ESXi 5.5 U1 - no special mods.
     
  7. olskool

    olskool n00bie

    Messages:
    6
    Joined:
    Mar 22, 2007
    I did try it that way and it didn't work but I only tried ESXi 5.5 U2. Guess I'll just have to take the time and try all version except 5.1 (I know everybody hand problems with that)

    Thanx for you help!!!
     
  8. AMD_Gamer

    AMD_Gamer Pick your own.....you deserve it.

    Messages:
    18,374
    Joined:
    Jan 20, 2002
    Does anyone run ESXi 6.0 on this?
     
  9. olskool

    olskool n00bie

    Messages:
    6
    Joined:
    Mar 22, 2007
    Sorry I should have updated this thread.

    USB pass-through works great on this board with ESXi 6.0
     
  10. AMD_Gamer

    AMD_Gamer Pick your own.....you deserve it.

    Messages:
    18,374
    Joined:
    Jan 20, 2002
    Does anyone still use this board for ESXi 6.5? Curious if it is still works ok?
     
    Last edited: Jul 4, 2017
  11. lopoetve

    lopoetve Imhotep

    Messages:
    28,795
    Joined:
    Oct 11, 2001
    It'll work fine, but you'll get a notice that the CPU will lose support in a future release soon. Those are old Nehalem/Westmere chips.