Become a Patron!

Strange Intel AMT remote KVM issues (could be HW?)

Discussion in 'Motherboards' started by JediFonger, Jan 10, 2017.

  1. JediFonger

    JediFonger 2[H]4U

    Messages:
    2,752
    Joined:
    Jan 2, 2003
    ASUS Q170M-C running i5-6600k

    BIOS=3016

    AMT info:

    MEBx Version 11.0.0.0010
    FW Version 11.6.10.1196
    LMS Version 11.6.0.1039
    MEI Driver Version 11.6.0.1032
    MEI DeviceID PCI\VEN_8086&DEV_A13A&SUBSYS_86941043&REV_31\3&11583659&0&B0
    SOL Driver Version 11.6.0.1009
    SOL DeviceID PCI\VEN_8086&DEV_A13D&SUBSYS_86941043&REV_31\3&11583659&0&B3

    I cannot remotely (from a different computer) connect to my Q170 no matter what I do (yes i Have a monitor hooked up to it and it is in use, I'm using it now!). i also have multiple Q170s and they all work fine. i've tried:

    -RESETTING BIOS on motherboard

    -DISABLE & RE-ENABLE physical jumper PIN on motherboard

    -Unprovision, disable AMT from BIOS and also from AMT menu many many times.

    -I've used KVMControlApplication.exe (from 11.6 SDK package), Mesh Commander 0.4.2, Intel Manage Commander 1.0.8 and nothing works.

    Here is an error from Intel MC 1.0.8 Error:

    KVMRedirectionSAP, RequestStateChange Error 400.

    Here are the workflows that has worked on many Intel AMT KVMs I've worked with previously and have been successful with:

    -Within BIOS enable AMT (if not enabled)

    -ctrl+p into the AMD configuration, enter default admin password, change pw and proceed to enable network IP

    -I use KVMControlApplication.exe to "edit machine settings and change KVM Status to Enabled - all ports

    -Then I can use any tool like VNC Viewer to connect and manage product out of band.

    Are there commandline methods to change this KVM Status setting without resorting to UI? Seems like there is an issue with a variety of UI programs adjusting this 1 setting to redirect the port.

    IS THIS a HW-component issue?

    I would like to add that when I first purchased and stood this machine up the remote KVM worked fine. It was post 11.6 FW that it stopped working for some strange reason.

    vPro Platform Solution Manager query shows:

    Exception: Attempt to use an unsupported feature: KVM is not supported by the Intel AMT device.
    Source: HLAPI
    Stack Trace: at Intel.Manageability.Impl.AMTInstanceManager.get_KVMSetup()
    at Plugins.IDER.ctrlIDERDetails.OpenSessionExists()
    at Plugins.IDER.ctrlIDERDetails.checkAllowStates()
    at Plugins.IDER.ctrlIDERDetails.CheckIfSourceProvided()
    at Plugins.IDER.ctrlIDERDetails.UserControl_Loaded(Object sender, RoutedEventArgs e)
    at System.Windows.RoutedEventHandlerInfo.InvokeHandler(Object target, RoutedEventArgs routedEventArgs)
    at System.Windows.EventRoute.InvokeHandlersImpl(Object source, RoutedEventArgs args, Boolean reRaised)
    at System.Windows.UIElement.RaiseEventImpl(DependencyObject sender, RoutedEventArgs args)
    at System.Windows.UIElement.RaiseEvent(RoutedEventArgs e)
    at System.Windows.BroadcastEventHelper.BroadcastEvent(DependencyObject root, RoutedEvent routedEvent)
    at System.Windows.BroadcastEventHelper.BroadcastLoadedEvent(Object root)
    at MS.Internal.LoadedOrUnloadedOperation.DoWork()
    at System.Windows.Media.MediaContext.FireLoadedPendingCallbacks()
    at System.Windows.Media.MediaContext.FireInvokeOnRenderCallbacks()
    at System.Windows.Media.MediaContext.RenderMessageHandlerCore(Object resizedCompositionTarget)
    at System.Windows.Media.MediaContext.RenderMessageHandler(Object resizedCompositionTarget)
    at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Boolean isSingleParameter)
    at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Boolean isSingleParameter, Delegate catchHandler)


    PS Could this be a HW component issue?
     
  2. alanzh

    alanzh n00bie

    Messages:
    2
    Joined:
    Jan 10, 2017
    Hi JF,

    today I've faced with the same issue with the same motherboard, ASUS Q170M-C.
    This one was fresh just out-the-box, I've played with BIOS AMT settings including un-configure option to understand how it works. After that I've switched on AMT network access and went home to configure this machine remotely.

    And at home I realized that AMT KVM doesn't work with the VNC Viewer plus error saying
    "Failed to access resource IPS_KVMRedirectionSettingData, check user permissions"
    when I've launched MeshCommander there was no "Redirection Port" feature listed under "Active Features" and when I'm trying to add one, "KVMRedirectionSAP, RequestStateChange Error 400" error appears. After that Redirection Port feature appears in the list but that doesn't make any change. The same error 400 appears when I'm trying to run "KVM Set State" script in the MechCommander.

    I never used Q170 chipsets before and I thought that was my mistake configuring it (probably because of some new features added) but after your post it seems that it is BIOS/ME/firmware related issue. At the same time I could connect to ISM with web browser and MeshCommander. It seems that some KVM-related parameters are locked after manipulations with ME (un-configuration in my case?). Unfortunately I couldn't say now if KVM was OK with the new MB before my intervention.

    I have to mention some differences with your configuration:

    1) I have no monitor connected to MB (it wasn't necessary in the earlier Q chipsets at all!)
    2) I haven't updated MB BIOS and ME: BIOS ver. 0801, ISM FW 11.0.0-build 1168
    3) Different CPU is used: intel Core i5-6400
    4) The only changes I've made with BIOS setting were in intel AMT section

    I will let you know If I will find the workaround. By the way could you please also check your BIOS setting regarding default GPU? Try to force it to use CPU graphics (not auto mode!), maybe it will help, I could not check it before I could get to this machine physically.
     
    Last edited: Jan 10, 2017
  3. JediFonger

    JediFonger 2[H]4U

    Messages:
    2,752
    Joined:
    Jan 2, 2003
    mine might be different issue as i've configured many hp, lenovo, dell laptops and desktops. i also have other q170s working no problem.

    so from your description you're missing a step:
    https://software.intel.com/en-us/amt-sdk/download

    unpack that and go into bin and grab kvm and use that app. you can either do it remotely or use 'localhost'

    edit machine settings you must also set rfb pw in addition to setting kvm status to redirect all

    save the setting and that should allow remote kvm.

    for onesie twosies this is well and fine but if you need to configure hundreds+ use intel scs and scripting

    they also have powershell cmdler modules if u wish
     
  4. JediFonger

    JediFonger 2[H]4U

    Messages:
    2,752
    Joined:
    Jan 2, 2003
  5. alanzh

    alanzh n00bie

    Messages:
    2
    Joined:
    Jan 10, 2017
    My problem is the same as yours because I'm using my VNC Viewer Plus as KVM viewer with many Q chipsets but not tried it on Q170 and I have the same error codes.

    Thank you for the information! I was sure that my i5-6400 is VPro enabled processor but ark.intel.com says that it isn't (( It was so with some "K" unlocked processors before but never with "non-K" models!

    But it's still strange that your config worked well before upgrading BIOS/FW... Today I have figured out that KVM is actually working on my system just a few seconds after full reset (BIOS and ME switches on the motherboard) before CPU identification. After that KVM server breaks the connection and locks the KVM feature.
     
  6. JediFonger

    JediFonger 2[H]4U

    Messages:
    2,752
    Joined:
    Jan 2, 2003
    if i think about i i do now remember i used to have the i5-6600t which does have vpro. after i upgraded to the i5-6600k is when it stopped working. so all of it holds up. the key is to have a supported ecosystem for vpro to work