Site to Site VPN with cisco asa 5505 +checkpoint

The Spyder

2[H]4U
Joined
Jun 18, 2002
Messages
2,628
I am trying to get this setup without having to admit defeat to the other tech at the other end of my Site to Site VPN.

Hardware:
My end: Comcast Business Internet -> SMC gateway (x.x.x.22) -> cisco asa 5505 (static Ip of x.x.x.18, part of the block of 5 from comcast)

Their end: Checkpoint gateway

Check Point External Gateway IP Address: x.x.x.93
Internal Network: Network is x.x.x.0/23

VPN SETUP SHEET:
Select Traditional mode configuration
Under Traditional mode configuration
Support key exchange encryption with: 3DES
Support data integrity with: MD5
Support authentication methods: Pre-Shared

Under Advanced settings in Traditional mode IKE properties
Support Diffie-Hellman groups for IKE (phase 1) Security associations Group 2 (1024 bit)
Renegotiate IKE (phase 1) Security associations every 300 Minutes or 18000 seconds
Renegotiate IPsec (IKE phase2) Security associations every 21600 seconds or 360 minutes.
*notes-

Does not support aggressive mode
Does not support Perfect Forward Secrecy (PFS)

ciscoasa# show config
: Saved
: Written by enable_15 at 15:53:02.232 UTC Mon Dec 8 2008
!
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.0.2 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address x.x.x.18 255.255.255.248
!
interface Vlan3
no nameif
security-level 50
no ip address
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
access-list outside_1_cryptomap extended permit ip 192.168.0.0 255.255.255.0
x.x.202.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 x.x.x.22 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer x.x.x.93
crypto map outside_map 1 set transform-set ESP-3DES-MD5
crypto map outside_map 1 set security-association lifetime seconds 21600
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash md5
group 2
lifetime 18000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns 68.87.69.146 68.87.85.98
!

tunnel-group x.x.x.93 type ipsec-l2l
tunnel-group x.x.x.93 ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:f998d32edf4355bf14d9a55f8da7d776
ciscoasa#

I believe I am missing something in my access lists. Advice?

EDIT*
Just noticed under my access lists-> addresses that the hosts networks netmask x.x.x.0/23 is showing as a /24 object. When I try to change this netmask, it only lets me go from 24-30, not lower. Ideas?
 
Your missing your NAT for one

access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 x.x.x.x 2x.x.x.x
nat (inside) 0 access-list inside_nat0_outbound

Your cmd should look something like this

Code:
access-list outside_20_cryptomap extended permit ip x.x.x.x 255.255.255.0 x.x.x.x 255.255.0.0 
access-list inside_nat0_outbound extended permit ip x.x.x.x 255.255.255.0 x.x.x.x 255.255.0.0
nat (inside) 0 access-list inside_nat0_outbound
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map outside_map 20 match address outside_20_cryptomap
crypto map outside_map 20 set pfs 
crypto map outside_map 20 set peer {Other Ends IP Address} 
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
tunnel-group {Other Ends IP Address} type ipsec-l2l
tunnel-group {Other Ends IP Address} ipsec-attributes
 pre-shared-key 12345678901234567890asdfg

Edit, made some adjustments
 
Did you try running the Site-to-Site VPN wizard from ASDM? Honestly that thing will usually get everything setup right for you the first time if you fill out the blanks correctly. I would just delete all the VPN crap from the config and start up from scratch using the wizard.
 
I was using the wizard. Dunno why I was missing the access route- checking it out now.
(I drove into work in a my Mazda 3, no chains/snow tires, while 90% of everyone else stayed home because of 2" of snow and ice :(, just to work on this. lol)
 
I was using the wizard. Dunno why I was missing the access route- checking it out now.
(I drove into work in a my Mazda 3, no chains/snow tires, while 90% of everyone else stayed home because of 2" of snow and ice :(, just to work on this. lol)


So, both my parents walked to school in 5 feet of show, barefoot, uphill both ways!
 
Best way to add this in? (Cmd instructions or through the ASDM?)

access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 x.x.x.x 2x.x.x.x
nat (inside) 0 access-list inside_nat0_outbound

Thanks!
 
see, that's why you need the VPN action. So you can stay home and work. :D

I have a VPN at home to my SBS, works great!

However I have this box tied to a single PC and off our network due to some security restrictions from the company at the other end of this VPN :(
 
Best way to add this in? (Cmd instructions or through the ASDM?)

access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 x.x.x.x 2x.x.x.x
nat (inside) 0 access-list inside_nat0_outbound

Thanks!

Did that work?
 
Check my first post in this thread.

I am failing with cmd line. I keep getting errors, lol. Basic instructions?
 
Back
Top