I have a 4-disk raidz for non-critical storage on my zfs server. 640GB WD blue drives. The host OS (centos7) was warning me about smart issues on one drive. I ran a long smart test on it and it says:
# 2 Extended offline Completed: read failure 20% 20915 1216029173
Various articles tell me to write a block of zeros to that sector and it will remap it. It doesn't. Here are the (I believe) germane smart fields:
Reallocated_Sector_Ct 0
Current_Pending_Sector 21
Offline_Uncorrectable 1
The drive shows as 'healthy'. As I alluded to, if I write to it, it doesn't remap. The dd fails with 'input/output error', and the above counts do not change. This doesn't sound good?
# 2 Extended offline Completed: read failure 20% 20915 1216029173
Various articles tell me to write a block of zeros to that sector and it will remap it. It doesn't. Here are the (I believe) germane smart fields:
Reallocated_Sector_Ct 0
Current_Pending_Sector 21
Offline_Uncorrectable 1
The drive shows as 'healthy'. As I alluded to, if I write to it, it doesn't remap. The dd fails with 'input/output error', and the above counts do not change. This doesn't sound good?