SATA detection Problem

JethroXP

[H]ard|Gawd
Joined
Oct 2, 2003
Messages
1,181
I've been fighting this problem for two days now, and I just solved it, so I thought I'd post this knowledge nuggest for anyone else who may run into the same thing.

The issue, *AFTER* upgrading my CPU, two brand new 400GB SATA drives were not being detected in the BIOS of my Abit IS7. Prior to the CPU upgrade, one of the drives was detected and worked fine (at that point I had only tried one).

The issue was that Abit Auto settings for the CPU were somehow not setting the correct PCI bus speed. Sure, at boot up it was displaying 66/33 for AGP/PCI, but it must have been different internally because the new SATA drives simply would not get detected.

With my previous CPU, I was overclocking, so I was using the "User Defined" settings, including setting the AGP/PCI clocks to "Fixed" at 66/33MHz. With the new CPU, I used the default "Auto" settings as I wanted to get everything setup before overclocking. So for two days I tried to figure out why my new 400GB SATA drive worked on my old CPU, but not my new one. I thought maybe I had a power issue, or a signaling issue, or a bad drive. But then on a whim I changed the CPU settings from Auto to User defined, and left everything default, but set AGP/PCI to "Fixed" at 66/33. To my amazement, it detected the drives just fine after that.

So the moral of the story, force the AGP/PCI clock to 66/33 and don't rely on Auto Detection.

For those curious about the system upgrade, this is what I did:

Mobo: Abit IS7 (unchanged)
CPU: P4 2.4C -> P4 3.4E
Video: ATI AIW 9800Pro -> ATI AIW X800XT
HD: 160GB SATA + 250GB SATA -> 400GB SATA + 400GB SATA

And I added a Gig-e NIC.

New HDs are Western Digital Caviar SE16s.
 
Top