RivaTuner's Fan Function does not work

Jul 31, 2005
I am using the latest RivaTuner to adjust my 7900GS' fan speed. I set it to 25% 2D, 30% low gaming, and 40% high gaming. However, it does not work!! I am using Windows XP Pro. I also have the latest Nvidia drivers from their website and their nTune program installed.
I don't know what's causing it because I just upgraded my card (6800gt to 7950gt), drivers (84.21 to 93.71), and riva tuner (using 2.01) all today, but the fan controller isn't working for me either. It's hot as hell in my house and I'd like to have my fan go faster than the default 30/40% to keep my new GPU nice and cool.
Go to Guru3d.com and go to the rivatuner section. There are links to guides on how to set up what you want to do. Also it appears that if you run ntune, it and rivatuner appear to cancel each other out. My rivatuner settings werent sticking, I removed Ntune and lo and behold my rivatuner settings now hold.:eek:
I'm not using any other utility than RivaTuner, and I tried one of those guides. Didn't work because my card's fan just doesn't respond to the fan speed settings. For instance if I tell it right now to have 2D speed of 100%, it won't budge from the standard 30%. I know my fan is capable of going a lot faster because it's loud as hell at startup, so I presume Riva is at least reporting correct speeds in the hardware monitor.

Anybody using Riva to control the fan on their eVGA 7950gt? Mine is the 256mb version, but I believe it has the same exact cooler and is probably very similar overall to the 512.
Just installed a 8800 in a fresh system yesterday. My Rivatuner fan function does not work either. Maybe it's because of the new drivers? Anyone with 158.22 have them working?
did you use the software setting or the lowlevel driver setting?
Driver. The fan tab doesn't show up for low level options, only NVstrap.

I also am unable to monitor the FAN speed. It doesn't show up as an option.
Just installed a 8800 in a fresh system yesterday. My Rivatuner fan function does not work either. Maybe it's because of the new drivers? Anyone with 158.22 have them working?

158.22's here and RivaTuner 2.01. eVGA 8800GTS. Fan utility works fine for me. I didn't do anything special, it just works. I also have NTune installed. So, who knows.
RivaTuner 2.01 fan controls a no-go for me also, no option there. The fans on these 7900 GS KO's are much to loud when ANY 3d app or game starts. Wish they'd fix this. Seems to be quite an issue for ALOT of people :(
From what ive found seems to be how the Nvidia driver installs !!! If the Nvidia driver dosnt install clean you will not have Fan under Rivatuner and wont show the Lowlevel fan when riva starts ...Ive found under XP/XP pro 32bit/ Xp Pro x64bit and Vista x64Bit Nvidia driver fan issue does suk!!!!! They need to fix it ASAP:(

Posable fix when Rivatuner wont load properly when Nvidia Drivers does not speed up the fan...Uninstall Nvidia display driver/ and Ntune /uninstall Rivatuner...Reboot...Then install New Nvidia Driver 158.19 or higher then install Rivatuner after you have Verified that the Nvidia card is reconized in Nvidia Control.....Then try to run the RivaTuner App...... This can take several try's in some cases due to Nvidia driver install..

With RivaTuner make shure you click the( Customize button under TARGET ADAPTER)....Click the Video card and then see if you have FAN tab!!!! if not RivaTuner wasnt detected or the Ndia driver did not properly install....

Under the Fan tab you should beable to Check the Boxes..(ENABLE LOW LEVEL FAN) and (Fixed 100%duty cycle)....then Check box (APPLY FAN SETTINGS at WINDOWS START UP)...then Apply settings at bottom ...Do not enable NVSTRAP DRIVER !!!!!

Now if you have that so far ,Go to the next (CUSTOMIZE )button below DRIVER SETTINGS ..Click the (FAN TAB ) see if you can Check the( APPLY THESE SETTINGS at WINDOWS STARTUP)..they should be able to read 100% then click Apply at bottom ,,and do not change any Overclock settings yet !

I will only OVERCLOCK .....After i have made shure the Fan was running 100% all the time or switching 2D low to 3D high when changing to Game !!!

Check too see if your fan speeds up ...If it dosnt the Nvidia Driver is not letting your Graphics card out of 2Dmode Fan setting ...BEFORE i even installed Rivatuner i checked to see if the Nvidia Driver was turning my fan up in 3D mode and it was Not....I then installed Rivatuner the same way As i did above on three different Pc's x2 3800- 939- Vistax64 Os 6800oc128mb 93.71 driver,,, 754-3200+ Oced @2.4 Os XP pro32bit 8600GTS 158.19driver and AM2 3200+@2.4hz DDR2 960Hz Oc with 8800GTS320 Oced 648/1512/1650...160.02 Quadro Driver Beta ......ALL Three systems work with RIVATUNER With out any problems ..But i have found that each of them were Messed up with the Nvidia Fan Control on the new Drivers!!!!!!!!!!:mad: I use RIvaTuner to run FAN CONTROL on all 3machines:D
Sry did edit ...was working on two different post for the same thing ..

If the nvidia driver dosnt install 100% sometimes Rivatuner will conflict and wont have some options ....It can cause rivatuner to not have a FAN control tab

Make shure you are using the MOST RECENT RIVATUNER which i believe you are 2.01 and you may have too uninstall / reinstall driver several times !
But I do have the fan tab. It just doesn't function. Maybe I'll try uninstalling/reinstalling the drivers.
I HOPE THIS IS EASIER FOR YOU :D Rivatuner 2.01 Screen shots...

If you have fan tab does your screen look like this ?See where it says CUSTOMIZE...Click it then Click the Video Card you should have this Screen!


You Need to make shure you Check the Box for (ENABLE LOW LEVEL FAN CONTROL)!!!

Then take it off( AUTO) and make shure it is GREEN dot next to((Fixed 100% FAN control))

Second: check the BOX that says (APPLY FAN SETTINGS at WINDOWS STARTUP)
Third: Click APPLY at very bottom of PAGE then Ok......(It is cut off from my screen shot)

This will give you your LOW LEVEL FAN at Windows StartUp!

Ok now you see this Screen below,,,you get here by Clicking the Second CUSTUMIZE BOX under DRIVER SETTINGS and click CUSTOMIZE Then CLICK videoCard!

This is your ALL your fan settings control i set mine to 100% and then make Shure you (CHECK THE BOX) that says (APPLY FAN SETTINGS at WINDOWS STARTUP)then click APPLY at bottom of page and click OK ....Now Your FAN will Be set to High!.....


ALWAYS Check FAN after in a 3D application , open a game or what ever 3D app you have make shure your fan is On High if it isnt it will be going slow with lil air or noise!

Only after this if the Fan is not going from low 2D to High 3D fan setting i would reinstall Driver and make shure you DO Not Use Ntune then see if it works...if all else fails you may have a Bad fan or Video Card ...I would suspect Drivers and Ntune..They are no way near optimal at this time as you can see..
Thanks a lot. I will try that for sure. Right now, the fan tab doesn't show up so I'll reinstall my drivers. I don't think I have a bad card because I was able to control it with Ntune.
Alrighty then keep trying ...Its mostlikely combination driver and Riva .....I had to reinstall my 158.19 twice for it to work and only had to install my 160.02 once!...Just take your time the drivers and stuff are really buggy .....Ive never in 10 years seen such crud for drivers!
Good info, but still doesn't work for me.

I have tried the above instructions (with 8600gts, 158.22, 2.01) and the fan tab still doesn't show up. It is apparently a driver/riva thing because every time I load up rivatuner after all the rebooting I get a message saying that my driver is unsupported and to get the latest version of rivatuner.

Has everyone solved this by reinstalling everything? Is there anything else I can do?

I've never gotten the low-level fan tab to show up even before I tried out NTune. It just doesn't want to show up on my 7600GT and the driver controls do nothing.