pfSense on ESXi - Help a noob out.

RabidSmurf

n00b
Joined
Jun 30, 2009
Messages
56
Hey Everyone,

Let me preface this by saying I am by no means a networking or ESX expert and this is not a production environment just a home setup. I am slowly attempting to virtualize as many services (file/web serving, etc) as possible for the purpose of power consumption and just to see if I can learn stuff in the process.

I would like to attempt to move a discrete pfsense box acting as my home network's router/firewall to a VM on my ESXi host. So my initial thought is to give the pfSense VM a dedicated two port NIC via PCI Pass through to act as WAN and LAN interfaces.

I am just a little confused as to how to get vSphere/ESX management functioning when the ESX host currently gets its IP from the router which would no longer work if the router is actually a guest VM (Since it won't be running at startup).

Has anyone else worked out a solution? I am sort of thinking dedicated NIC's between the client and host for ESX management/vSphere purposes but I am not sure how to set this up.

Appreciate your feedback.
 

RabidSmurf

n00b
Joined
Jun 30, 2009
Messages
56
This makes sense, I will have a look when I get some more time to dive into it, thank you fine sir.
 

RabidSmurf

n00b
Joined
Jun 30, 2009
Messages
56
Set the vmkernel interface IP to static.

http://kb.vmware.com/selfservice/mi...nguage=en_US&cmd=displayKC&externalId=1006710

link to do it on the console, you can do it in the inferface though Configuration->Networking->Properties of the vswitch->click on management->edit the settings

this one has photos:

http://www.orinoco-systems.com/blog...Setup-Part-2-The-ESXi-host-Management-Network

Setting the static IP on ESX host as well as client PC did the trick, so thanks for that.

For some reason I wasn't sure whether routing would function without the router even with a static IP. It seems obvious now, you'd think I'de know these things given my line of work but eh, learn something new every day.

Thanks for the tip!
 
Top