Nvidia flickering with UWP apps

Flapjack

2[H]4U
Joined
Apr 29, 2000
Messages
3,200
This is driving me crazy, and I've tried just about everything to fix it. The only thing I can find is that UWP apps don't support 10-bit/HDR color. I'd love to dump all UWP apps and never have the issue, but it seems like they're becoming more and more common (ie: Citrix Workspace, Wickr Pro, etc).
Sometimes it's only one monitor that flickers with on-screen corruption, and sometimes it's all of them. I've even put the HDR settings in the Nvidia control panel down to 8bpc and limited RGB range, but it still does it. Sometimes minimizing the apps stops the flickering, but other times I have to close the app altogether.
Is there a fix for this? It's even worse since the 9/17/2020 driver update.

These are the monitors I've been using. As far as I can remember, I don't recall having this problem. It has only been for a few months, and only since upgrading from a GTX 1070 to the RTX 2080 Super.
https://www.gadgetreview.com/samsung-u28e590d-review

Oh... my card is an RTX 2080 Super and I'm running three Samsung 28" 4K/60hz monitors (all via DisplayPort).
 

Flapjack

2[H]4U
Joined
Apr 29, 2000
Messages
3,200
I actually didn't realize there was a new nvidia driver update (9/30/2020). This issue has persisted over multiple driver updates, but it looks like this one may have done the trick!
 

Flapjack

2[H]4U
Joined
Apr 29, 2000
Messages
3,200
Disregard. The driver update didn't fix it. It might be a *little* better, but it still happens. This is absolutely and totally ridiculous. I'm wondering if it's my monitors?
 
Top