Need help troubleshooting HDR on DELL UP2718Q

Discussion in 'Displays' started by Andyk5, Jul 28, 2018.

  1. Andyk5

    Andyk5 [H]ard|Gawd

    Messages:
    1,151
    Joined:
    Jul 27, 2011
    My HDR works fine over HDMI 2.0 with a PS4 Pro. It used to work fine with my Desktop PC over HDMI 2.0 as well until windows forced an update on me and now the colors are all shades of green and pink. Interestingly when I connect the computer to an LG OLED E6 TV, HDR on windows works again, albeit the blacks have some white pixel flickering, but the color issue does not show.

    PC is a Windows 10 Pro, Build# 10.0.17134, Video card is GTX1080. I don't remember the Windows version that it used to work at but at some point I managed to revert back to it and it worked, I now don't have that option anymore.
    How the screen looks like when HDR is enabled is attached.

    Ps: I tried display port and the result is the same.
     

    Attached Files:

  2. Andyk5

    Andyk5 [H]ard|Gawd

    Messages:
    1,151
    Joined:
    Jul 27, 2011
    Update: When I change Nvidia color settings from RGB to YCr... the issue goes away.
     
  3. Armenius

    Armenius [H]ardForum Junkie

    Messages:
    15,408
    Joined:
    Jan 28, 2014
    Check to see if Windows managed to bork your driver installation. Probably wouldn't hurt to do a clean install of the latest driver with DDU either way.

    Check the NVIDIA control panel color settings. There should be an option to either let Windows manage the color or the driver to do it. Try changing this setting to the opposite of what you set and see if RGB is working again. My PG27UQ is working fine with HDR over DisplayPort on Windows 10 build 17134.191 and GeForce driver 398.36 with color management set to use Windows.

    FYI: 4K HDR10 can only be transmitted over HDMI at 60 Hz using 4:2:2 chroma subsampling. I'd switch to DisplayPort for full RGB.
     
    Andyk5 likes this.
  4. Andyk5

    Andyk5 [H]ard|Gawd

    Messages:
    1,151
    Joined:
    Jul 27, 2011
    Thanks, I used DDU in safe mode and then re installed latest Nvidia drivers. I also switched to a display port cable. Display being in Dynamic HDR vs Normal does not change the behavior.

    RGB 10 or 8 bit, Full Range or Limited Range (all 4 possibilities) are still showing as the attached picture, hues of pink and green

    444 10 or 8 bit Limited works with HDR, does not provide Full option
    422 8 bit does not allow HDR to be turned on, 10 bit works albeit still Limited.

    So my issue is I can't use RGB and losing out on Full output dynamic range due to having to use 444 and I can't figure it out for the life of me.
     
  5. Andyk5

    Andyk5 [H]ard|Gawd

    Messages:
    1,151
    Joined:
    Jul 27, 2011
    I still have this issue, HDMI or minidisplay port does not work.... Why would RGB all the sudden not work and why I can't find anyone else to replicate the problem is beyond me.
     
  6. euskalzabe

    euskalzabe Gawd

    Messages:
    780
    Joined:
    May 9, 2009
    If it helps, the only way I get my 1060 to display hdr correctly is at 422 8bit rgb. Even then it’s software dependent: mass effect andromeda in hdr for me looks exactly like that purple/green mess you have. Sometimes it gets stuck with the wrong color upon switching to sdr and only a reboot will fix it. I blame immature drivers.
     
  7. Andyk5

    Andyk5 [H]ard|Gawd

    Messages:
    1,151
    Joined:
    Jul 27, 2011
    I hope this is something that is going to get resolved with drivers