need help: SACD skips when play thru HDMI port

Discussion in 'Home Theater PCs & Equipment' started by Happy Hopping, Feb 9, 2019.

  1. Happy Hopping

    Happy Hopping [H]ardness Supreme

    Messages:
    6,415
    Joined:
    Jul 1, 2004
    I just bought a Yamaha Universal blu-ray player, BD-A1060, this is set up to play CD and SACD to a pair of stereo speaker

    As we all know, with SACD, it only output to analog, if it's detected thru the digital port, there is no sound due to copyright violation.

    So about 1 yr. ago, I use an old Oppo universal DVD player, and bought this gadget from Monoprice, in which it takes a digital HDMI signal and converts to Digital co-ax, and w/ this box, I CAN play SACD thru digital coax port

    https://www.monoprice.com/product?p...7611&cjevent=e383649c2c7d11e9817c01a00a1c0e0e

    This Xmas, I thought I upgrade to a yamaha and thought it can do the same thing. THis is what happens:

    1) play regular CD just fine

    2) play SACD, it skips every so often.

    I then try it w/ a Sony universal blu-ray player, same thing, it also skip ONLY on SACD

    But if I take the sony back to my other room w/ a 5.1 speaker setup, it CAN play the SACD thru HDMI port on to my 5.1 Receiver just fine, no skipping

    I have try different cables, makes no difference.

    Why does it skip on SACD only? on both players?
     
  2. VoodooRufus

    VoodooRufus n00b

    Messages:
    34
    Joined:
    May 23, 2017
    Interesting problem. Are you having the player convert the DSD signal to PCM for the receiver? Can the receiver properly handle the DSD signal?

    Your Monoprice widget only supports the HT audio formats and uncompressed PCM. Something to keep in mind.

    I have my Oppo player output SACD as analog before sending it to my preamp.
     
  3. Happy Hopping

    Happy Hopping [H]ardness Supreme

    Messages:
    6,415
    Joined:
    Jul 1, 2004
    the situation is strange. The player only has DSD signal out or PCM out. I don't think they can convert DSD to PCM. I solve the problem, but I don't know what the cause is. I solve the problem by getting rid of the new Yamaha, and switch to an old Oppo 983 DVD player that has HDMI out. As soon as I switch over to Oppo, everything works. It seems like the Emotiva DAC is trying to decode SACD via PCM out, and it's not processing it properly from the yamaha.