Need help getting my first site up.

C7J0yc3

[H]ard|Gawd
Joined
Dec 27, 2009
Messages
1,353
Ok so here goes. I am looking to put up a site for myself, nothing fancy, so I figure why not give wordpress a go. I have a Ubuntu 10.10 server on a DMZ at home, so I installed all the LAMP packages, installed wordpress, followed the instructions to get it all setup, and everything seemed to be working. However I am not able to get to the server from the outside world. I tried looking at the apache configs and thought I had everything setup properly. I added the lines ServerName thejoycenet.com and ServerAlias *.thejoycenet.com to the config but left everything else the same. I also tried changing the URLs of the wordpress setup, however that didn't help either. I double checked my NAT, and also checked canyouseeme.org to verify that 80 was open.

I am completely lost, and need help badly.
 
Joined
Feb 6, 2005
Messages
780
can you connect and see server's pages locally by entering it's IP? is your config listening on port 80?
 

C7J0yc3

[H]ard|Gawd
Joined
Dec 27, 2009
Messages
1,353
Figured it all out, internal DNS issue, I have been up now for 30 hours strait and methinks its time for bed. Thanks for letting me vent!

Should any of you care the site is thejoycenet.com currently there is only the wordpress hello world page but that will change.
 

PTNL

Supreme [H]ardness
Joined
Jan 2, 2005
Messages
4,199
Also need to update the WP configuration. It thinks the root Url is "localhost" for all links.
 
Top