• Some users have recently had their accounts hijacked. It seems that the now defunct EVGA forums might have compromised your password there and seems many are using the same PW here. We would suggest you UPDATE YOUR PASSWORD and TURN ON 2FA for your account here to further secure it. None of the compromised accounts had 2FA turned on.
    Once you have enabled 2FA, your account will be updated soon to show a badge, letting other members know that you use 2FA to protect your account. This should be beneficial for everyone that uses FSFT.

Migrating Exchange 5.5 to 2003 issues

D3rk

n00b
Joined
Nov 22, 2005
Messages
31
I am having trouble when running ADC, I get this error.
Server QPIBACKUP:389 is not an Exchange 5.5 server or an SRS service.
If you can help please do so, I have researched this problem for hours
and hours.
I have created all fresh log files which I will attach here.

DCDIAG

Domain Controller Diagnosis

Performing initial setup:
Done gathering initial info.

Doing initial required tests

Testing server: Default-First-Site-Name\QPIBACKUP
Starting test: Connectivity
......................... QPIBACKUP passed test Connectivity

Doing primary tests

Testing server: Default-First-Site-Name\QPIBACKUP
Starting test: Replications
......................... QPIBACKUP passed test Replications
Starting test: NCSecDesc
......................... QPIBACKUP passed test NCSecDesc
Starting test: NetLogons
......................... QPIBACKUP passed test NetLogons
Starting test: Advertising
......................... QPIBACKUP passed test Advertising
Starting test: KnowsOfRoleHolders
......................... QPIBACKUP passed test
KnowsOfRoleHolders
Starting test: RidManager
......................... QPIBACKUP passed test RidManager
Starting test: MachineAccount
......................... QPIBACKUP passed test MachineAccount
Starting test: Services
......................... QPIBACKUP passed test Services
Starting test: ObjectsReplicated
......................... QPIBACKUP passed test
ObjectsReplicated
Starting test: frssysvol
......................... QPIBACKUP passed test frssysvol
Starting test: frsevent
......................... QPIBACKUP passed test frsevent
Starting test: kccevent
......................... QPIBACKUP passed test kccevent
Starting test: systemlog
......................... QPIBACKUP passed test systemlog
Starting test: VerifyReferences
......................... QPIBACKUP passed test
VerifyReferences

Running partition tests on : Schema
Starting test: CrossRefValidation
......................... Schema passed test
CrossRefValidation
Starting test: CheckSDRefDom
......................... Schema passed test CheckSDRefDom

Running partition tests on : Configuration
Starting test: CrossRefValidation
......................... Configuration passed test
CrossRefValidation
Starting test: CheckSDRefDom
......................... Configuration passed test
CheckSDRefDom

Running partition tests on : qualitestrx
Starting test: CrossRefValidation
......................... qualitestrx passed test
CrossRefValidation
Starting test: CheckSDRefDom
......................... qualitestrx passed test
CheckSDRefDom

Running enterprise tests on : qualitestrx.com
Starting test: Intersite
......................... qualitestrx.com passed test
Intersite
Starting test: FsmoCheck
......................... qualitestrx.com passed test
FsmoCheck

NETDIAG

Computer Name: QPISERVER
DNS Host Name: qpiserver.qualitestrx.com
System info : Microsoft Windows Server 2003 (Build 3790)
Processor : x86 Family 15 Model 4 Stepping 3, GenuineIntel
List of installed hotfixes :
KB890046
KB891957
KB893756
KB896358
KB896422
KB896424
KB896428
KB898715
KB899587
KB899588
KB899589
KB899591
KB900725
KB901017
KB901105
KB901214
KB902400
KB904706
KB904942
KB905414
KB905915
KB908519
KB908531
KB908981
KB909520
KB910437
KB911562
KB911567
KB911927
KB912812
KB912919
KB913446
Q147222

Netcard queries test . . . . . . . : Passed

Per interface results:

Adapter : Management Network

Netcard queries test . . . : Passed

Host Name. . . . . . . . . : qpiserver
IP Address . . . . . . . . : 192.168.1.2
Subnet Mask. . . . . . . . : 255.255.255.0
Default Gateway. . . . . . :
Dns Servers. . . . . . . . :

AutoConfiguration results. . . . . . : Passed

Default gateway test . . . : Skipped
[WARNING] No gateways defined for this adapter.

NetBT name test. . . . . . : Passed
[WARNING] At least one of the <00> 'WorkStation Service', <03>
'Messenger Service', <20> 'WINS' names is missing.
No remote names have been found.

WINS service test. . . . . : Skipped
There are no WINS servers configured for this interface.

Adapter : Local Area Connection

Netcard queries test . . . : Passed

Host Name. . . . . . . . . : qpiserver
IP Address . . . . . . . . : 10.1.1.12
Subnet Mask. . . . . . . . : 255.0.0.0
Default Gateway. . . . . . : 10.1.1.1
Dns Servers. . . . . . . . : 10.3.1.19
10.1.1.12

AutoConfiguration results. . . . . . : Passed

Default gateway test . . . : Passed

NetBT name test. . . . . . : Passed
[WARNING] At least one of the <00> 'WorkStation Service', <03>
'Messenger Service', <20> 'WINS' names is missing.

WINS service test. . . . . : Skipped
There are no WINS servers configured for this interface.

Global results:

Domain membership test . . . . . . : Passed

NetBT transports test. . . . . . . : Passed
List of NetBt transports currently configured:
NetBT_Tcpip_{E56284CC-DB76-4DD2-B25D-83A81FA7ACD2}
NetBT_Tcpip_{AA0E0120-5A94-4D7E-937D-89E306D22DAD}
2 NetBt transports currently configured.

Autonet address test . . . . . . . : Passed

IP loopback ping test. . . . . . . : Passed

Default gateway test . . . . . . . : Passed

NetBT name test. . . . . . . . . . : Passed
[WARNING] You don't have a single interface with the <00>
'WorkStation Service', <03> 'Messenger Service', <20> 'WINS' names
defined.

Winsock test . . . . . . . . . . . : Passed

DNS test . . . . . . . . . . . . . : Passed
[WARNING] Cannot find a primary authoritative DNS server for
the name
'qpiserver.qualitestrx.com.'. [ERROR_TIMEOUT]
The name 'qpiserver.qualitestrx.com.' may not be registered
in DNS.

Redir and Browser test . . . . . . : Passed
List of NetBt transports currently bound to the Redir
NetBT_Tcpip_{E56284CC-DB76-4DD2-B25D-83A81FA7ACD2}
NetBT_Tcpip_{AA0E0120-5A94-4D7E-937D-89E306D22DAD}
The redir is bound to 2 NetBt transports.

List of NetBt transports currently bound to the browser
NetBT_Tcpip_{AA0E0120-5A94-4D7E-937D-89E306D22DAD}
NetBT_Tcpip_{E56284CC-DB76-4DD2-B25D-83A81FA7ACD2}
The browser is bound to 2 NetBt transports.

DC discovery test. . . . . . . . . : Passed

DC list test . . . . . . . . . . . : Passed

Trust relationship test. . . . . . : Passed
Secure channel for domain 'QUALITESTRX' is to
'\\qpidc01.qualitestrx.com'.

Kerberos test. . . . . . . . . . . : Passed

LDAP test. . . . . . . . . . . . . : Passed

Bindings test. . . . . . . . . . . : Passed

WAN configuration test . . . . . . : Skipped
No active remote access connections.

Modem diagnostics test . . . . . . : Passed

IP Security test . . . . . . . . . : Skipped

Note: run "netsh ipsec dynamic show /?" for more detailed
information

The command completed successfully

****exdeploy-polcheck.log***

[16:41:35] #*** Policy Check began: 05/22/2006 16:41:35 ***#
[16:41:36] Entering HrMapFileHandle
[16:41:36] Leaving HrMapFileHandle
[16:41:36] PolicyTest.exe results:

This tool will check every domain controller in the local
domain to see if the "Manage auditing and security logs"
privilege granted to the "Exchange Enterprise Servers"
group by DomainPrep has replicated to that DC. If the
policy change has not yet replicated to all DCs, then
you should avoid making policy changes on any DC that
has not received those changes yet.

You must have Domain Admin rights to run this tool
successfully. If you see an error that says:
!! LsaEnumerateAccountRights returned error 5 !!
then you don't have permission to open the LSA on the
given DC.

===============================================
Local domain is "qualitestrx.com" (QUALITESTRX)
Account is "QUALITESTRX\Exchange Enterprise Servers"
========================
DC = "QPIBACKUP"
In site = "Default-First-Site-Name"
Right found: "SeSecurityPrivilege"
========================
DC = "QPIDC01"
In site = "Default-First-Site-Name"
Right found: "SeSecurityPrivilege"
[16:41:36] Entering HrFindPrintErrorMessage
[16:41:36] Leaving HrFindPrintErrorMessage
[16:41:36] PolCheck completed successfully.
[16:41:36] #*** Policy Check finished: ***#

*****exdeploy-Progress.log*****

[16:41:34] ********** Beginning Exchange Deployment Tools **********
[16:41:34] Starting Exchange 6944 Deployment Tools on Windows 5.2.3790
at 16:41:34 05/22/2006
[16:41:34] Entering HrDirPreReq_Initialize
[16:41:34] Init called with Domain Controller qpibackup.qualitestrx.com
and Exchange 5.5 server qpibackup. Setup's language ID is 0. ActiveX
Path is (null)
[16:41:34] Entering HrRegisterAXDLL
[16:41:34] Leaving HrRegisterAXDLL
[16:41:34] Leaving HrDirPreReq_Initialize
[16:41:34] Entering HrRegisterAXDLL
[16:41:34] Leaving HrRegisterAXDLL
[16:41:34] HrDirPreReq_CmdLine
(f:\titanium\dsa\src\deploy\dsintegchk\cmdline.cpp:2092). Error code
0XFFFFFFFF(65535).
[16:41:34] Entering HrOrgCheck
[16:41:35] Leaving HrOrgCheck
[16:41:35] Entering HrRunPolCheck
[16:41:35] Entering HrGetDSILog
[16:41:35] Leaving HrGetDSILog
[16:41:35] Entering HrGetDSILog
[16:41:35] Leaving HrGetDSILog
[16:41:36] Entering HrMapFileHandle
[16:41:36] Leaving HrMapFileHandle
[16:41:36] Entering HrFindPrintErrorMessage
[16:41:36] Leaving HrFindPrintErrorMessage
[16:41:36] Leaving HrRunPolCheck
[16:41:36] Entering HrDirPreReq_Terminate
[16:41:36] Leaving HrDirPreReq_Terminate

*****ExDeploy.log******

#*** Exdeploy began: 05/22/2006 16:41:34 ***#
+ Exchange 5.5 Server: qpibackup
+ Global Catalog Server: qpibackup.qualitestrx.com
+ Tools run: PolCheck, and OrgCheck.

- A name for the Global Catalog server has not been provided. Exdeploy
is using an automatically discovered name.
- Error: Could not connect to the Exchange 5.5 server 'qpibackup'.
Tools that require an Exchange 5.5 server will not run.

+ Preparing Active Directory for Exchange Server 2003 (OrgPrepCheck)

- Organization Readiness Check (OrgCheck)
OrgCheck verifies the Exchange extensions to the Active Directory
schema, checks the existence and membership of the Exchange Domain
Servers group and Exchange Enterprise servers group, and checks that a
global catalog server is available in a domain in which DomainPrep has
been run.

Warning: The Exchange Domain Servers group 'cn=Exchange Domain
Servers,cn=Users,DC=qualitestrx,DC=com' does not contain the local
computer 'CN=QPISERVER,CN=Computers,DC=qualitestrx,DC=com'. If the
local computer is not running Exchange Server 2003, this is not a
problem.
OrgCheck completed successfully.

- Policy Check (PolCheck)
PolCheck verifies that the necessary permissions are configured
correctly on domain controllers. Details are logged to
exdeploy-polcheck.log.

PolCheck completed successfully.

#*** Exdeploy finished: 05/22/2006 16:41:36 ***#

(The Next Three are from the DSScope)

***gcvercheck.log****

#*** GC Version Check began: 05/22/2006 16:43:15 ***#
Current Site (Default-First-Site-Name)
Global catalog servers running Windows 2000 SP3 or later:
QPIBACKUP
QPIDC01
Domain controllers running Windows 2000 SP3 or later:
VPIDC02
SERVER1CH
#*** GC Version Check finished: 05/22/2006 16:43:15 ***#

**ExDeply.log**

#*** Exdeploy began: 05/22/2006 16:43:14 ***#
+ Exchange 5.5 Server: qpibackup
+ Global Catalog Server: qpibackup.qualitestrx.com
+ Tools run: DSScopeScan, and OrgNameCheck.

- A name for the Global Catalog server has not been provided. Exdeploy
is using an automatically discovered name.
- Error: Could not connect to the Exchange 5.5 server 'qpibackup'.
Tools that require an Exchange 5.5 server will not run.

+ Planning Your Deployment (DSScopeScan)

- Existing Org Report (OrgReport)
OrgReport checks Active Directory for an existing organization.

Test completed successfully. An organization was created by
ForestPrep. You can rename this organization when you install the
first Exchange 2003 server.
- Global Catalog Server Version Check (GCVerCheck)
GCVerCheck verifies the availability of a global catalog server or
domain controller running SP3 or later in the current or adjacent site.
Details are logged in gcvercheck.log.

GCVerCheck completed successfully. All domain controllers and global
catalog servers in the current and adjacent Windows sites are running
Windows 2000 SP3 or later.

#*** Exdeploy finished: 05/22/2006 16:43:15 ***#

***exdeploy-Progress.log***

[16:43:14] ********** Beginning Exchange Deployment Tools **********
[16:43:14] Starting Exchange 6944 Deployment Tools on Windows 5.2.3790
at 16:43:14 05/22/2006
[16:43:14] Entering HrDirPreReq_Initialize
[16:43:14] Init called with Domain Controller qpibackup.qualitestrx.com
and Exchange 5.5 server qpibackup. Setup's language ID is 0. ActiveX
Path is (null)
[16:43:14] Entering HrRegisterAXDLL
[16:43:14] Leaving HrRegisterAXDLL
[16:43:14] Leaving HrDirPreReq_Initialize
[16:43:14] Entering HrRegisterAXDLL
[16:43:15] Leaving HrRegisterAXDLL
[16:43:15] HrDirPreReq_CmdLine
(f:\titanium\dsa\src\deploy\dsintegchk\cmdline.cpp:2092). Error code
0XFFFFFFFF(65535).
[16:43:15] Entering HrOrgReport
[16:43:15] Test completed successfully. An organization was created by
ForestPrep. You can rename this organization when you install the
first Exchange 2003 server.
[16:43:15] Leaving HrOrgReport
[16:43:15] Entering HrGCVerCheck
[16:43:15] GCVerCheck completed successfully. All domain controllers
and global catalog servers in the current and adjacent Windows sites
are running Windows 2000 SP3 or later.
[16:43:15] Leaving HrGCVerCheck
[16:43:15] Entering HrDirPreReq_Terminate
[16:43:15] Leaving HrDirPreReq_Terminate
 
Don't know whaqt you specific issue is, but i'd get the issue wit DNS resolution of your server resolved first. Even if its not the cause of the issue you are experiencing now, it'll cause you endless issues later.

[WARNING] Cannot find a primary authoritative DNS server for
the name
'qpiserver.qualitestrx.com.'. [ERROR_TIMEOUT]
The name 'qpiserver.qualitestrx.com.' may not be registered
in DNS.

Depending on your config, it looks like your internal IP interface doesn't have any DNS entries. AD is very dpendent on DNS to find the machine it needs to talk to over port 389 (Its going to use DNS to locate a global catalog server with port 389 open to make the ADC connection).

Host Name. . . . . . . . . : qpiserver
IP Address . . . . . . . . : 192.168.1.2
Subnet Mask. . . . . . . . : 255.255.255.0
Default Gateway. . . . . . :
Dns Servers. . . . . . . . :

If the authoritative DNS is being accessed by another external interface, you may be OK, but I didn't see any indication of that.

Some other questions: Is you current Exchange 5.5 Server running on this, or another box? If it is another box and its running something older than 2k server, and you are in 2003 AD mode, you are hosed.

Are you using a static route to handle routing to your internal network, or is your internal network limited to a single subnet? (no gateway entry listed, but you have a class c)
 
That Ip you posted is a management network (direct connection) to another server for a replication software.

My current Exchange server is being ran on anohter box with Windows 2000 installed on it.
(It is not installed on my Domain controller server either, if that has anything to do with it)

Yes we are using a static route to issue out IPs.

Qpibackup is the name of the Exchange 5.5 server and when I try using ADC I recieve this error| Server QPIBACKUP:389 is not an Exchange 5.5 server or an SRS service.

I'm able to telnet to the Exchange server using port 389
I also was able to even bind to the exchange server.
But, ADC won't recognize it. It is very strange.

When the server pings itself it calls back the manage network, yet of course if you ping the server from another client machine you recieve the standard network IP. That is why the error is appearing in the log, due to the managemetn network.
 
Back
Top