Marvell controller HDDs show as removable

Discussion in 'SSDs & Data Storage' started by alitech, Oct 6, 2018.

  1. alitech

    alitech n00b

    Messages:
    2
    Joined:
    Jun 13, 2012
    I have done a whole weeks worth of research and tried everything, nothing works.

    I have rebuilt my computer recently and installed 10 drives in it.

    Config:
    Asus ROG Strix Z270 Gaming MATX board
    i7 6700k
    16GB 2400 RAM
    1TB Samsung EVO 970 NvME
    EVGA 650w G2
    NVidia 1060 3GB
    9x various sized hard disks (platter)
    Fractal Design Node 804 case
    Marvell 88SE92xx based sata expansion card with 4 Sata 6G ports non raid

    I am not the most competant hardware wise, but I usually resolve things by research and trying new things out. This problem is not going away.

    The mobo has 6 Sata ports of which one is disabled as I used one of the nvme slots.

    I bought the sata controller card because I needed to add 9 more drives in there. I am using pretty much all the ports available to me now.

    The problem I am having is that all the drives connected to the Marvell Sata controller are showing as removable drives. I have done everything. The registry editor fix, getting latest drivers for marvell etc etc etc.

    The sata controller shows AHCI passthrough via boot up and I have not been able to access the settings for the controller (not sure I can anyways as its an expansion card connected to PCIE)

    I have also tried to make a single volume by combining all the drives on the marvel controller with MS storage spaces, it doesnt let me do that either.

    I have pretty much exhausted all options that I researched. I am at a loss. Any help is appreciated.

    I am considering getting a better expansion card perhaps from Intel but I am at a loss right now.

    Help please?
     
  2. pendragon1

    pendragon1 [H]ardForum Junkie

    Messages:
    11,548
    Joined:
    Oct 7, 2000
    you should be able to access the cards bios to set what mode it is in. it sounds like its acting as e-sata. try setting usb to legacy or compatible mode in the mobo bios. see if that gets you into the card config. hopefully you dont have any data on the drives as changing the config will require reparation/formatting.

    edit and double check the mobo bios doesn't have any e-sata stuff