Looking for help with Cisco ASA

kkeirnan

n00b
Joined
Apr 20, 2010
Messages
42
Brand new member here. Long time listener, first time caller :D

Looking for some help.

I am somewhat familiar with Cisco devices but the ASA's seem to be a little more complex. What I'm trying to do is setup VPN. At this point I am able to connect to the VPN but cannot ping into the internal network. Computers from inside the network can ping outside VPN clients when they are connected.

Can this be solved using the ASDM? The syntax involved with the CLI seems to be quite different than the devices im used to. Any help would be greatly appreciated.

Thanks in advance!


ASA Version 7.2(4)
!
hostname TDS
domain-name TDS.local
enable password encrypted
passwd encrypted
names

!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.0.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address *.*.*.* 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
domain-name TDS.local
access-list inside_access_in extended permit tcp any any
access-list inside_access_in extended permit ip any any
access-list inside_access_in extended permit tcp any any eq pptp
access-list outside_access_in extended permit tcp any any eq smtp
access-list outside_access_in extended permit tcp any any eq https
access-list outside_access_in extended permit tcp any any eq www
access-list outside_access_in extended permit ip any any
access-list inside_nat0_outbound extended permit ip any 192.168.0.96 255.255.255.224
access-list outside_cryptomap_1 extended permit ip 192.168.0.0 255.255.255.0 any
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool TDS 192.168.2.2-192.168.2.10 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 192.168.0.2 255.255.255.255
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface pptp 192.168.0.1 pptp netmask 255.255.255.255
static (inside,outside) tcp interface www 192.168.0.2 www netmask 255.255.255.255
static (inside,outside) tcp interface smtp 192.168.0.2 smtp netmask 255.255.255.255
static (inside,outside) tcp interface https 192.168.0.2 https netmask 255.255.255.255
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route inside 192.168.2.0 255.255.255.0 192.168.0.1 255
route outside 0.0.0.0 0.0.0.0 173.61.106.1 255
!
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.0.0 255.255.255.0 inside
http 173.61.106.0 255.255.255.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-DES-SHA
crypto dynamic-map outside_dyn_map 60 set pfs group1
crypto dynamic-map outside_dyn_map 60 set transform-set ESP-3DES-SHA
crypto map outside_map 1 match address outside_cryptomap_1
crypto map outside_map 1 set peer 173.61.106.5
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 30
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
crypto isakmp nat-traversal 20
client-update enable
telnet 192.168.1.0 255.255.255.0 inside
telnet 192.168.0.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns 192.168.1.2 interface inside
!
vpnclient server tdsserver
vpnclient mode client-mode
vpnclient vpngroup TDS password ********
dns-server value 192.168.0.2
vpn-tunnel-protocol IPSec
default-domain value tds.local
username ken.kiernan password 2uOzcvLK8k48f2ja encrypted privilege 15
username ken.kiernan attributes
vpn-group-policy TDS
username keith.wagner password rD6flal58I20pwGy encrypted privilege 15
username keith.wagner attributes
vpn-group-policy TDS
group-lock value TDS
tunnel-group TDStype ipsec-ra
tunnel-group TDSgeneral-attributes
address-pool TDS
authorization-server-group (inside) LOCAL
authorization-server-group (outside) LOCAL
default-group-policy TDS
authorization-dn-attributes use-entire-name
tunnel-group TDSipsec-attributes
pre-shared-key *
peer-id-validate nocheck
isakmp ikev1-user-authentication (inside) none
isakmp ikev1-user-authentication (outside) none
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:
: end
 
Your missing the NAT for your VPN pool.

access-list inside_nat0_outbound extended permit ip {Inside Netowrk} 255.255.255.0 {VPN Network} 255.255.255.0
 
Thanks for your help, sorry it took so long to get back. But I entered the above command, and its showing in my access lists, but still no go.

I made some other minor changes over the weekend. I don't think they affected anything. Here is my new running-config:

: Saved
:
ASA Version 7.2(4)
!
hostname tdsASA
domain-name tds.local
enable password xxxxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxx encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.0.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 173.61.106.5 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
domain-name tds.local
object-group service remotedesktop tcp
description remotedesktop
port-object eq 3389
access-list inside_access_in extended permit tcp any any
access-list inside_access_in extended permit ip any any
access-list inside_access_in extended permit tcp any any eq pptp
access-list outside_access_in extended permit tcp any any eq smtp
access-list outside_access_in extended permit tcp any any eq https
access-list outside_access_in extended permit tcp any any eq www
access-list outside_access_in extended permit ip any any
access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list outside_cryptomap_1 extended permit ip 192.168.0.0 255.255.255.0 any
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool NEWtds 192.168.2.2-192.168.2.10 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 192.168.0.2 255.255.255.255
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface pptp 192.168.0.1 pptp netmask 255.255.255.255
static (inside,outside) tcp interface www 192.168.0.2 www netmask 255.255.255.255
static (inside,outside) tcp interface smtp 192.168.0.2 smtp netmask 255.255.255.255
static (inside,outside) tcp interface https 192.168.0.2 https netmask 255.255.255.255
static (inside,outside) tcp interface 3389 192.168.0.2 3389 netmask 255.255.255.255
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route inside 192.168.2.0 255.255.255.0 192.168.0.1 255
route outside 0.0.0.0 0.0.0.0 173.61.106.1 255
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.0.0 255.255.255.0 inside
http 173.61.106.0 255.255.255.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-DES-SHA
crypto dynamic-map outside_dyn_map 60 set pfs group1
crypto dynamic-map outside_dyn_map 60 set transform-set ESP-3DES-SHA
crypto map outside_map 1 match address outside_cryptomap_1
crypto map outside_map 1 set peer 173.61.106.5
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 30
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
crypto isakmp nat-traversal 20
client-update enable
telnet 192.168.1.0 255.255.255.0 inside
telnet 192.168.0.0 255.255.255.0 inside
telnet 173.61.106.0 255.255.255.0 outside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns 192.168.1.2 interface inside
!
vpnclient server tdsserver
vpnclient mode client-mode
vpnclient vpngroup tds password ********
group-policy tds_Employees internal
group-policy tds_Employees attributes
dns-server value 192.168.0.2
vpn-tunnel-protocol IPSec
default-domain value tds.local
group-policy tdsServer internal
group-policy tdsServer attributes
dns-server value 192.168.0.2
vpn-tunnel-protocol IPSec
default-domain value tds.local
group-policy tds internal
group-policy tds attributes
vpn-tunnel-protocol IPSec
address-pools value NEWtds
username jared.adams password kPzoyT0tb/D3GwGU encrypted privilege 15
username jared.adams attributes
vpn-group-policy tds
username ken.kiernan password 2uOzcvLK8k48f2ja encrypted privilege 15
username ken.kiernan attributes
vpn-group-policy tds
username keith.wagner password rD6flal58I20pwGy encrypted privilege 15
username keith.wagner attributes
vpn-group-policy tds
group-lock value tds
tunnel-group tds type ipsec-ra
tunnel-group tds general-attributes
address-pool NEWtds
authorization-server-group (inside) LOCAL
authorization-server-group (outside) LOCAL
default-group-policy tds
authorization-dn-attributes use-entire-name
tunnel-group tds ipsec-attributes
pre-shared-key *
peer-id-validate nocheck
isakmp ikev1-user-authentication (inside) none
isakmp ikev1-user-authentication (outside) none
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:2edd981e8374170ea7cff5fcc1baea63
: end
 
Wipe out your VPN setting and use the template below, replace anything in { } with your specific settings

Code:
access-list remotevpn_splitTunnelAcl standard permit {Internal subnet} {Internal Subnet mask}
access-list inside_nat0_outbound extended permit ip {Internal subnet} {Internal Subnet mask} {VPN subnet} VPN Subnet mask} 
ip local pool vpnpool {VPN Dhcp Pool} mask 255.255.255.0
nat (inside) 0 access-list inside_nat0_outbound
aaa-server windowsias protocol radius
aaa-server windowsias host }Radius Server}
key {Radius key}
radius-common-pw {password}
group-policy remotevpn internal
group-policy remotevpn attributes
dns-server value {DNS Server}
vpn-tunnel-protocol IPSec 
split-tunnel-policy tunnelspecified
split-tunnel-network-list value remotevpn_splitTunnelAcl
default-domain value {Domain}
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto dynamic-map outside_dyn_map 20 set pfs 
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
tunnel-group remotevpn type ipsec-ra
tunnel-group remotevpn general-attributes
address-pool vpnpool
authentication-server-group windowsias
default-group-policy remotevpn
tunnel-group remotevpn ipsec-attributes
pre-shared-key {Key}
 
THANKS!

Where'd you find that? Or did you just type all that stuff out off the top of your head? ;)
 
THANKS!

Where'd you find that? Or did you just type all that stuff out off the top of your head? ;)

I have templates for all kinds of stuff for Cisco ASA's, i could type it all out, but copy paste is faster lol
 
Guess that comes with the experience. Thats pretty smart!

One more question...

Is it ok that my internal lan is on 192.168.0.0 subnet, the vpn pool is on 192.168.2.0 subnet and assuming everyones home computers are on 192.168.1.0 subnet?
 
I've found that working with these devices are quite different than your normal switches and routers. The syntax in the commands seem quite cryptic to me. Do you have a site to recommend that I could read up on these in detail? My google searches dont turn up too much.
 
What kind of reading up do you want to do. Cisco's articles are always good help, but depending on what your looking for, there are others
 
I highly recommend the Cisco Press ASA book which was also recently updated. It covers a fair amount of ground and shows you how to do everything referenced in the book in CLI. I know asdm is tempting to use but to me its not intuitive. Here is a link to the book
 
The ASDM really doesnt make the ASA any easier to use in my opinion. And actually finding decent articles online can be hard.
 
The ASDM really doesnt make the ASA any easier to use in my opinion. And actually finding decent articles online can be hard.

ungghh bs. Creating anything vpn-specific from commandline is a gigantic pain in the ass, along with ACL's that have 20-30 entires in them. ASDM makes that all a breeze.
 
ungghh bs. Creating anything vpn-specific from commandline is a gigantic pain in the ass, along with ACL's that have 20-30 entires in them. ASDM makes that all a breeze.

I guess i'm just old fashion, I think ASDM is good for reviewing what ACL's are in place, but i would much rather wirte them in notepad then paste them into CLI
 
ungghh bs. Creating anything vpn-specific from commandline is a gigantic pain in the ass, along with ACL's that have 20-30 entires in them. ASDM makes that all a breeze.

Oh! so you found one good reason.... reviewing. Guess that makes my entire statment as a whole "BS"?? :rolleyes:
 
ASDM will explode if you have an ASA with access-lists that have around 20,000 lines though... plus I've noticed people tend to go insane with nested objects when they use ASDM more than the command line.

Like most things, command line vs gui is situational and personal preference. If you really hose things up, you'll need to have command line skills for the debugs and console access anyway...
 
As a novice on ASA's I've preferred the ASDM. When I finally got some help with a more experienced network admin he fired up the CLI and fixed some problems I've had with ACLs in just a few minutes. Things that made sense viewing it from the CLI as opposed to the GUI. Most things I can get setup via CLI but when it comes to ACLs I've just never been a pro at them - and unfortunately it's the biggest part to know and get right on an ASA.
 
HUGE thanks to k1pp3r for the template thread. Its a life saver. VPN is up and working however when users connect to the VPN from the outside they cannot get internet on their machines. I connected to the vpn from outside and can also confirm this. Google searches don't turn up much except another person with the same problem posting it on techrepublic with no replies. Is this a problem with the way the VPN is setup or my internal network??
 
Go into the Client profile (In Cisco VPN software) and on the Transport tab, choose, allow local access. The template i gave you should allow split tunneling
 
When inputting your template there was one line:

split-tunnel-network-list value remotevpn_splitTunnelAcl

That threw an error. I don't remember exactly what it said but this must be the reason why remote clients cannot get internet., now that you mentioned split tunneling. I won't be in the office until friday to try any troubleshooting.
 
Do you see this line in your config

access-list remotevpn_splitTunnelAcl standard permit {Internal subnet} {Internal Subnet mask}
 
No.

I'm remoted in to one of our server while I'm sitting here waiting on my plane. Maybe I can figure it out before I board.
 
Edit and paste in these three lines

access-list remotevpn_splitTunnelAcl standard permit {Internal subnet} {Internal Subnet mask}
split-tunnel-policy tunnelspecified
split-tunnel-network-list value remotevpn_splitTunnelAcl
 
Thanks for the help thus far. My plane is boarding. Ill give this a try on Friday when I'm back.
 
Back
Top