Litecoin miners can't connect (cgminer and guiminer-scrypt)

dalekphalm

Limp Gawd
Joined
Jul 30, 2012
Messages
195
Hey guys,

I've been mining Bitcoins using Guiminer for several months now, using an AMD HD 7950 3GB WF card, but as anyone mining knows, the difficulty increases with the ASIC units finally arriving have been becoming too large. Since I don't pay electricity (included in my rent), I can still mine bitcoins and make a bit of cash, but it's dwindling quite rapidly.

I planned to switch over to Litecoin mining, since GPU's are still effective for Litecoin mining, but I'm running into some issues.

So, to start, I've created accounts on 3 different LTC pools:
1) LitecoinPool.org
2) give-me-ltc.com
3) Coinotron.com

I downloaded the Litecoin wallet, and let it sync. I then downloaded Guiminer-scrypt, and entered in my worker login details and server details, and finally selected the HD 7950 from the drop-down list.

I click start, and it continuously says "Connecting", or occasionally "Connection Problems". Looking at the console doesn't give much info, but occasionally the console reports that either there is an invalid URL for the server, or my details are incorrect.

I'm 100% confident that both the URL and the login details are CORRECT, since I've tried it on 3 different pools.

Next, I tried cgminer, using a batch script with all the same details.
I created 3 different batch scripts on my desktop, each identical except for the url and login details:
Code:
c:\cgminer\cgminer --scrypt -o us.litecoinpool.org:9332 -u myusername.worker -p mypassword --thread-concurrency 17920 -I 13 -g 1 -w 256
The cmd prompt window replies with:
Pool 0 slow/down or URL or credentials invalid
No servers were found that could be used to get work from
etc.

No some additional details:
I still have my Bitcoin wallet installed and running.
When I first installed guiminer-scrypt, I still had Guiminer installed.

I then deleted Guiminer and deleted the profile save file hidden in the AppData folder. After, I reconfigured guiminer-scrypt and resaved. No change.

It seems to me like either:
a) None of my workers from the 3 different pools are configured or "active" (it's been several days since I created accounts and created workers, so I doubt this).
or
b) My firewall or something else is blocking the connection.

Can someone please help me out with this? It's incredibly frustrating, since Guiminer with BTC worked no probs, and I haven't changed any firewall settings since then.
 

Morphes

Supreme [H]ardness
Joined
Jul 16, 2001
Messages
4,264
did you ever figure this out? I am having the same issue. I ended up using a linux distro made for LTC so I could start mining but in windows it is still a mystery to me.
 

dalekphalm

Limp Gawd
Joined
Jul 30, 2012
Messages
195
I did indeed figure it out.

Basically long story short, it was a Driver issue. I was using 13.4 drivers, and then I downloaded 13.6 Beta drivers and all my issues went away.

I'm now happily chugging away using cgminer at a kHash rate of about 625 kHash/s.

If you're having similar issues where guiminer "can't connect" or cgminer constantly crashes, then I suggest trying different drivers. Download the latest Beta, or try different ones in the 12.x series.
 
Top