Is my RX 580 busted?

Discussion in 'AMD Flavor' started by McClintoc, Aug 12, 2018.

  1. McClintoc

    McClintoc HIRE ME DAMMIT!

    Messages:
    15,893
    Joined:
    Sep 27, 2005
    I just built a new Ryzen system a couple weeks ago and I put a Radeon RX 580 in it. My complete specs are in my sig. I also got a brand new monitor a couple days ago. I was really wanting to use the DisplayPort but whenever I try to play a game, the DP stops working and my screen goes black. Here's a run-down:

    • everything works fine when I use the HDMI cable but it seems my screen is locked at 60MHz
    • with the DP, my monitor will run at 144MHz (its native refresh rate) but goes black during games
    • with the DP, I have no issues while in Windows doing mundane stuff and I can even launch games and be in the game menus with no issues; the screen only goes black once I am actually playing
    Is my card messed up, is it the monitor, is it the card drivers? Has anyone had this issue? I have been trouble-shooting and can't figure it out.
     
  2. Araxie

    Araxie [H]ardness Supreme

    Messages:
    6,208
    Joined:
    Feb 11, 2013
    what DP cable are you using?.. it seems to me you have to test with a high quality certified DP cable (with the 20th pin disabled)..
     
  3. McClintoc

    McClintoc HIRE ME DAMMIT!

    Messages:
    15,893
    Joined:
    Sep 27, 2005
    The monitor came with a DP cable but I also bought an aftermarket cable that was highly rated on Amazon.
     
  4. Araxie

    Araxie [H]ardness Supreme

    Messages:
    6,208
    Joined:
    Feb 11, 2013
    tested with both?
     
  5. McClintoc

    McClintoc HIRE ME DAMMIT!

    Messages:
    15,893
    Joined:
    Sep 27, 2005
    Ok, I think it is definitely the video card. I just took out the RX 580 and put in my old R9 290x. Granted, my overall FPS are lower but I am not getting any blackouts. I test the same 3 games and no issues. The DisplayPort on my old R9 290x works just fine. And I am using the aftermarket DP cable with my old card.
     
  6. pendragon1

    pendragon1 [H]ardForum Junkie

    Messages:
    12,444
    Joined:
    Oct 7, 2000
    ddu and newest drivers yet? try another psu just in case.
     
  7. DeathFromBelow

    DeathFromBelow [H]ardForum Junkie

    Messages:
    10,099
    Joined:
    Jul 15, 2005
    The DisplayPort died on my old 290x, it started randomly dropping out in games and then failed.
     
  8. McClintoc

    McClintoc HIRE ME DAMMIT!

    Messages:
    15,893
    Joined:
    Sep 27, 2005
    I was within the Amazon return window so I returned it to them. They sent me a shipping label, I packed up the RX 580 and dropped it at a UPS store today on my lunch break. About two hours later, Amazon issued me a refund as an Amazon gift card. I use the gift card and pay the extra difference to get something top of the line. I've been using Radeon cards since my HD 4870 AGP. I may switch back to Nvidia since nothing seems to compare to a 1080 Ti.
     
  9. McClintoc

    McClintoc HIRE ME DAMMIT!

    Messages:
    15,893
    Joined:
    Sep 27, 2005
    Yup, the first RX 580 I got was busted. I purchased a Sapphire Nitro+ RX 580 Special Edition over the weekend. It arrived today and I am running it now. I just played a few rounds of Rainbow 6 Siege using the DisplayPort. Everything seems to be running fine.
     
    pendragon1 and c3k like this.
  10. c3k

    c3k [H]ard|Gawd

    Messages:
    1,833
    Joined:
    Sep 8, 2007
    Glad to hear you got it sorted!

    And, thanks for posting what worked for you.
     
    McClintoc likes this.