ipcop bummer

thedude42

Limp Gawd
Joined
Nov 12, 2004
Messages
477
anyone using the ipcop addon for FAH ever experience a situation where the FAH client abruptly stops on 2 ipcop boxes simultaneously that are vpn'ed together? mine and my dad's did just that saturday afternoon.
 

thedude42

Limp Gawd
Joined
Nov 12, 2004
Messages
477
sigh... bigger problem. seems the script isn't reading the team and user info properly. although the log from when it went down seemed to have been overwritten or there simply was no verbose on why it stopped, the log clearly shows that i am anonymous and no username.

the "settings" file shows my correct info, but the client.cfg script shows:

[settings]
username=Anonymous
team=0
asknet=no
machineid=1

[http]
active=no
host=localhost
port=8080

[clienttype]
type=2


and even changing it with vi doesn't help once i restart the service, so this is definitely dynamically created. I'm trying to ficure out where it is created from so I can fix the path it uses to get the config data.

anyone savey with batch scripting, here's the rc.folding script in the rc.d directory:

#!/bin/bash

case "$1" in
start)

if [ -f /var/ipcop/folding/enable ]; then
cd /var/ipcop/folding/
./FAH504-Linux.exe
else
exit 0;
fi
;;
stop)
killall FAH504-Linux.exe

;;
restart)
$0 stop
sleep 5
$0 start
;;

*)

esac

exit 0


the /var/ipcop/folding/enable file is totally empty, so i'm wondering if that's the source of the problem here.
 

thedude42

Limp Gawd
Joined
Nov 12, 2004
Messages
477
fixed.

i'm going to stop this thread and start a new one with my findings with a more suitable "possible ipcop bog" tittle.
 
Top