I'm at a loss

Discussion in 'General Hardware' started by tehslippery, Oct 12, 2018.

  1. tehslippery

    tehslippery Gawd

    Messages:
    835
    Joined:
    Feb 17, 2012
    Okay so I don't really know what to do, so I'm posting for some advice.

    A co-worker has a son who was building his own computer. Apparently he built it with a friend who supposedly know's what he's doing, it didn't work. They called a repair guy, repair guy came out and spent an hour and told them it was the power supply. They got a new power supply, didn't work. At this point I got told about all this, they brought it to me to look at, they had the damn motherboard screwed directly to the case, no stand-offs. I tell them that, they take it home. A few days go by, still not working, they bring it to me. They everything was loose, only 2 stand-offs installed, whatever.

    I bring the computer home, take everything out, install it correctly. Apply power, motherboard has power light, and RGB lights, turn it on, nothing. No fans, no boot, nothing. Get a new motherboard since it's probably safe they fried the old through there couple weeks of shenanigans with it screwed to the case. Everything spins up including all case fans, cpu fan, GPU, even powers the keyboard and mouse. CPU QLED is on, don't receive any video output. Get new CPU figuring could have been fried at the same time, nothing changes. Still have the CPU QLED on, everything spins up, no video. I also tried another power supply that I know works after all the part changes.

    This is the build as it stands.

    https://pcpartpicker.com/list/kjNVbX

    Oh, I also tried without the front panel stuff connected and just shorting the power switch to boot, because google tells me some people had issues with the front panel stuff preventing boot

    Edit: Also, RAM isn't on the supported list, would that really cause the CPU QLED instead of the RAM QLED? Along with just no boot? It's the same timings and stuff as things that are on the list.

    Edit 2: Also have an internal speaker plugged into the front panel connectors, no beeps of any kind on power up.
     
    Last edited: Oct 12, 2018
  2. KazeoHin

    KazeoHin [H]ardness Supreme

    Messages:
    7,635
    Joined:
    Sep 7, 2011
    Remove the RAM: if the mainboard screams at you through the speaker, then the board is still breathing.
    Put ONE stick of RAM back in. Test. Move stick to next available slot. Test. Again, move to next slot. Test. Again. Test.
    Do the same thing with ALL other sticks of RAM. Still not working?
    Remove ALL devices except the CPU, ONE stick of RAM and PSU 24 pin and 4/8 pin. Watch the POST code.
    Put in a known working video card, check.
    Replace the PSU with a known working one, check.

    Continue until you find the bastard stalling the system. I see a Gigabyte board in there, my biases tell me it's most likely the issue.
     
    elite.mafia and gigatexal like this.
  3. tehslippery

    tehslippery Gawd

    Messages:
    835
    Joined:
    Feb 17, 2012
    So it turns out it was the RAM, I'm not sure if it was bad RAM or just not compatible. New RAM fixed it though.

    It's really strange to me that with Ryzen RAM that doesn't work just hard stops the boot process, and gives you the CPU QLED on the motherboard, and even prevents any beep codes from happening.
     
  4. FlamingTP01

    FlamingTP01 [H]Lite

    Messages:
    82
    Joined:
    Sep 27, 2018
    That's a bit of a WTF there for me. Any hardware geniuses out there with the answers.
     
  5. Brian_B

    Brian_B [H]ard|Gawd

    Messages:
    1,830
    Joined:
    Mar 23, 2012
    If the mobo was shorted straight to the case, no standoffs - good chance they fried not only the mobo but the RAM as well.

    RAM is finicky stuff. Seems anytime any other component fries, esp the mobo or PSU, the RAM tends to go with it. And it can cause really weird faults, like the one you are seeing.