I7-8700 Turbo Issue

Joined
Nov 18, 2011
Messages
696
I have an I7-8700 NON-K that has worked great up till today. All of a sudden, the only turbo boost that works is the all core 4.3GHZ. It should boost to 4.6 on 1 core, 4.5 on 2 cores, and 4.3 on three cores. Instead, I only get 4.3 on all cores.

I checked the BIOS. Multicore enhancement is off. Turbo Boost is enabled. XMP memory profile enabled.

I reset the bios to stock. Stuck at 4.3.

I reset the above options one by one. Stuck at 4.3

I tried changing the Windows power management. Still no boost for single core speeds. Stuck at 4.3.

CPU temps haven't changed from a year ago.

Does anyone have any have any idea where to go from here?


Specs: Aside from the CPU, ASUS Z370 Strix ITX, Corsair 32GB DDR4-3200, 960 EVO NVME SSD, Corsair SFX 600 PSU, Noctua L12 cooler, CCD MI-6 Case, Windows 10 Pro (latest version), MSI GeFroce 1070 Aero ITX.
 
Last edited:

Polo6RGTI

n00b
Joined
Jun 7, 2018
Messages
34
Hi,

Check the Intel C-State setting in the BIOS. If it is set to Auto then change it to Enabled.
 
Top