Home network question


Feb 5, 2007
Hello all,

I am running a comcast wireless gateway, and an asus AC66u router. The router doesnt have enough ethernet ports for all of my devices (currently has Denon Receiver, seagate Central network drive, Xbox 360, and Xbox One wired in). I have my PS4 wired into one of the 4 wireless gateways ethernet ports.

My issue is that it seems as though the gateway and router are trying to set up multiple networks. My PS Vita is unable to locate my PS4 on the network because it is connected wifi to the Linksys router. I had the same issue with the network drive, if i used the ethernet on the modem i was unable to connect to it using ANY of my devices on the router.

Is there a work-around for this?


Limp Gawd
May 14, 2006
Can't you run the game systems wireless? I've always ran mine wireless with zero issues. As long as you have good signal there won't be any difference in gameplay. Also there are network hubs with more ports you can get. How many you need total?


Feb 3, 2010
You could set one of the routers up to be a client of the other and disable DHCP. Example, if the main router is make the second router's IP and it's gateway, etc.

You could also just replace the second router with a switch which might just make everything easier.


Supreme [H]ardness
Oct 4, 2007
The reason this is happening OP is because the device Comcast gave you is a router. What's happening is your internet connection is getting NAT from the Comcast gateway to a private address:

(Comcast WAN) -> (Comcast LAN) -> (Asus WAN Port) -> (Asus LAN) -

Your devices are on seperate networks if you plug them into the Comcast and Asus.

You could do as Timta2 says and just connect the Asus via a LAN port to the comcast Gateway, and put the Asus in AP mode, rather than router mode. Otherwise, just have comcast put the modem is bridge mode and have your Asus do the NAT to public address space (BEST SCENARIO). Then manage all port forwarding on your Asus and never worry about the gateway. Or you can call Comcast and have them just send you a modem, rather than a gateway. Next option would be to connect a switch to the Comcast to get more Eth ports if you need that many.


Successfully Trolled by Megalith
Jul 18, 2010
Contact Comcast and ask them to place your modem/router device in bridge mode.