Help with blocking auto-play of videos on Android?

Discussion in 'Smart Phones and Devices' started by DaRuSsIaMaN, Dec 10, 2018.

  1. DaRuSsIaMaN

    DaRuSsIaMaN [H]ard|Gawd

    Messages:
    1,192
    Joined:
    Apr 22, 2007
    Ugh. I'm using FF on Android. All the solutions I've so far found online seem to only work on the desktop version but not on my mobile. For example I tried adding the Disable HTML5 Autoplay extension, as recommended in this thread on the Mozilla forum:
    https://support.mozilla.org/en-US/questions/1224795
    Didn't work.

    Btw, this is an example of a site that keeps playing video:
    https://www.cnet.com/news/why-some-...0-p20-pro-mate-10-pro-phones-arent-in-the-us/

    On my desktop, I don't even have to do anything -- all my about:config settings are at default, and nothing plays automatically when I visit that site. On mobile, I tried changing 3 different settings that come up when searching "media.autoplay", and nothing helps so far. I have:

    media.autoplay.enabled: false
    <-- the most obvious one that should kill it
    media.autoplay.block-webaudio: false <-- I would be satisfied if it at least doesn't blare sound randomly...
    media.autoplay.ask-permission: true

    It looks like none of these have any impact on that stupid video on that page. Wtf is the point of these about:config things if they don't even do anything?? What else can be done? Should I just give up and switch to a different browser? Is there one that is 100% fail-safe with this? This shit is driving me nuts.
     
  2. Supersnake

    Supersnake Gawd

    Messages:
    764
    Joined:
    Dec 23, 2007
    DaRuSsIaMaN likes this.
  3. DaRuSsIaMaN

    DaRuSsIaMaN [H]ard|Gawd

    Messages:
    1,192
    Joined:
    Apr 22, 2007
    Thanks! I would prefer to use FF, as Google is already pretty much a monopoly, and I would rather support their competitors, other things being (more or less) equal. But if necessary I'll resort to Chrome, so that's good to know that at least one option exists.
     
    Supersnake likes this.
  4. celwin

    celwin Gawd

    Messages:
    985
    Joined:
    Oct 18, 2006
    This doesn't work. CNN and some other news sites still automatically plays videos. It's never worked universally
     
  5. FSCDiablo

    FSCDiablo Limp Gawd

    Messages:
    214
    Joined:
    Jul 3, 2003
    Settings > Advanced > Block Autoplay

    Testing the sites linked above by turning that option off/on works perfectly for me.
     
    Climber likes this.
  6. Supersnake

    Supersnake Gawd

    Messages:
    764
    Joined:
    Dec 23, 2007
    In Android Chrome version 71.0.3578.99 the path is Chrome > Settings > Advanced > Site settings > Media > Autoplay [toggle to Blocked]
     
    GoldenTiger likes this.
  7. Supersnake

    Supersnake Gawd

    Messages:
    764
    Joined:
    Dec 23, 2007
    GoldenTiger and DaRuSsIaMaN like this.
  8. DaRuSsIaMaN

    DaRuSsIaMaN [H]ard|Gawd

    Messages:
    1,192
    Joined:
    Apr 22, 2007