HBA errors on OmniOS ZFS install

TechTrend

n00b
Joined
Aug 29, 2011
Messages
15
I am using a Dell C2100 server for ZFS using the napp-it all in one install with OmniOS (thanks, Gea!). The HBA is a Dell Perc H310 (LSI2008) flashed with Dell's IT firmware. The drives are four Samsung 840 1TB SSDs in a pool with two 2-drive mirrors (2x2). A similar config with mechanical drives has worked well for over a year. In this case VMs can read and write to the iSCSI LUNs but 'dmesg' periodically reports errors when accessing the adapter.

Code:
Feb  4 11:43:02 san2 scsi: [ID 107833 kern.notice] /pci@0,0/pci15ad,7a0@16/pci1028,1f1c@0 (mpt_sas0):
Feb  4 11:43:02 san2       Aborted_command!

This leads to periodic disk hard errors when there is active I/O. An old ZFS thread on a similar issue suggested checking 'sasinfo hba-port -vly' and it does shows link errors on the last ID (copy below). I pulled the server offline for now. Would this indicate a hardware issue with the HBA or could this be caused by configuration issues? Any suggestions would be appreciated. Thanks.

Code:
# sasinfo hba-port -vly
HBA Name: SUNW-mpt_sas-0
  HBA Port Name: /dev/cfg/c3
    Type: SAS Device
    State: online
    Local SAS Address: 5d4ae520b19b3400
    Attached SAS Address: 500065b36789abff
    Number of Phys: 6
    Phy Information:
      Identifier: 0
        State:  enabled
        HardwareLinkRate(Min/Max): 1.5Gbit/6Gbit
        ProgrammedLinkRate(Min/Max): 1.5Gbit/6Gbit
        NegotiatedLinkRate: 6Gbit
        Link Error Statistics:
            Invalid Dword: 0
            Running Disparity Error: 0
            Loss of Dword Sync: 0
            Reset Problem: 0
      Identifier: 1
        State:  enabled
        HardwareLinkRate(Min/Max): 1.5Gbit/6Gbit
        ProgrammedLinkRate(Min/Max): 1.5Gbit/6Gbit
        NegotiatedLinkRate: 6Gbit
        Link Error Statistics:
            Invalid Dword: 0
            Running Disparity Error: 0
            Loss of Dword Sync: 0
            Reset Problem: 0
      Identifier: 2
        State:  enabled
        HardwareLinkRate(Min/Max): 1.5Gbit/6Gbit
        ProgrammedLinkRate(Min/Max): 1.5Gbit/6Gbit
        NegotiatedLinkRate: 6Gbit
        Link Error Statistics:
            Invalid Dword: 0
            Running Disparity Error: 0
            Loss of Dword Sync: 0
            Reset Problem: 0
      Identifier: 3
        State:  enabled
        HardwareLinkRate(Min/Max): 1.5Gbit/6Gbit
        ProgrammedLinkRate(Min/Max): 1.5Gbit/6Gbit
        NegotiatedLinkRate: 6Gbit
        Link Error Statistics:
            Invalid Dword: 0
            Running Disparity Error: 0
            Loss of Dword Sync: 0
            Reset Problem: 0
      Identifier: 4
        State:  enabled
        HardwareLinkRate(Min/Max): 1.5Gbit/6Gbit
        ProgrammedLinkRate(Min/Max): 1.5Gbit/6Gbit
        NegotiatedLinkRate: 6Gbit
        Link Error Statistics:
            Invalid Dword: 0
            Running Disparity Error: 0
            Loss of Dword Sync: 0
            Reset Problem: 0
      Identifier: 5
        State:  enabled
        HardwareLinkRate(Min/Max): 1.5Gbit/6Gbit
        ProgrammedLinkRate(Min/Max): 1.5Gbit/6Gbit
        NegotiatedLinkRate: 6Gbit
        Link Error Statistics:
            Invalid Dword: 59999356
            Running Disparity Error: 46775556
            Loss of Dword Sync: 0
            Reset Problem: 0
 
The 'sasinfo hba-port -vly' on the server with mechanical drives shows 8 PHYs as expected and no errors. There may be a problem with PHY #5 on the SFF-8087 cable or the backplane. Since only 4 drives are installed and the server is remote, a temporary solution may be to disable PHYs #4 to #7 until I am back at the site to check the cable and backplane. Is there a config option to disable selected PHYs on the mpt_sas driver?
 
'lsiutil' from the link below allows disabling PHY on option #13 (Change SAS IO Unit settings). After disabling PHYs 4 to 7 there are no more "Aborted_command" messages and no hard errors on disk I/O. Will check the cabling and backplane when I am back at that site, but this allows the server to be operational now.

http://www.juhonkoti.net/media/LSIUTIL-1.63.zip
 
Last edited:
Back
Top