Has anyone Gotten the latest ATI driver and Xorg 6.8.1 to work?

Neocorteqz

2[H]4U
Joined
Mar 24, 2001
Messages
2,051
Just wondering, I've tried al sorts of voodoo to get them working on Gentoo, and still no luck, this has even caused me to bork the kernel.

No big deal though I wanted to reinstall Gentoo anyways. :p :D
 

sc3252

Gawd
Joined
Jan 3, 2005
Messages
680
have you ever installed the ati drivers prior to xorg 6.8. Also what kernel are you using? I am just going to assume you have the kernel source installed since it is gentoo. What part are you getting stuck on?
 

Neocorteqz

2[H]4U
Joined
Mar 24, 2001
Messages
2,051
sc3252 said:
have you ever installed the ati drivers prior to xorg 6.8. Also what kernel are you using? I am just going to assume you have the kernel source installed since it is gentoo. What part are you getting stuck on?
yeah i had the kernel sources installed.

When I first installed the system it installed Xorg 6.7.x when i emerged ati-drivers and ati-drivers-extra. But i upgraded after emerging kde 3.3.2, I wanted to make sure i could get into KDE before I messed around with driver and xorg updates.

as for the kernel I'm using 2.6.10-r1 (gentoo-dev-sources).

I'm about to reinstall Gentoo because of a problem where i couldn't rescue gentoo. So I'll find out if they work with Xorg 6.7.x on a default install and go from there. but as you asked here is where the hang is.

The main part I kept getting stuck on was when i ran Fglrxconfig, I couldn't boot into a gui after i restarted, this was due to having the wrong module loaded, I had loaded ati-agp instead of intel-agp, as i was told on gentoo.org,
the other problem that came up was it couldn't load the keyboard module, Now I changed it from keyboard to kbd like instructed only to have it still not boot into a gui. That's the only other hang up i had. I was told it had to be Kbd (case matters), but i never got to check that because after recompiling the kernel to add a few modules, i came up with an error, I don't think it had anything to do with the kernel size, but some kind of error like that.

I just wanted to know if anyone has gotten them to work with xorg 6.8.1.902 (which is the latest release on portage), before i went ahead and updated to 6.8.1 from 6.7.x.
 

sc3252

Gawd
Joined
Jan 3, 2005
Messages
680
I havent got it working personaly since i am using debian, but at rage 3d post 39 of this thread claims to have got it working http://rage3d.com/board/showthread.php?t=33800070&page=2&pp=30
but notice how he states that you need to change the keyboard in xorg. But what also concerns me is that you were running the 2.6.10 kernel, from what i have read you need to patch fglrx drivers. I would look to rage3d linux forum for more information on that.
 

Neocorteqz

2[H]4U
Joined
Mar 24, 2001
Messages
2,051
I've done that, didn't help any. But then again it could have been because of the wrong module loaded.

I never had this problem with Mandrake 10.1 or 10.0. But hell, it's not a big deal. Least i'm learning something.

Anyone else have any ideas?
 
Top