Gigabit only connecting at 100mbps?


Nov 9, 2009
OK so here is the situation...

I have two PCs. A laptop (Sony VAIO E Series) and a desktop connected to a D-Link DGL-4500 via CAT5e ethernet cables (~100ft and ~10ft respectively). They connect at 1.0Gbps perfectly fine before but somehow today when I tried copying over ~70GB of media it was going slower than usual. I checked the transfer speeds and lo-and-behold it was topping at ~10MBps. I then checked in Network Connections (btw, both PCs are running Win7 x64) and the speed was at 100Mbps. I was baffled?!

What DOESN'T work (aka: What I've already tried):
(a) First step, always suspect the cables... I tried the said cables used in the setup on other machines and they worked fine; connected at 1Gbps. I even tried new cables on the laptop and desktop and still they connect at 100Mbps.
(b) The Switch (Router)... I've tried nearly every port on this switch to no avail. I've reset the switch several times, and everything just re-establishes its connection at the same speeds. Also, I ensured the PCs were off (and tried it with them on as well) when resetting the switch so when it did get to Windows, it would (hopefully) negotiate at the speed I wanted... It didn't...
(c) The OS...All settings on both PCs are identical (DHCP, auto-neg. connection speed, etc.). I dual boot the laptop into Ubuntu and run several tests from that, but it still only detects 100Mbps Full Duplex as the max connection speed. To me, this ruled out the OS.
(d)(1) Software/Settings... On ALL PCs, under the Advanced tab in the adapter properties from the Device Manager, the Speed & Duplex is set to Auto Negotiation. In dropping this down, it doesn't give me an option for 1.0Gbps. I've gone as far as manually adding this in the registry under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972 [etc.]\0004 [network adapter in question] *SpeedDuplex key to 5, then to 6, and even tried to add them under the above tree \Ndi\params\*SpeedDuplex as 1.0Gbps. Still only connects at 100Mbps, although I can select 1.0Gbps in the Speed & Duplex drop down now (small 'victory', but it amused me nonetheless...) Oh, and yes, I rebooted each time in between.
(d)(2) Also, on all PCs I've completely disabled any type of low power mode the PCs may want to put PCIe/network adapter devices into.
(e) Drivers... Turns out my laptop installed an updated driver on 11/20/2009 for my network adapter. I knew it was a small chance seeing as how multiple PCs can't connect, but I rolled back the driver to the previous one, completely removed it all together and re-installed the ORIGINALS from the manufacturer, and re-updated it using both drivers from Realtek (network chipset), and just letting Windows automatically grabbing "the best drivers available" from the internet. No dice on ANY of these.

Sorry if this all seems a bit long winded. Like I said, I've trolled the internet for a solution and racked my brain for FAR too long for this not to work. PLEASE HELP!!!

EDIT: Oh, one last thing I tried (again, something I knew wasn't going to work, but I want to cover ALL bases): I ran a netsh interfaces ipv4 reset as well. Didn't help, obviously....
Probably the actual port on the notebook. If one of the pins that is used for Gb but not 100Mb may be bad or not making contact.
Probably the actual port on the notebook. If one of the pins that is used for Gb but not 100Mb may be bad or not making contact.

^ This

also. The only other 2 suggestions that I have are to pull the AC adapter and battery out of the notebook and then hold the power button in for 15 seconds, then reassemble. And the other is to try a Cat6 cable instead of a 5e. Most other possibilities you've tested already.
just buy a few $3 8-foot cables that you know are good, removing the cable possibility from the equation. just because it works in another computer doesnt necessarily mean it is good.

if your software settings havnt changed, its most likely going to be a hardware thing. most likely the cable, or possibly the network adapter at some point in the line is dying.