Games creating weird color profile

Discussion in 'Displays' started by Darkstar87, Oct 3, 2015.

  1. Darkstar87

    Darkstar87 n00b

    Messages:
    22
    Joined:
    Sep 12, 2015
    Not sure this is the right section but I have noticed in some games that the image looks awful the colors are all washed out and dull looking. I went through my monitor presets and it's not using any of them and everytime alt+tab out of game and go back into the game it gets rid of my monitor setting (Color Temp. 6500k on Dell U2515)

    Also when leaving the effected games it applies the problem to my desktop!


    I thought it may be a Nvidia driver problem, so I installed an older version and it's happening on that too.
     
  2. Darkstar87

    Darkstar87 n00b

    Messages:
    22
    Joined:
    Sep 12, 2015
    It does seem to be an Nvidia driver issue after all.. anyone else getting this problem though?


    Current Nvidia driver is 355.98

    I went back one update to 355.82 and the issue persists

    So I tried 352.84 and it's working fine
     
  3. Polar_Fox

    Polar_Fox Limp Gawd

    Messages:
    226
    Joined:
    May 7, 2015
    Ask direct x and game developers why it's happening and will it ever end.

    There's a command in direct x that either resets gpu lut or ignores icc profile entirely, it's made to implement their own shitty gamma/black levels sliders in game's menu.

    Solutions: 1 run video games in borderless windowed mode. 2 Use 3d lut injector. 3 Buy a monitor with a hardware lut.

    Now, if you are talking about your monitor's 6500k preset in the OSD menu resetting....then this is a totally strange behavior and I don't really know, try disconnecting the uplink usb from it, maybe, so the dell software doesn't communicate with it if you have any installed.:eek:
     
  4. Darkstar87

    Darkstar87 n00b

    Messages:
    22
    Joined:
    Sep 12, 2015
    I'm talking about the 6500k preset and all my OSD menu presets.

    Some games are giving a terrible bland look and I then have to enter the OSD menu and select the preset to apply it...

    Then if I alt tab out of game, and go back in it reverts back to the bland image and I have to go through the OSD menu again.


    I just installed an old Nvidia driver and no issues anymore so far so I guess the problems been resolved.

    Anyone else having this problem with the last few Nvidia drivers?

    I'm using a GTX670.
     
  5. TheManko

    TheManko [H]Lite

    Messages:
    122
    Joined:
    Jun 13, 2004
    Is this when you're running in non-native resolutions? I have this problem on my Benq BL3201PT, where running it at 1080p defaults to 16-235 (aka limited dynamic range), as Nvidia all of a sudden thinks the monitor is a HDTV. The way to fix this is to go to the resolution settings in the Nvidia control panel, change resolution to the one you're using in games, like 1080p for example, and then make sure "output dynamic range" is set to full. On the BL3201PT it correctly detects 3840x2160 as full dynamic range, while 1080p defaults to limited. This is because Nvidia has two different categories of resolution, one which is "PC" resolutions, and the other "HD" resolutions. On some monitors like the Dell S2715H Nvidia always incorrectly identifies it as a HDTV and sends a horrible washed out signal, forcing me to change it manually to full dynamic range in the resolution settings.

    Or you could be having a completely different issue!
     
  6. Darkstar87

    Darkstar87 n00b

    Messages:
    22
    Joined:
    Sep 12, 2015

    No it happens at native resolution. It ignores my monitor color settings like color temp, custom color, movie, standard, multimedia etc

    So when I load up a game, like Battlefront's Beta the colors look awful

    I then have to go into menu settings and set the color preset mode to get it look good

    Then if I alt tab to desktop, it loses that preset...
     
  7. Darkstar87

    Darkstar87 n00b

    Messages:
    22
    Joined:
    Sep 12, 2015
    I wish I knew what was going on


    Now for whatever reason when I log into windows its using the standard preset instead of the 6500k color temp I had selected..


    [update]
    I just reset my monitors settings and windows color calibration and now im not having any issues at all..





    [update2]



    It's acting up again, it's reverting to standard preset..

    However I noticed if I go custom color and set something really noticeable like RGB 100, 0, 100

    It stays at that, doesn't go back to the standard color..


    Any ideas people?
     
    Last edited: Oct 12, 2015
  8. Darkstar87

    Darkstar87 n00b

    Messages:
    22
    Joined:
    Sep 12, 2015
    I thought it was changing to the standard present but actually its not, its similar to it though
     
  9. Colonel Sanders

    Colonel Sanders 2[H]4U

    Messages:
    3,889
    Joined:
    Sep 26, 2001
    So what is it actually doing then?
     
  10. Darkstar87

    Darkstar87 n00b

    Messages:
    22
    Joined:
    Sep 12, 2015
    Game mode stops it from changing but the colors suck
     
  11. Colonel Sanders

    Colonel Sanders 2[H]4U

    Messages:
    3,889
    Joined:
    Sep 26, 2001
    I have never ever seen Windows somehow take direct control of a monitor's OSD settings...
     
  12. baii

    baii Limp Gawd

    Messages:
    165
    Joined:
    Jan 21, 2012
    It can in practice, DDC/CI .
     
  13. Darkstar87

    Darkstar87 n00b

    Messages:
    22
    Joined:
    Sep 12, 2015
    Not sure what DDC/CI is but I've just turned it off, i'll let you know if it still does it.
     
  14. Darkstar87

    Darkstar87 n00b

    Messages:
    22
    Joined:
    Sep 12, 2015
    Since disabling the DDC/CI I had no problems, kept on going in and out of game and no change in color profile to games or desktop

    Its been fine for hours


    Now for some reason its doing it again



    Just when I thought I had it fixed...
     
    Last edited: Oct 15, 2015
  15. Darkstar87

    Darkstar87 n00b

    Messages:
    22
    Joined:
    Sep 12, 2015
    Changing the resolution in either nvidia control panel, or windows settings ignored my monitors OSD color settings

    It doesn't always do this it's erratic with everything

    I went ages yesterday alt tabbing out of a game with no issues and now its doing it all the time
     
  16. bcham

    bcham Limp Gawd

    Messages:
    144
    Joined:
    Mar 23, 2007
    i am a dell u2515h owner and i have noticed when gaming,and then exiting game back to desk top. my desk top colors are all washed out, but if i go to ati control panel and move any slider they come back instantly.?
     
  17. jcvjcvjcvjcv

    jcvjcvjcvjcv Gawd

    Messages:
    703
    Joined:
    Sep 28, 2007
    Allows more functions of the monitor to be changed by the computer. For example; brightness. You could use this to adjust brightness of the backlight based on time of day etc.

    Or to swap from one "profile" to the other when launching certain applications.

    Example; Dell U3014; when lauching a game, you could use DDC/CI (Dell provides a tool) to set the monitor to Game Mode so the inputlag is gone. When not gaming, one might prefer the "Standard" profile to take advantage of better colors.
     
  18. Darkstar87

    Darkstar87 n00b

    Messages:
    22
    Joined:
    Sep 12, 2015
    It's been fine for a day or so now...

    So I figured something must causing it.




    I was playing a game, went through the monitor OSD menu presets and selected standard. I then went back to custom color. I alt tabbed out of game and now I have the ugly color profile...



    Could selecting standard standard mode being causing this?

    Here is the odd part. I left the game, selected my custom color. Restarted PC, and it's giving me the messed up colours!

    Now I'm trying to figure out how to fix that....


    Strange behaviour is there anything in color management setting in windows that could be doing it?



    [update]

    I tried custom color (using 98,94,99) rgb, restarted PC and its ignoring that color profile..

    Tried 6500k, and it's doing the same...

    went for a crazy custom color (98,20,99) and stayed like that after restarting the PC

    Wtf
     
    Last edited: Oct 19, 2015
  19. Darkstar87

    Darkstar87 n00b

    Messages:
    22
    Joined:
    Sep 12, 2015
    [EDIT]

    Oops double post
     
  20. jcvjcvjcvjcv

    jcvjcvjcvjcv Gawd

    Messages:
    703
    Joined:
    Sep 28, 2007
    Are you doing the custom color on the monitor itself or on the PC?

    Do you have anything under "Color Management" in Windows?

    What version of Windows are you running? If W10, I'm out of here; waste of time.
     
  21. Darkstar87

    Darkstar87 n00b

    Messages:
    22
    Joined:
    Sep 12, 2015
    Windows 10


    I'm selecting the color presets on the monitor itself


    Its worse now, everytime I restart my PC it's ignoring my preset

    At first it was just doing it with games, but even then I had an entire day of playing it didn't change at all!

    Now even if i restart my pc it ignores my the preset I set my monitor too..


    Haven't done anything to color management

    all I need to do now is try on another PC I suppose..


    Damn this is annoying, this is my 2nd Dell I've owned the first the power button went

    I better get on the Dell forums and ask them
     
  22. Darkstar87

    Darkstar87 n00b

    Messages:
    22
    Joined:
    Sep 12, 2015
    The standard preset is causing it somehow I don't understand why..

    I had it set on custom color, everything looked as it should


    Used the OSD and went on Standard preset, but didn't actually confirm it but cancelled which reverts back to the custom color of course..

    Restarted my PC, and now I have the mysterious color profile