Frequent frame drops with vsync.

Discussion in 'Video Cards' started by viivo, Jan 6, 2020.

  1. viivo

    viivo [H]ard|Gawd

    Messages:
    1,438
    Joined:
    Sep 7, 2005
    Scenario - FFXIV
    Vsync on: 99 FPS, 98, 100, 99, 96, 98, 99, 97, 99, etc. Micro stutters galore.
    Vsync off: 200+ FPS, but unbearable tearing.
    Same in both borderless and exclusive.

    What is the reason for this and is there a workaround that will not introduce screen tear? Freesync is not an option due to the excessive flickering.

    Win10 x64 1909
    8700K
    32GB 3600 C16
    5700 XT
    Game installed on nvme drive
     
  2. Armenius

    Armenius I Drive Myself to the [H]ospital

    Messages:
    20,005
    Joined:
    Jan 28, 2014
    Turn V-Sync off, use FRTC to limit framerate to your monitor's refresh rate.
     
    HAL_404, Mega6, viivo and 1 other person like this.
  3. pendragon1

    pendragon1 [H]ardForum Junkie

    Messages:
    15,280
    Joined:
    Oct 7, 2000
    make sure the enhanced sync settings are off in amd control panel. i had an issue like that in rdr2 after installing the last driver update. turning it off fixed it.
    or try what Arme said.
     
    viivo and Armenius like this.
  4. Armenius

    Armenius I Drive Myself to the [H]ospital

    Messages:
    20,005
    Joined:
    Jan 28, 2014
    Isn't Enhanced Sync AMD's version of Fast Sync? It wouldn't do anything unless the framerate was above the refresh rate and isn't ideal unless the framerate is something like double the refresh rate.
     
  5. pendragon1

    pendragon1 [H]ardForum Junkie

    Messages:
    15,280
    Joined:
    Oct 7, 2000
    idk but i do know that even while showing a locked 60fps rdr2 stuttered like mad with it on and its on by default now.
     
    Armenius likes this.
  6. Furious_Styles

    Furious_Styles [H]ard|Gawd

    Messages:
    1,521
    Joined:
    Jan 16, 2013
    After reading I think you're right here.

    That game's engine is broken so I wouldn't base much off it.
     
    viivo and Armenius like this.
  7. pendragon1

    pendragon1 [H]ardForum Junkie

    Messages:
    15,280
    Joined:
    Oct 7, 2000
    i guess maybe it could fuck with the physics and cause stutter. either way, if its on its a mess for me and its a suggestion for op to try. you got one?
     
  8. Furious_Styles

    Furious_Styles [H]ard|Gawd

    Messages:
    1,521
    Joined:
    Jan 16, 2013
    If he can't do what armenius suggests I'd try a different amd driver version I guess.
     
  9. pendragon1

    pendragon1 [H]ardForum Junkie

    Messages:
    15,280
    Joined:
    Oct 7, 2000
    wouldnt it be simpler to turn this off first and try? then if that isnt the issue yes frame rate limit it, rtss or even in amd drivers.
     
  10. viivo

    viivo [H]ard|Gawd

    Messages:
    1,438
    Joined:
    Sep 7, 2005
    Thanks for the replies. I've always left disabled Enhanced Sync, Anti-Lag, and similar features. At first I thought it was just FFXIV, but I notice the stutter in ESO, No Man's Sky, Dying Light, and other games that require lots of camera movement which highlights framerate drops and frametime issues. The problem is that to me the lack of smoothness is so noticeable and distracting that it's hard to focus on anything else while playing.

    I will do some testing with FRTC. I've avoided it because it was said to dramatically increase input lag. If that doesn't work I'll have to give RTSS' scan line sync another try.
     
  11. Furious_Styles

    Furious_Styles [H]ard|Gawd

    Messages:
    1,521
    Joined:
    Jan 16, 2013
    Sure I suppos
    Just as a double-check have you used AB or equiv. and seen if you're having any weird CPU % spikes/drops or just something unusual with another component? Is W10's game-mode or whatever turned off?
     
    viivo likes this.
  12. viivo

    viivo [H]ard|Gawd

    Messages:
    1,438
    Joined:
    Sep 7, 2005
    No Afterburner. I've not seen any CPU utilization strangeness in HWINFO64 or perf. monitor. Game mode and all the DVR stuff is disabled via group policy and all games have "disable fullscreen optimizations" checked.

    edit: Now that I think about it, I do sometimes notice that my CPU isn't boosting properly. Normally HWINFO will report when a single core has boosted to 4.6, but sometimes the max clocks of all cores remains at 4.4 even after many hours of use.
     
  13. Furious_Styles

    Furious_Styles [H]ard|Gawd

    Messages:
    1,521
    Joined:
    Jan 16, 2013
    Hmmm that should be investigated. Also have you already done a DDU wipe and driver re-install? It's good to just rule stuff out when these weird issue crop-up.
     
    viivo likes this.