• Some users have recently had their accounts hijacked. It seems that the now defunct EVGA forums might have compromised your password there and seems many are using the same PW here. We would suggest you UPDATE YOUR PASSWORD and TURN ON 2FA for your account here to further secure it. None of the compromised accounts had 2FA turned on.
    Once you have enabled 2FA, your account will be updated soon to show a badge, letting other members know that you use 2FA to protect your account. This should be beneficial for everyone that uses FSFT.

Freenas Guys ? Question about ZFS

dashpuppy

Supreme [H]ardness
Joined
May 5, 2010
Messages
6,163
ok, so i got my new 1U server running. Stuffed in 4 160 gig drives for learning on and stuff. today i got a notification that the storage is degraded due to a failing drive.

My question is, when rebooting changing the drive does freenas automatically rebuild ? Do i need to do anything ? i rebooted and changed out the drive for a identical one the notification was red but now its green stating its helthy.

This is my learning box to screw around with and learn on till boxing day when i order my 4 x ( what ever size ) drives for my proper setup. So for now im taking the time to move my vm's over to it over iscsi, and see how she performs ( yes ill back it up every day ) but for now i want to see how everything comes together and works, if it fails then id like it to fail now that im in the learning stages of this.

After 2 weeks of working on this new server making it quieter etc etc, removed the 3 noisy ass server fans and replaced with better ones, now its quieter and tolerate able.


Little storey on this asus server, drives don't go 1-2-3-4

it goes 1b 2a 1b 2b found this out the hard way trying to figure out what drive was dead, as i changed the drive and it kept saying drive failed, at first i thought it might be the back-plane. but reading the book and noticed how it says master and slave drive when booting and showing the drives, i figured it out. they are not in order left to right * up down in bios list *

The new server is a 1u * quietn'd * core 2duo 4 gigs ram and 4 hot swappable 160 gig drives 2 gigabit ethernet cards :)

suggestions ?


Next after this, to figure out what drives to buy, ? suggestions on that too ? i was told to stay awy from the WD green's in a zfs / raid array so now to look for 1.5tb drives etc etc. When i buy the ill buy 5 one for spare on hand.

Dash.
 
im not really sure what your asking. that whole post is fairly convoluted. are you asking if the zpool will auto resilver a disk?

if you're using raw drives with no gpt or geom partition or label then yeah swapping the disk probably will auto repair. if you're using geom or gpt though the process is manual since the pool is built on the partition.

since you're using WD greens for best performance you're going to be forced to use gpt or geom and the gnop tool to attain the 4k offset.
 
im not really sure what your asking. that whole post is fairly convoluted. are you asking if the zpool will auto resilver a disk?

if you're using raw drives with no gpt or geom partition or label then yeah swapping the disk probably will auto repair. if you're using geom or gpt though the process is manual since the pool is built on the partition.

since you're using WD greens for best performance you're going to be forced to use gpt or geom and the gnop tool to attain the 4k offset.

i'm not using wd greens, i was told to stay away from them in any raid / zfs configuration.


My question was, if a drive fails i put in a new one boot the machine will free nas rebuild it or is it manual ? trying to decide if i need or should stick with freenas or move to win 2008r2 storage server..
 
As far as I know, you need to add that drive to the pool to replace the dead/removed one.
 
if you're even considering a windows solution over bsd/zfs just go with the windows solution.
 
ZFS won't have any information on what you want to do with that drive. It doesn't really identify drives by slots/bays, so you will have to tell it to use the replacement manually, and possibly remove the failed drive manually as well.
 
because anyone who is still considering windows storage server after using zfs likely isn't going to have a good experience the moment anything goes wrong that a gui can't fix.
 
points at server >> its running right now with iscsi 4 x 160 gig hdd's using the zfs pool option.

im trying to learn how and what to do when it fails, so when i install the new 4 x drives i know what os im going to be running etc etc etc.

Right now this is a learning box to see and learn on what to do when it fails / has problems..

It's in a home environment so nothing critical, but don't want to loose data.

I have the option t use 2008r2 storage server OR freenas..
 
pull the drive (power on if you powered off) and type

zpool replace 'poolname' path/to/drive

if freenas throws a partition in there though you may want to add a partition so the drive is consistent with the others. i forget if freenas does or doesnt do that.
 
pull the drive (power on if you powered off) and type

zpool replace 'poolname' path/to/drive

if freenas throws a partition in there though you may want to add a partition so the drive is consistent with the others. i forget if freenas does or doesnt do that.

it's working but i didn't use your command yet..
 
Back
Top