folder sharing question.

Discussion in 'Networking & Security' started by Bigbacon, Jul 19, 2017.

  1. Bigbacon

    Bigbacon [H]ardForum Junkie

    Messages:
    15,980
    Joined:
    Jul 12, 2007
    ok...how in the world do I share a folder on a windows 10 PC so that I can copy files from one machine to that one without need to supply a log in?
     
  2. Cmustang87

    Cmustang87 [H]ardness Supreme

    Messages:
    4,405
    Joined:
    Oct 4, 2007
    By default, shared folders only have read permissions for everyone. If you are trying to write to the other computer, it will require you to authenticate with a local account on that machine unless you change the permissions to allow everyone to write. I don't recommend you do this, however, as it is against most standard security practices. Things can get a little trickier if you are using Microsoft accounts as it won't use the typical <hostname>\username for authentication.
     
  3. Bigbacon

    Bigbacon [H]ardForum Junkie

    Messages:
    15,980
    Joined:
    Jul 12, 2007
    folder is set to EVERYONE with full access. Don't care about standards. Still prompts me for credentials.
     
  4. Cmustang87

    Cmustang87 [H]ardness Supreme

    Messages:
    4,405
    Joined:
    Oct 4, 2007
    Are you changing the share permissions or the NTFS permissions? There are two permission sections.
     
  5. bman212121

    bman212121 [H]ard|Gawd

    Messages:
    1,533
    Joined:
    Aug 18, 2011
    Yea I don't know if I've ever successfully gotten around that little nag issue myself. With Windows 7 it seemed like it would let you open up a specific folder and with both NTFS permissions set for everyone and sharing set for everyone, it would go through. Windows 8.1 and up definitely likes to ask you regardless of that particular share. The easiest way I know is to just create the user account you're logged into on both pcs with the same password. So if computer A has the share, you need to make an account on computer A that uses the same user / password combo you're using to login to computer B with. Once you do that Windows will automatically try using those credentials and it will succeed. I think the issue really comes down to the fact that whenever you go to access the share in the first place, Windows attempts to login to that share with your current user credentials instead of just trying to do an anonymous login first. (Or just doesn't attempt to do anonymous logins at all anymore)
     
  6. Brian_B

    Brian_B 2[H]4U

    Messages:
    3,356
    Joined:
    Mar 23, 2012
    I've had horrible luck since Win8 with SMB/Windows Sharing. Seems like once they added that Homegroup option - even if you don't use it, it screws everything up.

    I end up passing everything back and forth via a shared folder on a NAS, because I can't get Windows to reliably talk directly to another Windows PC without authentication/permission issues.
     
  7. Mackintire

    Mackintire 2[H]4U

    Messages:
    2,892
    Joined:
    Jun 28, 2004
    You're seeing that prompt because you did exactly what I recommend to users to do.... but you forgot the NTFS security part which is why you are still being prompted.

    Remember as Cmustan87 said "There are two permission sections."

    Share permissions (which limit access to the share itself )
    NTFS permissions (which limit access to the files/folders which the share is pointed to, using local or domain accounts)


    Normally I'd suggest just Adding "everyone" to the share permissions, and explicitly only adding the people you want to give access to in the NTFS security section.



    Brian_B Other than what I posted above the other small detail is computer network location setting.

    If it is set to "Public Network" file sharing and computer discovery is turned off, Homegroup can be forced on, but won't work.
    If it is set to "Domain Network" file sharing and computer discovery is turned on, but Homegroup is forced off.
    If it is set to "Private Network" file sharing and computer discovery should be turned on and Homegroup should work.

    Once you have the Network Location setting correct you can examine the adv settings located: Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings

    (AFTER fixing your Network location setting) --->In this section If you want to share files, make certain File and Printer sharing is on. <---(AFTER fixing your Network location setting)
     
  8. MrTroy03

    MrTroy03 Limp Gawd

    Messages:
    422
    Joined:
    Feb 12, 2008
    On top of having the "Security" tab (NTFS) set to "Everyone Allow Read" and the Share permissions set to "Everyone Allow Read", you need to do this:

    1. Network And Sharing Settings
    2. Click on Change Advanced Sharing Settings
    3. Under Private (assuming your set to Private) area...
      1. File And Printer Sharing: Turn on file and printer sharing.
      2. HomeGroup connections: Use user accounts and passwords to connect to other computers.
    4. Click Save. It will make you log out and back in.
    5. Go back to Change Advanced Sharing Settings.
    6. Under All Networks...
      1. Password protected sharing: Turn off password protected sharing.
        1. This is your issue, if this is ON, then you will need to enter credentials to get to the share, even if Everyone is allowed.
    7. Connect to the share.
    Also, make sure you have no other 3rd party software firewalls running that is blocking the connection. Temporarily disable the software firewall on both sides if the above doesn't work. By firewall I mean something like Norton firewall, Windows should open the ports in its firewall when you turn on file sharing.
     
  9. Mackintire

    Mackintire 2[H]4U

    Messages:
    2,892
    Joined:
    Jun 28, 2004
    Evidently Microsoft added another layer to this in Windows 10... If the local account offering the share is a "microsoft" account it will ignore the Turn off password Protected sharing, but won't prompt any windows 10 users who remotely attempt to connect also using a Microsoft account. Its like a hidden HomeGroup in behavior.

    Using a non Microsoft account... it works as you would expect it to.