Epson & nvidia

DrNick

Limp Gawd
Joined
Jul 19, 2006
Messages
276
Hey guys I recently picked up an Epson all in one printer and it does not seem to like nvidia very much. Since installing the Epson drivers the nvidia display driver likes to crash and recover like there is no tomorrow. Just opening a new window can make it crash and its very easy to do so if I'm messing with the printing properties.
Epson is aware of the nvidia issues going from their support response but they say there is nothing they can do and I was wondering if any of you have run into a better fix? Making a windows 7 install look like windows 2000 is not a fix imho (i have to use the default windows nvidia driver and set windows to "High Performance" which is ugly as sin)
Thanks for any tips
 

genetech

Limp Gawd
Joined
Jan 31, 2008
Messages
144
I run win 7 on all nvidia laptops and a m using an epson 810 artisan all in one and have had no crashes to speak of. must be product specific since laptops use different driver from desktop
 

rincewind

Gawd
Joined
Sep 21, 2004
Messages
888
I have an Epson 830U installed alongside my GTX260 on both XP and Vista - no problems here.
 

DrNick

Limp Gawd
Joined
Jul 19, 2006
Messages
276
I've narrowed it down to Print Preview being the issue. With that disabled all is well and I can even use the monitoring options. Only happens with nvidia cards though, everything works fine on the radeon. But I don't think I'll find something better for the price so I'll live with it:)
Thanks much guys
 

drakken

[H]ard|Gawd
Joined
Aug 19, 2004
Messages
1,196
If print preview is part of the problem, it may be a conflict with non-default print spooler. Having had to fix something similar before if you had Lexmark (includes rebranded dell printers) drivers installed at some point on the machine they usually overwrite the default ms print spooler that the Epson print drivers are looking for. The question is if they do it in win 7. Since the only way I know how to get the print spooler back is to re-install the OS, I really don't want to install Lexmark drivers to check if it breaks my machine.

I would look at the print spooler (in services) and see if it is spoolsv.exe or something else. Epson all in wonders are more temperamental than the rest of the stuff they make. My parents have a 595 and when I visited them I had to fix it only to find the issue above they had bought a cheap dell printer (rebranded lexmark) and it was messing with print spooler.

Good luck
 

DrNick

Limp Gawd
Joined
Jul 19, 2006
Messages
276
Thanks much drakken, I appreciate it. I checked and it looks like its still using the default ms print spooler. The only thing I see that Epson has added to the services is EpsonBidirectionalService.
I did get a response from Epson support and they seem to be aware of issues with nvidia drivers but they say there is nothing they can do on their end. They recommend I disable windows aero and use the default wddm driver but neither is an option.
Thanks
 
Top